WordPress.org

Make WordPress Themes

Opened 5 years ago

Closed 5 years ago

#10226 closed theme (closed-newer-version-uploaded)

THEME: Spartan - 1.0.0

Reported by: tskk Owned by: jcastaneda
Priority: Keywords: theme-spartan
Cc: tskk79@…

Description

Spartan - 1.0.0

Responsive wordpress magazine theme with 3 home page layouts, 2 page layouts including a full width page template, featured posts, social icons, twitter updates, threaded comments and widget support.

Theme URL - http://www.themealley.com/Spartan/
Author URL - http://www.themealley.com/

SVN - http://themes.svn.wordpress.org/spartan/1.0.0
ZIP - http://wordpress.org/extend/themes/download/spartan.1.0.0.zip?nostats=1

All previous tickets for this theme: http://themes.trac.wordpress.org/query?keywords=~theme-spartan

https://themes.svn.wordpress.org/spartan/1.0.0/screenshot.png

Attachments (1)

spartan-menu-css.PNG (2.8 KB) - added by jcastaneda 5 years ago.

Download all attachments as: .zip

Change History (14)

#1 @jcastaneda
5 years ago

  • Owner set to jcastaneda
  • Status changed from new to accepted

#2 @tskk
5 years ago

Thanks for the review, if there are any issues, please give me a couple of days to fix them before you close the ticket.

#3 @jcastaneda
5 years ago

About how many days would you like? Personally I'm happy with no more than three days.
One of the first things I did notice was that you have an unopened </span> tag in your single.php file. You will have to submit a new ticket anyway so if you want just post a link to the new ticket after I finish the review on the theme that way you can submit any/all fixes you may have to do. :)
Jose

#4 @tskk
5 years ago

3 days is enough, will submit a new ticket with any/all fixes after the full review :)

#5 @jcastaneda
5 years ago

Required

  • Says translation ready but I didn't see load_theme_textdomain(), a languages folder or a Text Domain declaration in style.css Language
  • Post thumbnails: I did not see the function the_post_thumbnail() see Post Thumbnails (use of core implementation)
  • HTML errors created were WordPress related except for a stray <span> tag in single.php ( post_links section )

Suggestions

  • Consider using a conditional so that way a visitor doesn't see the notice about no menu selected. current_user_can('edit_theme_options')
  • The favicon link meta tag shows up in the lite version consider removing that
  • Consider adding suport for custom-backgrounds and visual editor
  • Menu CSS. Sorry it kept bugging me because it seems to bring down the submenu by one pixel on every level as you add more levels. see attached image.

Resolution: upload-new-version

#6 @tskk
5 years ago

Hello Jose,

Will upload new version with the fixes, but theme already uses post thumbnail, line # 15 & 16 in functions.php

Tskk

#7 @jcastaneda
5 years ago

I didn't see the_post_thumbnail being used in index.php or single.php. In functions.php you are creating the support. You aren't implementing it. It would be like adding register_nav_menu and *not using wp_nav_menu in the theme. :)

Last edited 5 years ago by jcastaneda (previous) (diff)

#8 @tskk
5 years ago

i am using

wp_get_attachment_image_src( get_post_thumbnail_id($post->ID), 'Spartanthumb', false, );

in wilto-slider.php, index-mageight.php and index-magseven.php

#9 @jcastaneda
5 years ago

I missed that. My apologies. Even better two minor things to fix. :)

#10 @tskk
5 years ago

No need to apologize :)

Will fix the other issues and add custom background functionality.

New ticket coming up in few hours...

#11 @jcastaneda
5 years ago

Okay. I'll have a look tomorrow once I get home from work. :)

#13 @jcastaneda
5 years ago

  • Resolution set to closed-newer-version-uploaded
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.