WordPress.org

Make WordPress Themes

Opened 14 months ago

Closed 14 months ago

Last modified 14 months ago

#11522 closed theme (live)

THEME: Voyage - 1.1.9

Reported by: scui2 Owned by: chipbennett
Priority: Keywords: theme-voyage
Cc: scui2005@…

Description

Voyage - 1.1.9

Voyage Theme is a flexible and responsive premium theme that combines a modified version of 960.gs Grid System and Twitter Bootstrap framework. It allows users changing layout and style using flexible and simple Theme Options: 1-, 2- or 3-column blog layout; fixed, fluid or responsive; 12- or 16-column grid; grid width and many more. The Voyage Theme features 11 widget areas, 4 menu positions and 6 page templates including Featured Post, Landing Page, Featured Blog and Multi-Column Blog Summary/Portfolio with template options. The Theme includes 2 highly customizable widgets (Recent Post and Tabbed Navigation) and Integrated Jetpack Sharing. Voyage Theme supports aside, link, quote, image and gallery post format as of now. ColorBox and Font Awesome are included as a bonus.

Theme URL - http://www.voyagebc.com/voyagetheme
Author URL -

SVN - http://themes.svn.wordpress.org/voyage/1.1.9
ZIP - http://wordpress.org/extend/themes/download/voyage.1.1.9.zip?nostats=1

Diff with previous version: http://themes.trac.wordpress.org/changeset?old_path=/voyage/1.1.8&new_path=/voyage/1.1.9

All previous tickets for this theme: http://themes.trac.wordpress.org/query?col=id&col=summary&col=keywords&col=owner&col=status&col=resolution&keywords=~theme-voyage&order=id

https://themes.svn.wordpress.org/voyage/1.1.9/screenshot.png

Change History (19)

comment:1 scui214 months ago

Changes:

  • Removed shortcodes as per Guidelines
  • Changed social sharing to integrte with Jetpack Sharing.
  • Renamed home.php to front-page.php
  • All page templates use WP_Query now.
  • Minor Bug Fixes

comment:2 chipbennett14 months ago

  • Owner set to chipbennett
  • Status changed from new to assigned

comment:3 chipbennett14 months ago

  • Resolution set to approved
  • Status changed from assigned to closed

Required

  • Ensure that front-page.php accounts for user configuration of get_option( 'show_on_front' ). If Dashboard -> Settings -> Reading is set for the front page to display the blog posts index, front-page.php must respect that option.

Review Summary

  • Previous version of Theme approved
  • No previous-ticket required issues
  • Diff-review only
  • Changes as per change log
  • Theme has required issues; can be addressed in next Theme revision
  • Ticket being resolved as approved. Please address required issues in next Theme revision.

comment:4 scui214 months ago

Hi, Chip:

Appreciate your quick review. I thought I am in trouble :-) I will address the required issue in next release. Do you have a good example?

if ( 'page' === get_option( 'show_on_front' ) && get_option( 'page_on_front' ) )

return;

Stephen

Last edited 14 months ago by scui2 (previous) (diff)

comment:5 chipbennett14 months ago

One example:

if ( 'page' == get_option( 'show_on_front' ) ) {
    // STATIC FRONT PAGE OUTPUT HERE
} else {
    // BLOG POSTS INDEX OUTPUT HERE
}

The easiest way to do that with your current code:

if ( 'page' == get_option( 'show_on_front' ) ) {
    get_header();

	global $voyage_options;
	if ($voyage_options['homepage'] == 1) {
 		get_template_part( 'page-templates/featured'  ); 		
	}
	elseif ($voyage_options['homepage'] == 2) {
 		get_template_part( 'page-templates/landing'  ); 		
	}	
	elseif ($voyage_options['homepage'] == 3) {
 		get_template_part( 'page-templates/blog'  ); 		
	}
	elseif ($voyage_options['homepage'] == 4) {
		get_template_part( 'page-templates/portfolio' );
	}
	elseif ($voyage_options['homepage'] == 5) {
		get_template_part( 'page-templates/blog-sticky' );
	}

    get_footer(); ?>
} else {
    get_template_part( 'index' );
}

If you defined a home.php for the blog posts index (which is really what page-templates/blog.php should be), you could use get_template_part( 'home' ).

comment:6 follow-up: scui214 months ago

Thanks. In fact, I designed the 'homepage' option is to help users choosing different layout (page template) without creating a dummy page. I noticed that many users does not know how to do it or confused about it.

However, if they do create a page, the theme will respect the settings. I know it is a kind of out of box and it override WordPress' logic.

If it is not allowed, I will have to remove this feature and educate my users.

comment:7 in reply to: ↑ 6 chipbennett14 months ago

Replying to scui2:

However, if they do create a page, the theme will respect the settings. I know it is a kind of out of box and it override WordPress' logic.

If it is not allowed, I will have to remove this feature and educate my users.

Educating users is the best approach. The best experience we, as Theme developers, can give users is to ensure that the UI/UX stays the same from Theme to Theme, and to ensure that we're supporting the workflows that core WordPress defines. In this case, that means instructing users to create "dummy" pages. (Note that this workflow is slated for improvements.)

comment:8 scui214 months ago

Great to know. I am new to WordPress Theme. I hope to create something useful. In this case, I will modify the front-page.php as suggested and change the definition - one page multiple options:-)

Appreciate your time and I learn a lot from past days reading the emails.

comment:9 scui214 months ago

Hi, Chip: My users reported a problem after I change from home.php to front-page.php

I realized that my case should be home.php. I should not use front-page.php at first place.

Thanks.

comment:10 chipbennett14 months ago

Actually, no. The home.php is only for the Blog Posts Index page. To create a template for the site front page, you must use front-page.php.

Can you direct me to the reported problem? I can help explain how to resolve it.

comment:11 scui214 months ago

The problem: WordPress will use front-page.php if user assigned a static front page using other page template.

I already worked with my users fixed it.

I thought about. My case should be home.php. In other words, users will have 5 choices for the blog posts index. I know it will cause other problem (i.e. Blog Index if user assign a static page).

If it is NOT allowed also, I will have to remove the front-page.php.

Thanks Stephen

comment:12 scui214 months ago

Maybe even index.php?

comment:13 chipbennett14 months ago

I believe my case should be home.php. I should NOT change to front-page.php. In other words, I have multiple templates if user choose multiple blog style.

You would want the blog posts index template file to be home.php. From what I can tell, templates/blog.php is the blog posts index template.

The problem is, most of those other included templates are not the blog posts index (portfolio, landing, sticky, featured). These aren't "blog style" variations; they're custom pages.

The easiest path forward might be:

  1. Move page-templates/blog.php to the Theme root, and rename it home.php
  2. Delete front-page.php
  3. Let users assign any of the remaining page templates as the site front page, using the Page Attributes metabox for the page assigned to the front page.

comment:14 follow-up: scui214 months ago

In other words, I do lost the 'homepage' feature in theme options.

In this case, I will create a landing page + blog index page template. i.e. User will have "h1 headline" + "media box" on top, then blog index below. This is the default view when the theme is activated. You can check the view on Theme Preview in repo.

I would like to confirm before I submit the revision.

comment:15 in reply to: ↑ 14 chipbennett14 months ago

Replying to scui2:

In other words, I do lost the 'homepage' feature in theme options.

Probably so; but then, that's a core option, anyway.

In this case, I will create a landing page + blog index page template. i.e. User will have "h1 headline" + "media box" on top, then blog index below. This is the default view when the theme is activated. You can check the view on Theme Preview in repo.

I would like to confirm before I submit the revision.

As long as:

  1. If the user selects "blog posts" to display on front, the blog posts index displays
  2. If the use selects "static page" to display on front, a static page displays
  3. If the user selects "static page" to display on the front, and assigns a separate static page to display the blog posts, the blog posts display on that static page

...then you should be fine. You're welcome to customize the blog posts index; after all, that's why it has a reserved template filename. :)

comment:16 scui214 months ago

Got it. Appreciate your time. As confused as a theme developer, how about normal users? My idea was "change home page" with one option.

Anyway I would submit a revision later. Not many users use static page anyway.

Thanks

Stephen

comment:17 chipbennett14 months ago

As confused as a theme developer, how about normal users? My idea was "change home page" with one option.

Indeed. And front-page handling has been one of the most-confused aspects of Theme development and user configuration ever since front-page.php was added three years ago.

The best long-term solution is to ensure that users have the same process, no matter what Theme they use, rather than have to do things slightly (or considerably) different from Theme to Theme.

It's all about education; slowly but surely, we'll get there!

comment:18 follow-up: scui214 months ago

Hi,

I uploaded a new version. I am not asking you to review it but in case you want to take a look.

http://themes.trac.wordpress.org/ticket/11541

As for the front-page.php discussion, I still do not understand the logic. Why we even need the front-page.php as 'show_on_front' can achieve the same thing? Did I miss something?

comment:19 in reply to: ↑ 18 chipbennett14 months ago

Replying to scui2:

As for the front-page.php discussion, I still do not understand the logic. Why we even need the front-page.php as 'show_on_front' can achieve the same thing? Did I miss something?

The front-page.php template file is intended for a specific static-page layout for the site front page. In your case, you have several, optional layouts, none of which is meant as the single, specific layout for the site front page. If one of those layouts were intended as the single, specific layout for the site front page, then that template file would appropriately be named front-page.php.

Whether that template file gets used or not is pretty much up to the design intent of the developer.

Note: See TracTickets for help on using tickets.