WordPress.org

Make WordPress Themes

Opened 4 years ago

Closed 4 years ago

#13891 closed theme (not-approved)

THEME: Noble - 1.4.1

Reported by: CasBK Owned by: ZGani
Priority: previously reviewed Keywords: theme-noble
Cc: brian@…

Description

Noble - 1.4.1

A clean and elegant personal blog theme from ThemeJam.

Theme URL - http://themejam.com/wordpress-themes/noble/
Author URL - http://themejam.com

SVN - http://themes.svn.wordpress.org/noble/1.4.1
ZIP - http://wordpress.org/themes/download/noble.1.4.1.zip?nostats=1

Diff with previous version: http://themes.trac.wordpress.org/changeset?old_path=/noble/1.4&new_path=/noble/1.4.1

History:

Ticket Summary Status Resolution Owner
#13157 THEME: Noble - 1.4 closed not-approved bhadaway
#13891 THEME: Noble - 1.4.1 closed not-approved ZGani

(this ticket)

#14013 THEME: Noble - 1.4.3 closed not-approved ZGani
#14175 THEME: Noble - 1.4.5 closed live ZGani
#23225 THEME: Noble - 1.4.6 closed live emiluzelac


https://themes.svn.wordpress.org/noble/1.4.1/screenshot.png

Attachments (3)

GalleryStyling.png (289.9 KB) - added by ZGani 4 years ago.
Gallery needs styling
PostFormatVideo.png (142.4 KB) - added by ZGani 4 years ago.
Video embed overflows container
LongTitleAndContent.png (19.5 KB) - added by ZGani 4 years ago.
Long title and content overflow in Chrome

Download all attachments as: .zip

Change History (5)

#1 @ZGani
4 years ago

  • Owner set to ZGani
  • Status changed from new to reviewing

@ZGani
4 years ago

Gallery needs styling

@ZGani
4 years ago

Video embed overflows container

@ZGani
4 years ago

Long title and content overflow in Chrome

#2 @ZGani
4 years ago

  • Resolution set to not-approved
  • Status changed from reviewing to closed

General.

Required:

  • Theme url if used must link to a page/site with content specific to the theme under review - upsell or demo url are not acceptable.
  • Google Analytics are plugin territory and must not be included in themes - please remove this option.
  • Screenshot must be an actual screenshot or a facsimile of the theme on first install with default settings.
  • Themes must declare copyright/license in the following format either in the head of style.css or in the readme file:
    Themename WordPress theme, Copyright (C) 2013 YOUR NAME or YOUR COMPANY NAME
    Themename WordPress theme is licensed under the GPL.
    
  • Themes must also declare license and copyright of any resources (if not already done so in the documents head) used in constructing the theme. i.e. scripts, images and fonts in the following format:
    Resource name here - ​http://resource.url/
    License: Distributed under the terms of the License Name
    Copyright: Author, authorurl.com
    
  • As the theme seems to be a derivative of the TwentyThirteen (be it in part) this must be declared in the themes documents and a copyright/license of the original work included.

Code Check.

Required:

  • <title></title> must only contain <?php wp_title( '|', true, 'right' ); ?> with the rest of the parameters fed to it via the wp_title filter in functions.php
  • All stylesheets and scripts must be enqueued via a function callback hooked to the wp_enqueue_scripts()/wp_enqueue_styles() action.
  • wp_head(); must be immediately above the closing </head> tag
  • wp_footer(); must be immediately above the closing </body> tag
  • The term "Designed By" is not allowed as it implies the site was designed by you - use "Theme Designed By"
  • In addition the use of title="ThemeJam WordPress Themes" is considered to be SEO seeding and is not allowed - use the theme name in this place.
  • Themes must not provide backward compatibility for out-of-date WordPress versions (more than two prior major WordPress versions - currently, that means versions prior to WordPress 3.3), including using function_exists() conditional wrappers for current WordPress functions.

e.g. function_exists('register_sidebar'), if ( !function_exists('dynamic_sidebar') and if ( function_exists( 'add_theme_support' )

  • All add_theme_support, register_nav_menu, if ( ! isset( $content_width ), add_editor_style and set_post_thumbnail_size must be called from a function callback hooked to the after_setup_theme action.
  • register_sidebar must be called from a function callback and hooked to the widgets_init action.
  • Incorrect textdomain (twentythirteen) used in single.php
  • Please escape all instances of home_url(); thus esc_url(home_url('/'));

Theme Unit Test

Required:

  • Theme has Header Text Color enabled but the selected color does not apply to the Site title on the front end or in the customizer.
  • Large images in sidebar overflow their container - please see below for resources to use in order to replicate the issues
  • Select element with long string overflows container in sidebar - refer to links in resources for testing.
  • Pages must show comments and comment form if selected by the user, however they must not show the words "Comments are closed" or similar when comments are set to off.
  • Post Format: Gallery - needs styling as some images overlap in places - see attachment
  • Post Format: Gallery - single image view: please consider adding the Next/Previous image links for ease of navigation on a gallery with more than one image. See links below.

Next Image Link
Previous Image Link

  • Post Format: Video - video embed overflows its container for both WordPress.tv and YouTube codes. See attachment.
  • Post with super duper long title and non breaking text overflows its container in Chrome - see attachment.
  • Post with no title must somehow link to the single post view - the easiest way to achieve this is to wrap the permalink around the post date.
  • Single post view Previous/Next post links are too close together - please consider using float to space them out.
  • 404 does not function as it should - please look in to this.

This is not a complete review and other issues may well arise in the next review - you are therefore advised to use the following resources to check and test your theme to be sure it meets all of the current requirements.
Resources to be used for testing...
Theme Test Unit Data
Theme Review Guidelines
Monster Widget plugin
Debug Bar plugin
Log Deprecated Notices
Theme Check Plugin
Debogger Plugin

Conclusion:

Theme has major required issues that need addressing fully before it can be considered for inclusion in the repository - resolving as not approved this time round.
Please address all raised issues and re-submit for further consideration.

Note: See TracTickets for help on using tickets.