WordPress.org

Make WordPress Themes

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14013 closed theme (not-approved)

THEME: Noble - 1.4.3

Reported by: CasBK Owned by: ZGani
Priority: previously reviewed Keywords: theme-noble
Cc: brian@…

Description

Noble - 1.4.2

A clean and elegant personal blog theme from ThemeJam.

Theme URL -
Author URL - http://themejam.com

SVN - http://themes.svn.wordpress.org/noble/1.4.2
ZIP - http://wordpress.org/themes/download/noble.1.4.2.zip?nostats=1

Diff with previous version: http://themes.trac.wordpress.org/changeset?old_path=/noble/1.4.1&new_path=/noble/1.4.2

History:

Ticket Summary Status Resolution Owner
#13157 THEME: Noble - 1.4 closed not-approved bhadaway
#13891 THEME: Noble - 1.4.1 closed not-approved ZGani
#14013 THEME: Noble - 1.4.3 closed not-approved ZGani

(this ticket)

#14175 THEME: Noble - 1.4.5 closed live ZGani
#23225 THEME: Noble - 1.4.6 closed live emiluzelac


https://themes.svn.wordpress.org/noble/1.4.2/screenshot.png

Change History (8)

#1 @ZGani
4 years ago

  • Owner set to ZGani
  • Status changed from new to reviewing

#2 @ZGani
4 years ago

Required:

  • Theme url if used must link to a page/site with content specific to the theme under review - upsell or demo url are not acceptable. - Fixed by url removal.
  • Google Analytics are plugin territory and must not be included in themes - please remove this option. - Fixed.
  • Screenshot must be an actual screenshot or a facsimile of the theme on first install with default settings. - Fixed.
  • Themes must declare copyright/license in the following format either in the head of style.css or in the readme file: - Fixed.
  • Themes must also declare license and copyright of any resources (if not already done so in the documents head) used in constructing the theme. i.e. scripts, images and fonts in the following format: Fixed.
  • As the theme seems to be a derivative of the TwentyThirteen (be it in part) this must be declared in the themes documents and a copyright/license of the original work included. - Not Fixed.

Code Check.

Required:

  • <title></title> must only contain <?php wp_title( '|', true, 'right' ); ?> with the rest of the parameters fed to it via the wp_title filter in functions.php - Fixed.
  • All stylesheets and scripts must be enqueued via a function callback hooked to the wp_enqueue_scripts()/wp_enqueue_styles() action. - Not Fixed. Please remove all styles and scripts from header.php and enqueue them correctly via the functions.php
  • wp_head(); must be immediately above the closing </head> tag - Fixed.
  • wp_footer(); must be immediately above the closing </body> tag - Fixed.
  • The term "Designed By" is not allowed as it implies the site was designed by you - use "Theme Designed By" - Fixed.
  • In addition the use of title="ThemeJam WordPress Themes" is considered to be SEO seeding and is not allowed - use the theme name in this place. - Fixed.
  • Themes must not provide backward compatibility for out-of-date WordPress versions (more than two prior major WordPress versions - currently, that means versions prior to WordPress 3.3), including using function_exists() conditional wrappers for current WordPress functions.

e.g. function_exists('register_sidebar'), if ( !function_exists('dynamic_sidebar') and if ( function_exists( 'add_theme_support' ) - Not Fixed. See below for new issues.

  • All add_theme_support, register_nav_menu, if ( ! isset( $content_width ), add_editor_style and set_post_thumbnail_size must be called from a function callback hooked to the after_setup_theme action. - Partially Fixed. See this review section below.
  • register_sidebar must be called from a function callback and hooked to the widgets_init action. - Fixed with a new issue, see below.
  • Incorrect textdomain (twentythirteen) used in single.php - Fixed but since you are not providing the theme as translation ready then there's no need for the strings and they should be removed.
  • Please escape all instances of home_url(); thus esc_url(home_url('/')); - Fixed.

Theme Unit Test

Required:

  • Theme has Header Text Color enabled but the selected color does not apply to the Site title on the front end or in the customizer. - Fixed by removal but header has new issue, see below.
  • Large images in sidebar overflow their container - please see below for resources to use in order to replicate the issues - Not Fixed.
  • Select element with long string overflows container in sidebar - refer to links in resources for testing. - Fixed.
  • Pages must show comments and comment form if selected by the user, however they must not show the words "Comments are closed" or similar when comments are set to off. - Not Fixed.
  • Post Format: Gallery - needs styling as some images overlap in places - see attachment - Fixed.
  • Post Format: Gallery - single image view: please consider adding the Next/Previous image links for ease of navigation on a gallery with more than one image. See links below. - Fixed.
  • Post Format: Video - video embed overflows its container for both WordPress.tv and YouTube codes. See attachment. - Fixed.
  • Post with super duper long title and non breaking text overflows its container in Chrome - see attachment. - Fixed.
  • Post with no title must somehow link to the single post view - the easiest way to achieve this is to wrap the permalink around the post date. - Fixed.
  • Single post view Previous/Next post links are too close together - please consider using float to space them out. - Fixed.
  • 404 does not function as it should - please look in to this. - Fixed.

This Review - New issues

Required:

  • Themes must not generate any PHP/Scripts Errors, Warnings, Notices and or Deprecated calls - the following Notices were generated on activation:
    Notice: Use of undefined constant add_theme_support - assumed 'add_theme_support' in /home/sites/wpliveserver.com/public_html/wp-content/themes/noble/functions.php on line 8 
    Notice: Use of undefined constant register_nav_menu - assumed 'register_nav_menu' in /home/sites/wpliveserver.com/public_html/wp-content/themes/noble/functions.php on line 22 
    Notice: Use of undefined constant add_editor_style - assumed 'add_editor_style' in /home/sites/wpliveserver.com/public_html/wp-content/themes/noble/functions.php on line 25 
    
  • Please remove the if fucntion_exists wrapper from add_theme_support, register_nav_menu, add_editor_style, register_sidebar and dynamic_sidebar - doing so may well resolve the above Notices!
  • themejam_scripts_styles should be hooked to the wp_enqueue_scrpts()/wp_enqueue_styles() action instead of the init action.
  • Header section (Site title, site description and nav menu) are out of place - please visit http://wpliveserver.com/my-way/ (Only live for the next 24hrs) to see what I mean. Also see the sidebar for the issues mentioned in previous review which remain unresolved.

Please address of the issues marked as Not Fixed plus all of the new issues raised above before resubmitting for review. Once again I refer you to the resources I pointed out in my previous review to be used in assisting the checking and fixing of the aforementioned issues.

Leaving this ticket open for you to upload a revised version with the fixes so that I can continue with the review.

Zulf

#3 @ZGani
4 years ago

Hello CasBK,

Any feedback on how soon I can expect a revised version with the fixes to be submitted?

Please let me know if it's going to take a while so that I can close the ticket pending future submission.

Zulf

#4 @themetracbot
4 years ago

  • Summary changed from THEME: Noble - 1.4.2 to THEME: Noble - 1.4.3

Noble - 1.4.3

A clean and elegant personal blog theme from ThemeJam.

Theme URL -
Author URL - http://themejam.com

SVN - http://themes.svn.wordpress.org/noble/1.4.3
ZIP - http://wordpress.org/themes/download/noble.1.4.3.zip?nostats=1

Diff with previous version: http://themes.trac.wordpress.org/changeset?old_path=/noble/1.4.2&new_path=/noble/1.4.3

History:

Ticket Summary Status Resolution Owner
#13157 THEME: Noble - 1.4 closed not-approved bhadaway
#13891 THEME: Noble - 1.4.1 closed not-approved ZGani
#14013 THEME: Noble - 1.4.3 closed not-approved ZGani

(this ticket)

#14175 THEME: Noble - 1.4.5 closed live ZGani
#23225 THEME: Noble - 1.4.6 closed live emiluzelac


https://themes.svn.wordpress.org/noble/1.4.3/screenshot.png

#5 @ZGani
4 years ago

  • Resolution set to not-approved
  • Status changed from reviewing to closed

I'm sorry but you are not fixing the issues raised.

From Previous review.

Required: All these issues are required and theme will not be approved until and unless they are fixed!

  • Large images in sidebar overflow is Not Fixed.
  • Page with comments enable must show comments and comment form - Not Fixed.

From recent review.

  • Themes must not generate any PHP/Scripts Errors, Warnings, Notices and or Deprecated calls - the following Notices were generated on activation: - Not Fixed.
    Notice: Use of undefined constant add_theme_support - assumed 'add_theme_support' in /home/sites/wpliveserver.com/public_html/wp-content/themes/noble/functions.php on line 8 
    Notice: Use of undefined constant register_nav_menu - assumed 'register_nav_menu' in /home/sites/wpliveserver.com/public_html/wp-content/themes/noble/functions.php on line 22 
    Notice: Use of undefined constant add_editor_style - assumed 'add_editor_style' in /home/sites/wpliveserver.com/public_html/wp-content/themes/noble/functions.php on line 25 
    
  • Please remove the if fucntion_exists wrapper from add_theme_support, register_nav_menu, add_editor_style, register_sidebar and dynamic_sidebar - doing so may well resolve the above Notices! - Not Fixed.
  • themejam_scripts_styles should be hooked to the wp_enqueue_scrpts()/wp_enqueue_styles() action instead of the init action. - Not Fixed.

Please fix all of the above and any outstanding issues before re-submitting for further reviews.

#6 follow-up: @CasBK
4 years ago

Sorry about that - I uploaded the wrong version of the theme... Working on these last few fixes and will re-upload shortly. Thanks

#7 in reply to: ↑ 6 @ZGani
4 years ago

Replying to CasBK:

Sorry about that - I uploaded the wrong version of the theme... Working on these last few fixes and will re-upload shortly. Thanks

No problem - just leave a note on this ticket as well as new one so that I can pick up on where I left of :)

#8 @CasBK
4 years ago

Hi ZGani - I just uploaded the fixed version: http://themes.trac.wordpress.org/ticket/14175

  • Large images in sidebar overflow - Fixed
  • Page with comments enable must show comments and comment form - Fixed
  • Please remove the if fucntion_exists wrapper from add_theme_support, register_nav_menu, add_editor_style, register_sidebar and dynamic_sidebar - Fixed
  • themejam_scripts_styles should be hooked to the wp_enqueue_scrpts()/wp_enqueue_styles() action instead of the init action. - Fixed

Hope this is good to go for approval :)

Note: See TracTickets for help on using tickets.