WordPress.org

Make WordPress Themes

Opened 7 months ago

Closed 6 months ago

#14658 closed theme (live)

THEME: Sweet Tech - 1.3.5

Reported by: sudeep611 Owned by: ZGani
Priority: previously reviewed Keywords: theme-sweet-tech
Cc: sudeep611@…

Description

Sweet Tech - 1.2

Beautiful Responsive WordPress theme especially for Tech related blogs. If you want a theme that loads faster and looks beautiful with many features in it then Sweet Tech is for you. It is Ads ready just copy the adsense code in theme options setting page then the ads will appear below post title and below post.

Theme URL -
Author URL - http://cwlk.org

SVN - http://themes.svn.wordpress.org/sweet-tech/1.2
ZIP - http://wordpress.org/themes/download/sweet-tech.1.2.zip?nostats=1

Diff with previous version: http://themes.trac.wordpress.org/changeset?old_path=/sweet-tech/1.1&new_path=/sweet-tech/1.2

History:

Ticket Summary Status Resolution Owner
#14487 THEME: Sweet Tech - 1.0 closed not-approved ZGani
#14563 THEME: Sweet Tech - 1.1 closed not-approved ZGani
#14658 THEME: Sweet Tech - 1.3.5 closed live ZGani

(this ticket)

#15034 THEME: Sweet Tech - 2.1 closed live tskk
#15146 THEME: Sweet Tech - 2.1.1 closed live tskk
#16177 THEME: Sweet Tech - 2.1.3 closed live tskk
#16507 THEME: Sweet Tech - 2.1.5 closed live chipbennett


https://themes.svn.wordpress.org/sweet-tech/1.2/screenshot.png

Attachments (5)

sweettech.zip (80.0 KB) - added by sudeep611 7 months ago.
Updated
LargeImageOverflowsContainer.png (83.7 KB) - added by ZGani 6 months ago.
Large image overflows container
PostFormatGallery.png (13.2 KB) - added by ZGani 6 months ago.
Code should not be showing in the blog feed
PostFormatVideoWPTV.png (141.2 KB) - added by ZGani 6 months ago.
WordPress TV video overflows container
LongTitleOverflow.png (19.4 KB) - added by ZGani 6 months ago.
Long titles should not overflow their container

Download all attachments as: .zip

Change History (26)

comment:1 ZGani7 months ago

  • Owner set to ZGani
  • Status changed from new to reviewing

comment:2 ZGani7 months ago

Could you please test your theme with the following - there are a lot of issues with how the content is presented.

Theme Test Unit Data
Monster Widget plugin
Debug Bar plugin
Log Deprecated Notices
Theme Check Plugin
Debogger Plugin

Especially check the Gallery format in blog feed, image alignment for both content and sidebar and video format. In addition, I'm sure you'll agree that content and sidebar are to close together and could do with some padding/margin separation.

Social links should not be pre-populated with example links if there's no option to disable theme - what happens if the user does not have an account with a specific network or does not wish to use any of the social links?

Please fix the issues and upload a revised version for me to continue with the review - leaving ticket open for now.

sudeep6117 months ago

Updated

comment:4 themetracbot7 months ago

  • Summary changed from THEME: Sweet Tech - 1.2 to THEME: Sweet Tech - 1.3

Sweet Tech - 1.3

Beautiful Responsive WordPress theme especially for Tech related blogs. If you want a theme that loads faster and looks beautiful with many features in it then Sweet Tech is for you. It is Ads ready just copy the adsense code in theme options setting page then the ads will appear below post title and below post.

Theme URL -
Author URL - http://cwlk.org

SVN - http://themes.svn.wordpress.org/sweet-tech/1.3
ZIP - http://wordpress.org/themes/download/sweet-tech.1.3.zip?nostats=1

Diff with previous version: http://themes.trac.wordpress.org/changeset?old_path=/sweet-tech/1.2&new_path=/sweet-tech/1.3

History:

Ticket Summary Status Resolution Owner
#14487 THEME: Sweet Tech - 1.0 closed not-approved ZGani
#14563 THEME: Sweet Tech - 1.1 closed not-approved ZGani
#14658 THEME: Sweet Tech - 1.3.5 closed live ZGani

(this ticket)

#15034 THEME: Sweet Tech - 2.1 closed live tskk
#15146 THEME: Sweet Tech - 2.1.1 closed live tskk
#16177 THEME: Sweet Tech - 2.1.3 closed live tskk
#16507 THEME: Sweet Tech - 2.1.5 closed live chipbennett


https://themes.svn.wordpress.org/sweet-tech/1.3/screenshot.png

comment:5 ZGani6 months ago

General

Required:

  • Please include the license details of the underscores theme as well as the fonts used - this is in addition to declaring their respective copyrights.
  • Also include the same for the social icons used in the theme.

Code check

Required:

  • header.php: <title></title> must only contain <?php wp_title( '|', true, 'right' ); ?> with the rest of the parameters implemented via the wp_title filter.
  • header.php: Favicons if implemented must be off by default and be user configurable.
  • functions.php: register_sidebar must be called outside of the after_setup_theme in its own function callback hooked to the widgets_init action.
  • functions.php: Wrong textdomain used for register_nav_menus()
  • functions.php: if ( ! isset( $content_width ) ) $content_width = 960; should be set at 640 and not 960 - you'll find that is the cause if the large image overflow.

Theme Unit Test.

Required:

  • Image Alignment test: Large image still overflows its container - see attached screenshot.
  • Post Format Gallery: Gallery is still pulling in code on the blog feed index - see attached screenshot. This is not the normal expected output behavior.
  • Post Format Video: WordPress.tv video overflows its container - see attachment screenshot.
  • Post with super duper long title overflows its container - see attached screenshot.

This is a complete theme review - although most of the issues from previous review have been resolved the above remain unresolved and require fixing before the theme can be approved. Please refer back to my previous review and use the suggested resources to fully understand this review feedback and address the issues raised. Feel free to resubmit once you have fixed all of the above problems.

ZGani6 months ago

Large image overflows container

ZGani6 months ago

Code should not be showing in the blog feed

ZGani6 months ago

WordPress TV video overflows container

ZGani6 months ago

Long titles should not overflow their container

comment:6 themetracbot6 months ago

  • Summary changed from THEME: Sweet Tech - 1.3 to THEME: Sweet Tech - 1.3.1

Sweet Tech - 1.3.1

Beautiful Responsive WordPress theme especially for Tech related blogs. If you want a theme that loads faster and looks beautiful with many features in it then Sweet Tech is for you. It is Ads ready just copy the adsense code in theme options setting page then the ads will appear below post title and below post.

Theme URL -
Author URL - http://cwlk.org

SVN - http://themes.svn.wordpress.org/sweet-tech/1.3.1
ZIP - http://wordpress.org/themes/download/sweet-tech.1.3.1.zip?nostats=1

Diff with previous version: http://themes.trac.wordpress.org/changeset?old_path=/sweet-tech/1.3&new_path=/sweet-tech/1.3.1

History:

Ticket Summary Status Resolution Owner
#14487 THEME: Sweet Tech - 1.0 closed not-approved ZGani
#14563 THEME: Sweet Tech - 1.1 closed not-approved ZGani
#14658 THEME: Sweet Tech - 1.3.5 closed live ZGani

(this ticket)

#15034 THEME: Sweet Tech - 2.1 closed live tskk
#15146 THEME: Sweet Tech - 2.1.1 closed live tskk
#16177 THEME: Sweet Tech - 2.1.3 closed live tskk
#16507 THEME: Sweet Tech - 2.1.5 closed live chipbennett


https://themes.svn.wordpress.org/sweet-tech/1.3.1/screenshot.png

comment:7 ZGani6 months ago

Sorry but "Social Media Icons designed by veodesign is licensed under Creative Commons Attribution Share-Alike 3.0 Unported License, http://creativecommons.org/licenses/by-sa/3.0/" is not GPL compatible - these will have to be replaced or removed from the theme.

The only Creative Commons license compatible with GPL is the CC By 0!

comment:8 themetracbot6 months ago

  • Summary changed from THEME: Sweet Tech - 1.3.1 to THEME: Sweet Tech - 1.3.2

Sweet Tech - 1.3.2

Beautiful Responsive WordPress theme especially for Tech related blogs. If you want a theme that loads faster and looks beautiful with many features in it then Sweet Tech is for you. It is Ads ready just copy the adsense code in theme options setting page then the ads will appear below post title and below post.

Theme URL -
Author URL - http://cwlk.org

SVN - http://themes.svn.wordpress.org/sweet-tech/1.3.2
ZIP - http://wordpress.org/themes/download/sweet-tech.1.3.2.zip?nostats=1

Diff with previous version: http://themes.trac.wordpress.org/changeset?old_path=/sweet-tech/1.3.1&new_path=/sweet-tech/1.3.2

History:

Ticket Summary Status Resolution Owner
#14487 THEME: Sweet Tech - 1.0 closed not-approved ZGani
#14563 THEME: Sweet Tech - 1.1 closed not-approved ZGani
#14658 THEME: Sweet Tech - 1.3.5 closed live ZGani

(this ticket)

#15034 THEME: Sweet Tech - 2.1 closed live tskk
#15146 THEME: Sweet Tech - 2.1.1 closed live tskk
#16177 THEME: Sweet Tech - 2.1.3 closed live tskk
#16507 THEME: Sweet Tech - 2.1.5 closed live chipbennett


https://themes.svn.wordpress.org/sweet-tech/1.3.2/screenshot.png

comment:9 ZGani6 months ago

Please point to the resource and license/copyright url for the icons

Social Media Icons designed by Brainleaf Communication, http://www.brainleaf.eu/

This is not sufficient!

comment:10 follow-up: sudeep6116 months ago

But the icon author has not mentioned the copyright url. Instead these information is provided:

  • You can use this set for personal and commercial use.
  • No attribution required but a linkback would be appreciated.
  • You can't sell this set.
  • You can't redistribute this set.

comment:11 themetracbot6 months ago

  • Summary changed from THEME: Sweet Tech - 1.3.2 to THEME: Sweet Tech - 1.3.3

Sweet Tech - 1.3.3

Beautiful Responsive WordPress theme especially for Tech related blogs. If you want a theme that loads faster and looks beautiful with many features in it then Sweet Tech is for you. It is Ads ready just copy the adsense code in theme options setting page then the ads will appear below post title and below post.

Theme URL -
Author URL - http://cwlk.org

SVN - http://themes.svn.wordpress.org/sweet-tech/1.3.3
ZIP - http://wordpress.org/themes/download/sweet-tech.1.3.3.zip?nostats=1

Diff with previous version: http://themes.trac.wordpress.org/changeset?old_path=/sweet-tech/1.3.2&new_path=/sweet-tech/1.3.3

History:

Ticket Summary Status Resolution Owner
#14487 THEME: Sweet Tech - 1.0 closed not-approved ZGani
#14563 THEME: Sweet Tech - 1.1 closed not-approved ZGani
#14658 THEME: Sweet Tech - 1.3.5 closed live ZGani

(this ticket)

#15034 THEME: Sweet Tech - 2.1 closed live tskk
#15146 THEME: Sweet Tech - 2.1.1 closed live tskk
#16177 THEME: Sweet Tech - 2.1.3 closed live tskk
#16507 THEME: Sweet Tech - 2.1.5 closed live chipbennett


https://themes.svn.wordpress.org/sweet-tech/1.3.3/screenshot.png

comment:12 in reply to: ↑ 10 ZGani6 months ago

Replying to sudeep611:

But the icon author has not mentioned the copyright url. Instead these information is provided:

  • You can use this set for personal and commercial use.
  • No attribution required but a linkback would be appreciated.
  • *You can't sell this set.
  • *You can't redistribute this set.

    These* two points alone make the icon set to be non GPL compatible - all resources must be 100% GPL or GPL compatible i.e. no restrictions what soever. In addition the license and copyright must be explicitly stated.

comment:13 sudeep6116 months ago

Thanks for the info Sir. But in version 1.3.3 The icons used are 100% GPL compatible, please review the theme again.

comment:14 ZGani6 months ago

  • Status changed from reviewing to approved

All previously raised required issues have been resolved.

comment:15 sudeep6116 months ago

Hi Sir, my theme is approved but it is still not appearing in WordPress directory. How much time does it take to appear there.

comment:16 chipbennett6 months ago

  • Status changed from approved to reopened
  • Themes must use a single options array, rather than saving multiple options to the database.
  • Themes must sanitize options on input, and escape options on output

comment:17 chipbennett6 months ago

  • Status changed from reopened to reviewing

comment:18 themetracbot6 months ago

  • Summary changed from THEME: Sweet Tech - 1.3.3 to THEME: Sweet Tech - 1.3.4

Sweet Tech - 1.3.4

Beautiful Responsive WordPress theme especially for Tech related blogs. The load time of the Theme is fastest. Sweet Tech is the two column theme with right sidebar. The apperance is white in the body and sky blue color in Header and Footer.

Theme URL -
Author URL - http://twitter.com/acsudeep

SVN - http://themes.svn.wordpress.org/sweet-tech/1.3.4
ZIP - http://wordpress.org/themes/download/sweet-tech.1.3.4.zip?nostats=1

Diff with previous version: http://themes.trac.wordpress.org/changeset?old_path=/sweet-tech/1.3.3&new_path=/sweet-tech/1.3.4

History:

Ticket Summary Status Resolution Owner
#14487 THEME: Sweet Tech - 1.0 closed not-approved ZGani
#14563 THEME: Sweet Tech - 1.1 closed not-approved ZGani
#14658 THEME: Sweet Tech - 1.3.5 closed live ZGani

(this ticket)

#15034 THEME: Sweet Tech - 2.1 closed live tskk
#15146 THEME: Sweet Tech - 2.1.1 closed live tskk
#16177 THEME: Sweet Tech - 2.1.3 closed live tskk
#16507 THEME: Sweet Tech - 2.1.5 closed live chipbennett


https://themes.svn.wordpress.org/sweet-tech/1.3.4/screenshot.png

comment:19 themetracbot6 months ago

  • Summary changed from THEME: Sweet Tech - 1.3.4 to THEME: Sweet Tech - 1.3.5

Sweet Tech - 1.3.5

Beautiful Responsive WordPress theme especially for Tech related blogs. The load time of the Theme is fastest. Sweet Tech is the two column theme with right sidebar. The apperance is white in the body and sky blue color in Header and Footer.

Theme URL -
Author URL - http://twitter.com/acsudeep

SVN - http://themes.svn.wordpress.org/sweet-tech/1.3.5
ZIP - http://wordpress.org/themes/download/sweet-tech.1.3.5.zip?nostats=1

Diff with previous version: http://themes.trac.wordpress.org/changeset?old_path=/sweet-tech/1.3.4&new_path=/sweet-tech/1.3.5

History:

Ticket Summary Status Resolution Owner
#14487 THEME: Sweet Tech - 1.0 closed not-approved ZGani
#14563 THEME: Sweet Tech - 1.1 closed not-approved ZGani
#14658 THEME: Sweet Tech - 1.3.5 closed live ZGani

(this ticket)

#15034 THEME: Sweet Tech - 2.1 closed live tskk
#15146 THEME: Sweet Tech - 2.1.1 closed live tskk
#16177 THEME: Sweet Tech - 2.1.3 closed live tskk
#16507 THEME: Sweet Tech - 2.1.5 closed live chipbennett


https://themes.svn.wordpress.org/sweet-tech/1.3.5/screenshot.png

comment:20 ZGani6 months ago

  • Status changed from reviewing to approved

Raised required issues have been addressed.

comment:21 emiluzelac6 months ago

  • Resolution set to live
  • Status changed from approved to closed
Note: See TracTickets for help on using tickets.