WordPress.org

Make WordPress Themes

Opened 6 months ago

Closed 6 months ago

#14779 closed theme (not-approved)

THEME: Gold - 1.32

Reported by: usharia Owned by: rohitink
Priority: previously reviewed Keywords: theme-gold
Cc: manas@…

Description

Gold - 1.3

The Gold theme for WordPress is based on latest version of Responsive Framework of Twitter Bootstrap.It has a flaxible layout which looks great on small, medium and large devices. The Gold theme wraps in, 3 beautiful color themes on light backgrounds and provides you, full freedom to customize as per your needs.The theme features 10 Template Layouts with widgetized sidebar and footer.

Theme URL - http://code-b.in/wordpress-gold/themes/gold/
Author URL - http://invasion-technologies.com/

SVN - http://themes.svn.wordpress.org/gold/1.3
ZIP - http://wordpress.org/themes/download/gold.1.3.zip?nostats=1

Diff with previous version: http://themes.trac.wordpress.org/changeset?old_path=/gold/1.2&new_path=/gold/1.3

History:

Ticket Summary Status Resolution Owner
#5653 THEME: Golden ratio - 1.0 closed closed-newer-version-uploaded
#5661 THEME: Golden ratio - 1.0.1 closed closed-newer-version-uploaded
#5692 THEME: Golden ratio - 1.0.2 closed not-approved saymar90
#8631 THEME: Golden Eagle Lite - 1.0 closed closed-newer-version-uploaded
#8632 THEME: Golden Eagle Lite - 1.1 closed live saymar90
#10607 THEME: Golden Eagle Lite - 1.2 closed live life.object
#14645 THEME: Gold - 1.01 closed not-approved rohitink
#14750 THEME: Gold - 1.2 closed not-approved rohitink
#14779 THEME: Gold - 1.32 closed not-approved rohitink

(this ticket)

#15070 THEME: Gold - 1.33 closed not-approved rohitink
#15269 THEME: Gold - 1.37 closed live alex27
#15856 THEME: Golden Eagle Lite - 1.6 closed live ZGani
#16052 THEME: Gold - 1.38 closed live tskk
#16267 THEME: Gold - 1.39 closed live tskk
#16511 THEME: Gold - 1.40 closed live chipbennett
#16791 THEME: Gold - 1.41 closed live rohitink
#17915 THEME: Gold - 1.42 closed live tskk


https://themes.svn.wordpress.org/gold/1.3/screenshot.png

Change History (39)

comment:1 rohitink6 months ago

  • Owner set to rohitink
  • Status changed from new to reviewing

comment:2 rohitink6 months ago

Required

  1. No Styling is present for tables in posts and comments.
  1. Pagination on Paginated Template/Posts does not work.
  1. Post title & categories have almost same font-size and link-color, making theme in-distinguishable. General practice is to have similar style for the entire meta section. Separate the categories from the post title. I recommened you to include theme with the tags/author section.
  1. Pingbacks and Trackbacks do not show up on a post.
  1. Post titles, content, etc containing very long words overflow their container. Use word-wrap: break-word to fix this issue.
  1. There is no provision for a user who doesn't want to use the navigation menu and social icons. It always says on the top "Please select a social icons or create one here""". But, what if a user doesn't wanna use those icons?? There is not way to get rid of that message.
  1. Shortcodes are Plugin Territory and not allowed in themes at WPORG.
  1. You still need to explicitly state the license details for the images and js files.
  1. Give some right margin to "tags" in entry-meta section.

comment:3 usharia6 months ago

HI, I have completed most of the changes, however, there is a little confusion over a couple of things.

I cannot find out why the pingbacks and track backs are not working and how can i test trackbacks.. Also the pagination, which is given in single post page and gallery single page are working fine and I couldn't reproduce the bug. I have installed the theme on http://code-b.in/wordpress-gold/themes/gold/. If you want, I can create an admin and send to you to check.

Please help.

Thanks
Manas

comment:4 follow-up: usharia6 months ago

I have another question... I am using bootstrap css and js and some fonts. I have two options for this : bundle with the theme or use CDN to fetch them. Which one must be preferred?

comment:5 in reply to: ↑ 4 rohitink6 months ago

I have another question... I am using bootstrap css and js and some fonts. I have two options for this : bundle with the theme or use CDN to fetch them. Which one must be preferred?

The fonts,js and CSS files should be bundled with the theme. You can use only Google fonts with the Google API, nothing else.

I cannot find out why the pingbacks and track backs are not working and how can i test trackbacks.

Look at this page: http://code-b.in/wordpress-gold/themes/gold/?p=1149
There are be 5 pingbacks on it, but none are being displayed.

Pagination

At this page, you are displaying all the posts on a single page. http://code-b.in/wordpress-gold/themes/gold/?page_id=46
Whereas, it should be equal to the value, which is set under Settings > Reading in wordpress dashboard. And when it is set to that value, I am unable to see the navigation links at the bottom to navigate to the next set of posts.

comment:6 usharia6 months ago

Hi Rohit,

The pagination is sorted, I have also applied it to some other templates. However, I am still clueless about pingback and trackbacks. I have given a <link rel="pingback".... in the head. Also allowed the pingbacks and trackbacks from the admin. Am I supposed to do anything more to make this work? I believe WordPress handles the rest. Please advice.

Thanks again
Manas

comment:7 rohitink6 months ago

Okay. Great. WordPress does handle the pingback to some extent. If the pingbacks are still not showing up for you. Then, read the code in the comments.php of Underscores framework. http://underscores.me That will give you a much better understanding of how it works.

comment:8 themetracbot6 months ago

  • Summary changed from THEME: Gold - 1.3 to THEME: Gold - 1.31

Gold - 1.31

The Gold theme for WordPress is based on latest version of Responsive Framework of Twitter Bootstrap.It has a flaxible layout which looks great on small, medium and large devices. The Gold theme wraps in, 3 beautiful color themes on light backgrounds and provides you, full freedom to customize as per your needs.The theme features 10 Template Layouts with widgetized sidebar and footer.

Theme URL - http://code-b.in/wordpress-gold/themes/gold/
Author URL - http://invasion-technologies.com/

SVN - http://themes.svn.wordpress.org/gold/1.31
ZIP - http://wordpress.org/themes/download/gold.1.31.zip?nostats=1

Diff with previous version: http://themes.trac.wordpress.org/changeset?old_path=/gold/1.3&new_path=/gold/1.31

History:

Ticket Summary Status Resolution Owner
#5653 THEME: Golden ratio - 1.0 closed closed-newer-version-uploaded
#5661 THEME: Golden ratio - 1.0.1 closed closed-newer-version-uploaded
#5692 THEME: Golden ratio - 1.0.2 closed not-approved saymar90
#8631 THEME: Golden Eagle Lite - 1.0 closed closed-newer-version-uploaded
#8632 THEME: Golden Eagle Lite - 1.1 closed live saymar90
#10607 THEME: Golden Eagle Lite - 1.2 closed live life.object
#14645 THEME: Gold - 1.01 closed not-approved rohitink
#14750 THEME: Gold - 1.2 closed not-approved rohitink
#14779 THEME: Gold - 1.32 closed not-approved rohitink

(this ticket)

#15070 THEME: Gold - 1.33 closed not-approved rohitink
#15269 THEME: Gold - 1.37 closed live alex27
#15856 THEME: Golden Eagle Lite - 1.6 closed live ZGani
#16052 THEME: Gold - 1.38 closed live tskk
#16267 THEME: Gold - 1.39 closed live tskk
#16511 THEME: Gold - 1.40 closed live chipbennett
#16791 THEME: Gold - 1.41 closed live rohitink
#17915 THEME: Gold - 1.42 closed live tskk


https://themes.svn.wordpress.org/gold/1.31/screenshot.png

comment:9 rohitink6 months ago

  1. Remove the 'menu' parameter from your wp_nav_menu() function. 'theme-location' is just fine.
  1. Add styling for unordered lists in posts/pages.
  1. Your theme is licensed under GNU GPL v2. Bootstrap is only compatible with GPL v3. So, change your license to GPL v3 in order to use Bootstrap.
  1. You have still not resolved issue 6 from previous review: There is no provision for a user who doesn't want to use social icons. It always says on the top "Please select a social icons or create one here""". But, what if a user doesn't wanna use those icons?? There is no way to get rid of that message.

All other issues from current review and previous review have been fixed.

comment:10 themetracbot6 months ago

  • Summary changed from THEME: Gold - 1.31 to THEME: Gold - 1.32

Gold - 1.32

The Gold theme for WordPress is based on latest version of Responsive Framework of Twitter Bootstrap.It has a flaxible layout which looks great on small, medium and large devices. The Gold theme wraps in, 3 beautiful color themes on light backgrounds and provides you, full freedom to customize as per your needs.The theme features 10 Template Layouts with widgetized sidebar and footer.

Theme URL - http://code-b.in/wordpress-gold/themes/gold/
Author URL - http://invasion-technologies.com/

SVN - http://themes.svn.wordpress.org/gold/1.32
ZIP - http://wordpress.org/themes/download/gold.1.32.zip?nostats=1

Diff with previous version: http://themes.trac.wordpress.org/changeset?old_path=/gold/1.31&new_path=/gold/1.32

History:

Ticket Summary Status Resolution Owner
#5653 THEME: Golden ratio - 1.0 closed closed-newer-version-uploaded
#5661 THEME: Golden ratio - 1.0.1 closed closed-newer-version-uploaded
#5692 THEME: Golden ratio - 1.0.2 closed not-approved saymar90
#8631 THEME: Golden Eagle Lite - 1.0 closed closed-newer-version-uploaded
#8632 THEME: Golden Eagle Lite - 1.1 closed live saymar90
#10607 THEME: Golden Eagle Lite - 1.2 closed live life.object
#14645 THEME: Gold - 1.01 closed not-approved rohitink
#14750 THEME: Gold - 1.2 closed not-approved rohitink
#14779 THEME: Gold - 1.32 closed not-approved rohitink

(this ticket)

#15070 THEME: Gold - 1.33 closed not-approved rohitink
#15269 THEME: Gold - 1.37 closed live alex27
#15856 THEME: Golden Eagle Lite - 1.6 closed live ZGani
#16052 THEME: Gold - 1.38 closed live tskk
#16267 THEME: Gold - 1.39 closed live tskk
#16511 THEME: Gold - 1.40 closed live chipbennett
#16791 THEME: Gold - 1.41 closed live rohitink
#17915 THEME: Gold - 1.42 closed live tskk


https://themes.svn.wordpress.org/gold/1.32/screenshot.png

comment:11 follow-up: rohitink6 months ago

  • Status changed from reviewing to approved

All Issues with the Theme have been resolved. Marking as Approved.

comment:12 in reply to: ↑ 11 usharia6 months ago

Replying to rohitink:

All Issues with the Theme have been resolved. Marking as Approved.

Thanks a lot Rohit and the WordPress review team. You guys helped me in my first step towards WordPress development. Thanks again :)

Regards
Manas

comment:13 emiluzelac6 months ago

  • Resolution set to live
  • Status changed from approved to closed

Note that we need to have an actual undisordered screenshot of your theme which can be addressed in next update. Try this http://url2png.com/

comment:14 usharia6 months ago

Thank you so much. However, I have made a mistake in the description of the theme which does'nt look nice... Can you suggest how can I correct this? Thanks
Manas

comment:16 chipbennett6 months ago

Please remove query_posts() from your template files. Use new WP_Query() or pre_get_posts as necessary to create secondary loops or to modify the primary loop.

comment:17 usharia6 months ago

ok. I am preparing an update in a couple of days. Will include your recommendations.

comment:18 chipbennett6 months ago

These are required:

  1. Do not use query_posts()
  2. Use get_template_directory() in place of TEMPLATEPATH
  3. Proper implementation of the Template Hierarchy, especially with respect to site front page template and the blog posts index template. The blog.php is redundant with home.php (the latter of which is correct). template-home.php should be front-page.php.

comment:19 follow-up: usharia6 months ago

Chip,

I am making the said changes now. In the third point you mentioned using front-page.php for homepage. The reason I am using it as a template is that I want to leave it to user whether or not to use this template as home page. Is this not correct?

Also I thought that storing the template-directory in a constant will reduce the number of calls for the function. Am I doing it wrong?

Thanks

comment:20 in reply to: ↑ 19 ; follow-up: chipbennett6 months ago

Replying to usharia:

Chip,

I am making the said changes now. In the third point you mentioned using front-page.php for homepage. The reason I am using it as a template is that I want to leave it to user whether or not to use this template as home page. Is this not correct?

That's fine; but if you do that, then name it "Featured Content" or something. Don't name it "home", as that name means something else in WordPress, and could introduce confusion.

Also I thought that storing the template-directory in a constant will reduce the number of calls for the function. Am I doing it wrong?

TEMPLATEPATH is slated for deprecation, replaced by get_template_directory(). That value is cached by WordPress, and introduces no additional performance hits.

comment:21 in reply to: ↑ 20 usharia6 months ago

Replying to chipbennett:

OK. A last question.. Since I have found a few bugs like these, it will take me more than a day or two to clean the theme and implement the changes. Is it okay? Will this delay affect my live theme?

Replying to usharia:

Chip,

I am making the said changes now. In the third point you mentioned using front-page.php for homepage. The reason I am using it as a template is that I want to leave it to user whether or not to use this template as home page. Is this not correct?

That's fine; but if you do that, then name it "Featured Content" or something. Don't name it "home", as that name means something else in WordPress, and could introduce confusion.

Also I thought that storing the template-directory in a constant will reduce the number of calls for the function. Am I doing it wrong?

TEMPLATEPATH is slated for deprecation, replaced by get_template_directory(). That value is cached by WordPress, and introduces no additional performance hits.

comment:22 follow-up: emiluzelac6 months ago

header.php

  • Please remove or integrate into Theme Options: <link rel="shortcut icon" href="<?php echo TEMPPATH;?>/img/favicon.gif">
  • No need to comment out <!--h1>Invasion Technologies</h1--> if not needed remove this header.
  • User fallback instead of Please select a menu or create one some user may or may not need the extra menus at all.

In footer.php you have callto that's Skype only, I would recommend tel: instead.

comment:23 in reply to: ↑ 22 usharia6 months ago

Replying to emiluzelac:
I have seen users just find and replace favicon from the theme folder. Looks convenient to me. I can however, integrate it to theme options. But, is it just wrong including it w/o theme options in a WordPress theme?

header.php

  • Please remove or integrate into Theme Options: <link rel="shortcut icon" href="<?php echo TEMPPATH;?>/img/favicon.gif">
  • No need to comment out <!--h1>Invasion Technologies</h1--> if not needed remove this header.
  • User fallback instead of Please select a menu or create one some user may or may not need the extra menus at all.

In footer.php you have callto that's Skype only, I would recommend tel: instead.

comment:24 emiluzelac6 months ago

More items:

function inv_iframe_script() {
		wp_enqueue_script( 'jquery' );
	}

jQuery should not be enqueued, include as in array only not to mention that including wordpress.org/plugins/iframe/ is generally bad idea also no longer needed, WordPress is fully capable of embedding YouTube videos see: http://codex.wordpress.org/Embeds


I have a feeling that we need a complete review here, sorry

comment:25 chipbennett6 months ago

Please refer to the Guidelines:

Favicons

  • If implemented, favicon functionality is required to be opt-in, and disabled by default.
  • If implemented, favicon functionality is required to support user-defined favicon images

comment:26 emiluzelac6 months ago

see http://make.wordpress.org/themes/guidelines/guidelines-plugin-territory/

Favicons
If implemented, favicon functionality is required to be opt-in, and disabled by default.
If implemented, favicon functionality is required to support user-defined favicon images

comment:27 follow-up: chipbennett6 months ago

  • Resolution live deleted
  • Status changed from closed to reopened

comment:28 chipbennett6 months ago

Emil is right; this one needs a thorough re-review. There is too much here that should not have been approved.

comment:29 chipbennett6 months ago

  • Status changed from reopened to reviewing

comment:30 in reply to: ↑ 27 usharia6 months ago

Replying to chipbennett:
This being my first theme.. can you tell me the process ahead... what happens to the theme page http://wordpress.org/themes/gold? And the downloads done? Can I request either you or Emil to review and recommend more changes?

comment:31 follow-up: chipbennett6 months ago

For now, I've suspended the Theme in the directory. Once it passes approval and pushed live, it will be un-suspended.

Any reviewer is equally capable of performing a thorough review. This one will stay with the original reviewer, unless @rohitink requests to have it reassigned.

comment:32 follow-up: emiluzelac6 months ago

I think that @rohitink can proceed with a complete review :)

comment:33 in reply to: ↑ 31 usharia6 months ago

Replying to chipbennett:
I have absolutely no doubt on the reviewer. It was just that since you were looking at my code, I thought it as an opportunity to get most bugs out.

For now, I've suspended the Theme in the directory. Once it passes approval and pushed live, it will be un-suspended.

Any reviewer is equally capable of performing a thorough review. This one will stay with the original reviewer, unless @rohitink requests to have it reassigned.

comment:34 emiluzelac6 months ago

Reviewers usually just check the diff.

comment:35 in reply to: ↑ 32 rohitink6 months ago

Replying to emiluzelac:

I think that @rohitink can proceed with a complete review :)

Yes, I would like to go ahead and do a complete review on this theme.

@usharia, please submit a revised version of this theme, with all the issues reported above fixed. Once, you do that. I will do a thorough and detailed review of this theme.

comment:36 usharia6 months ago

Hello,

I will be working on the theme options in the gold theme. In the past few days, I have noticed that all that I have included in my theme options might not be acceptable. Can you please do a quick review of theme options and let me know if I need to change or remove something?

Thanks
Manas

comment:37 rohitink6 months ago

  1. You should use WordPress's default Backgroud Option for your theme, rather than implementing it from theme options.
  1. There is an option under the Background Color to upload something. It is not clear, what are you wanting the user to upload. Secondly, it says "Change the Background CSS", no option to do that.
  1. Remove the option to enable or disable Top Menu. Top Menu should be automatically displayed in the specified locations, when its set from Appearance > Menus.
  1. External Links in Theme options should open in a New Tab/Window.

Everything else seems fine. I would only recommend you to add more clearler description about what a particular setting does.

This is not a review of the complete theme, but only theme options.

Last edited 6 months ago by rohitink (previous) (diff)

comment:38 ZGani6 months ago

@Rohitink - this theme has a new ticket here: http://themes.trac.wordpress.org/ticket/15070 if you'd like to pick it please :)

comment:39 rohitink6 months ago

  • Resolution set to not-approved
  • Status changed from reviewing to closed

@ZGani, Thanks for the update.

I wonder why the ticket wasn't appended here.

Closing this ticket, as newer version has been uploaded.

Note: See TracTickets for help on using tickets.