WordPress.org

Make WordPress Themes

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#17116 closed theme (live)

THEME: Ex Astris - 1.0.1

Reported by: pollyplummer Owned by: emiluzelac
Priority: new theme Keywords: theme-ex-astris child-theme parent-stargazer
Cc: keepingcozy@…

Description

Ex Astris - 1.0.0

Ex Astris is a WordPress child theme for the excellent <a href="http://themehybrid.com/themes/stargazer">Stargazer</a> theme from <a href="http://themehybrid.com/">Theme Hybrid</a>. This bold theme was designed for bloggers. Make it your own with a customer header and custom background. The theme supports all of the custom layouts found in the Stargazer parent theme, including 1 Column Wide, 1 Column Narrow, 2 Columns: Content / Sidebar, and 2 Columns: Sidebar / Content.

Theme URL - http://themehybrid.com/themes/ex-astris
Author URL - http://untame.net

SVN - https://themes.svn.wordpress.org/ex-astris/1.0.0
ZIP - https://wordpress.org/themes/download/ex-astris.1.0.0.zip?nostats=1
Parent Theme: https://wordpress.org/themes/stargazer

History:

Ticket Summary Status Resolution Owner
#17116 THEME: Ex Astris - 1.0.1 closed live emiluzelac

(this ticket)

#17178 THEME: Ex Astris - 1.0.2 closed live emiluzelac
#17182 THEME: Ex Astris - 1.0.3 closed live emiluzelac
#17191 THEME: Ex Astris - 1.0.4 closed live emiluzelac


https://themes.svn.wordpress.org/ex-astris/1.0.0/screenshot.png

Change History (26)

#1 @emiluzelac
4 years ago

  • Keywords changed from theme-ex-astris, child-theme, parent-stargazer to theme-ex-astris child-theme parent-stargazer
  • Owner set to emiluzelac
  • Status changed from new to reviewing

#2 @emiluzelac
4 years ago

Before we can set this Theme live, can we address two minor details please?

  • footer.php allows us to have one credit link, other than WordPress.org. Link to the parent Theme either needs to be removed or turned off by default. (Assuming you want to keep your own that is)
  • Google font wp_register_style('googleFonts', 'http://fonts.googleapis.com/css?family=Copse'); will cause issues if/when user has SSL set. The most easiest fix to this would be to remove http: completely. wp_register_style('googleFonts', '//fonts.googleapis.com/css?family=Copse'); and no worries all will work just the same.

I will keep this ticket open for 7 days allowing you to fix the items listed above. Once they are fixed, please re-upload and we'll go from there :)

Thanks!

Last edited 4 years ago by emiluzelac (previous) (diff)

#3 follow-up: @emiluzelac
4 years ago

Edit: remove http: only not http:// as I posted above, sorry :)

#4 in reply to: ↑ 3 @pollyplummer
4 years ago

Thank you for your help! I have made the changes you suggested and have re-uploaded :)

#5 @emiluzelac
4 years ago

No problem. I still don't see new version :)

#6 @pollyplummer
4 years ago

Just did it about two minutes ago. Is there a delay?

#7 @emiluzelac
4 years ago

It should not be, usually this is done instantaneously.
When you submitted the Child Theme, did the system give you the ticket number?

#8 @pollyplummer
4 years ago

Oh wait, it looks like it failed - says I need to increase the version number. Is that required ?

#9 follow-up: @emiluzelac
4 years ago

Yep, very much so. Just up to i.e. 1.0.1 and you should be all right.

#10 @themetracbot
4 years ago

  • Summary changed from THEME: Ex Astris - 1.0.0 to THEME: Ex Astris - 1.0.1

Ex Astris - 1.0.1

Ex Astris is a WordPress child theme for the excellent <a href="http://themehybrid.com/themes/stargazer">Stargazer</a> theme from <a href="http://themehybrid.com/">Theme Hybrid</a>. This bold theme was designed for bloggers. Make it your own with a customer header and custom background. The theme supports all of the custom layouts found in the Stargazer parent theme, including 1 Column Wide, 1 Column Narrow, 2 Columns: Content / Sidebar, and 2 Columns: Sidebar / Content.

Theme URL - http://themehybrid.com/themes/ex-astris
Author URL - http://untame.net

SVN - https://themes.svn.wordpress.org/ex-astris/1.0.1
ZIP - https://wordpress.org/themes/download/ex-astris.1.0.1.zip?nostats=1
Parent Theme: https://wordpress.org/themes/stargazer

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=/ex-astris/1.0.0&new_path=/ex-astris/1.0.1

History:

Ticket Summary Status Resolution Owner
#17116 THEME: Ex Astris - 1.0.1 closed live emiluzelac

(this ticket)

#17178 THEME: Ex Astris - 1.0.2 closed live emiluzelac
#17182 THEME: Ex Astris - 1.0.3 closed live emiluzelac
#17191 THEME: Ex Astris - 1.0.4 closed live emiluzelac


https://themes.svn.wordpress.org/ex-astris/1.0.1/screenshot.png

#11 in reply to: ↑ 9 @pollyplummer
4 years ago

Thank you for your help - re-upload complete. :)

#12 @emiluzelac
4 years ago

  • Resolution set to live
  • Status changed from reviewing to closed

Requirements fixed, no other issues found. Approved.

Thank You!

Last edited 4 years ago by emiluzelac (previous) (diff)

#13 @chipbennett
4 years ago

Default background image - "<a href="http://www.flickr.com/photos/zanthia/4290315489/">green</a>" - landscape near Hekla (Iceland) - by Chris Zielecki - <a href="http://creativecommons.org/licenses/by-nc-sa/2.0/">cc</a> license

No Creative Commons license (except CC0, which is Public Domain) - and especially CC licenses with use restrictions such as "Non-Commercial" - is compatible with GPL. Please use a default background with a GPL-compatible license, and re-submit.

#14 @emiluzelac
4 years ago

@Chip I usually don't search for images to that extent, but yes, you're right.

#16 @emiluzelac
4 years ago

I did not even see that :(

#18 @pollyplummer
4 years ago

Thank you for clarifying. Sorry if this is a dopey question but how do I upload new versions of my theme? Is it like plugins where you get SVN access? Or do I always use the form at: https://wordpress.org/themes/upload/ I've selected a new image with a CC0 license.

#19 @pollyplummer
4 years ago

Sent the updated version with cc0 licensed image. Sorry for the inconvenience.

#20 @emiluzelac
4 years ago

No worries and sorry as well, I was out all morning. Yes, always via upload, unfortunately we don't have the SVN privileges.

#21 @greenshady
4 years ago

I just wanted to note that Emil's advice about only one credit link was correct. His assessment of the code was not, however. There was only a single theme credit link in the footer. The other two links were to WordPress.org and the user's home page.

#22 @emiluzelac
4 years ago

I don't think so, my assessments were pretty solid (at least to me)

Copyright © 2014 Ex Astris. Powered by WordPress and Stargazer.

  • Ex Astris
  • WordPress
  • Stargazer
<p class="credit">
    <?php printf(
    /* Translators: 1 is current year, 2 is site name/link, 3 is WordPress name/link, and 4 is theme name/link. */
    __( 'Copyright &#169; %1$s %2$s. Powered by %3$s and %4$s.', 'ex-astris' ),
date_i18n( 'Y' ), hybrid_get_site_link(), hybrid_get_wp_link(), hybrid_get_theme_link()
); ?>
</p><!-- .credit -->
<a class="site-link" href="http://untame.net/ex-astris" rel="home">Ex Astris</a>. Powered by <a class="wp-link" href="http://wordpress.org" title="State-of-the-art semantic personal publishing platform">WordPress</a> and <a class="theme-link" href="http://themehybrid.com/themes/stargazer" title="Stargazer WordPress Theme">Stargazer</a>

That would be 2 links correct? Excluding WPORG :)

Last edited 4 years ago by emiluzelac (previous) (diff)

#23 @pollyplummer
4 years ago

The first link is not a credit link. It is the site name/ link of the site where it is installed - so in my demo site, the site name was Ex Astris. But if you install it on another site, it will show your own site's name and link there.

#24 @emiluzelac
4 years ago

Ah shocks, I am so sorry, this is second error in your review and I feel like a complete beginner. Please re-submit and I will approve and make the Theme live asap :(

In past few days I am trying to do impossible and it doesn't seem to be working the way it should. Apologizes to you both! Need to pay more attention.

#25 @pollyplummer
4 years ago

Emil - No worries and thank you for all you do in reviewing themes. I really appreciate your help. New version is now uploaded with the Stargazer credit link added back in.

Last edited 4 years ago by pollyplummer (previous) (diff)

#26 @emiluzelac
4 years ago

Beer is on me and done :)

Note: See TracTickets for help on using tickets.