WordPress.org

Make WordPress Themes

Opened 4 years ago

Closed 3 years ago

#17596 closed theme (live)

THEME: Carrot Lite - 1.5.2

Reported by: MichalPawelczyk Owned by: alex27
Priority: new theme Keywords: theme-subtle
Cc: hello@…

Description

Carrot Lite - 1.0

Light and clean blog theme with a lot of white (ok, light gray to be honest) space

Theme URL - http://michal-pawelczyk.net/project/carrot-lite/
Author URL - http://michal-pawelczyk.net

SVN - https://themes.svn.wordpress.org/carrot-lite/1.0
ZIP - https://wordpress.org/themes/download/carrot-lite.1.0.zip?nostats=1

History:


https://themes.svn.wordpress.org/carrot-lite/1.0/screenshot.png

Attachments (1)

Screen Shot 2014-04-03 at 14.54.30.png (55.3 KB) - added by alex27 4 years ago.

Download all attachments as: .zip

Change History (30)

#1 @alex27
4 years ago

  • Owner set to alex27
  • Status changed from new to reviewing

#2 @alex27
4 years ago

REQUIRED

CODE

  • Themes must not generate any PHP Errors, Notices or Warnings

WARNING: wp-content/themes/carrot-lite/functions.php:202 - Illegal string offset 'link'
NOTICE: wp-content/themes/carrot-lite/functions.php:202 - Uninitialized string offset: 0
NOTICE: wp-content/themes/carrot-lite/functions.php:202 - Undefined index: link

  • The Protocol(http://) is not needed when enqueuing google fonts (and hard coding http might cause problems). Do it like this:
    wp_register_style( 'fontUbuntu', '//fonts.googleapis.com/css?family=Ubuntu:400,300,500,700,700italic&subset=latin,latin-ext');
    
  • Drop the wp_register_style and proceed straight to wp_enqueue_style() like this:
    wp_enqueue_style( 'fontUbuntu', '//fonts.googleapis.com/css?family=Ubuntu:400,300,500,700,700italic&subset=latin,latin-ext');
    

Same goes for scripts.

  • You’re using ‘carrotlite_page_menu’ as fallback for wp_nav_menu() but this function is not defined anywhere.
  • You need to properly escape home_url() function, like so: esc_url( home_url() ). Be sure to check all occurrences.
  • Remove all remove_action(); calls. This is plugin territory.
  • Remove xmlrpc_methods_filter() function. This is plugin territory.
  • You’ve got two function filtering wp_title. Maybe you could merge them into one function?
  • comment reply script should be enqueued from functions.php

OTHER

  • Themes are required to declare copyright and license information as specified by the applicable license, e.g.:
    Themename WordPress theme, Copyright (C) 2014 YOUR NAME or YOUR COMPANY NAME
    Themename WordPress theme is licensed under the LICENSE NAME.
    
  • Themes must provide explicit credit and license info for all resources bundled with the theme (fonts, scripts, images), like so:

[Theme name] Uses [Resource Name and URL], licensed under [Name of license].

CONCLUSION

Please fix above issues and upload new version of your theme, I'll leave this ticket open for another 2-3 days. Feel free to ask if you have any questions.

#3 @themetracbot
4 years ago

  • Summary changed from THEME: Carrot Lite - 1.0 to THEME: Carrot Lite - 1.1

#4 @alex27
4 years ago

Hello!

Previous issues have been resolved, but I noticed something else - your implementation of front-page.php is wrong:

  • you must allow for user to display static page as home page (no blog)
  • you must respect user settings regarding number of posts per page (Settings > Reading)
  • the message on top (if used) is displayed on every page
  • you should provide instructions on how to set the top message

Aside from that there's an issue with footer menu (when using multilevel menu) - see screenshot.

#5 @themetracbot
4 years ago

  • Summary changed from THEME: Carrot Lite - 1.1 to THEME: Carrot Lite - 1.2

#6 @MichalPawelczyk
4 years ago

OK, I fixed the issues you pointed out, and added the info about the big message in the template file. Is that OK, or should I put the info somewhere else?

#7 @alex27
4 years ago

The front page is still not properly implemented. Using page template intended to be used as front page is not allowed. File home.php should be present only when using front-page.php. Please read the following post for explanation.
Why not consider different approach? You could use theme customizer to add text field for the custom message to be displayed on the home page. Then simply use conditional statements to display it in index.php when appropriate. Just a suggestion.

Last edited 4 years ago by alex27 (previous) (diff)

#8 @themetracbot
4 years ago

  • Summary changed from THEME: Carrot Lite - 1.2 to THEME: Carrot Lite - 1.3

#9 @MichalPawelczyk
4 years ago

Thanks for your suggestion, it proved right :-) I changed the index template and got rid of home and home-page.

#10 @alex27
4 years ago

Hello!

Some small fixes remaining:

  • User input data must be sanitised on input and escaped on output. Escape the intro text upon output with esc_textarea. You could use sanitize_text_field as sanitize callback.
  • Notice: Undefined variable: front_message in /wordpress/wp-content/themes/carrot-lite/page.php on line 6

Also - all global variable names need to be properly prefixed (the same way as functions).

#11 @themetracbot
4 years ago

  • Summary changed from THEME: Carrot Lite - 1.3 to THEME: Carrot Lite - 1.4

#12 @alex27
4 years ago

  • Keywords theme-subtle added; theme-carrot-lite removed

Almost there, but you mixed the functions.
Sanitization should be done via the add_setting() method of the WP_Customizer object, which accepts 'sanitize_callback’ argument. You could use sanitize_text_field as callback function. Detailed tutorial can be found on Theme Shaper.
The escaping with esc_textarea should be done only when you output the data on front end (i.e. page.php).

#13 @themetracbot
4 years ago

  • Summary changed from THEME: Carrot Lite - 1.4 to THEME: Carrot Lite - 1.4.1

#14 @alex27
4 years ago

  • Status changed from reviewing to approved

All previous issues have been resolved. Marking theme as APPROVED.

#15 @chipbennett
4 years ago

  • Status changed from approved to reopened

#16 @chipbennett
4 years ago

  • Status changed from reopened to reviewing

Required

  • Shadowbox.js license is not GPL-compatible: http://www.shadowbox-js.com/LICENSE
  • No license documented for bundled images
  • Move $content_width definition inside the Theme setup function
  • Actions/filters must use callbacks, not anonymous functions. e.g.:
    add_filter('gallery_style', create_function('$a', 'return "<div class=\'gallery\'>";'));
    

Note

File home.php should be present only when using front-page.php.

Not really true. The home.php template file can be included at any time; however, it must be used as intended: as the blog posts index template.

#17 @themetracbot
4 years ago

  • Summary changed from THEME: Carrot Lite - 1.4.1 to THEME: Carrot Lite - 1.5

#18 follow-up: @MichalPawelczyk
4 years ago

  • shadowbox replaced by another script (licensed under MIT license)
  • $content_width definition already was outside the setup function
  • anonymouss function replaced with a callback
  • images removed (they were used by shadowbox)

I hope it'll be OK now :-)

#19 in reply to: ↑ 18 ; follow-up: @chipbennett
4 years ago

Replying to MichalPawelczyk:

  • $content_width definition already was outside the setup function

The $content_width definition needs to be moved inside the Theme setup function.

#20 @themetracbot
4 years ago

  • Summary changed from THEME: Carrot Lite - 1.5 to THEME: Carrot Lite - 1.5.1

#21 in reply to: ↑ 19 @MichalPawelczyk
4 years ago

Replying to chipbennett:

The $content_width definition needs to be moved inside the Theme setup function.

You're right, I must have missed that somehow :-(
Anyway, a new version is uploaded.

#22 follow-up: @alex27
3 years ago

shadowbox replaced by another script (licensed under MIT license)

You need to provide copyright & license info for that script too. Also what is the script at the beginning of script.js file? If it's some third-party script you also need to provide it's credit and license info.

#23 @themetracbot
3 years ago

  • Summary changed from THEME: Carrot Lite - 1.5.1 to THEME: Carrot Lite - 1.5.2

#24 in reply to: ↑ 22 @MichalPawelczyk
3 years ago

You need to provide copyright & license info for that script too. Also what is the script at the beginning of script.js file? If it's some third-party script you also need to provide it's credit and license info.

Tidied up, uploaded a new version

Last edited 3 years ago by MichalPawelczyk (previous) (diff)

#25 @alex27
3 years ago

  • Status changed from reviewing to approved

All issues have been fixed. Marking theme as APPROVED.

#26 @MichalPawelczyk
3 years ago

Great, thanks a lot!
What should I do to make it available in the themes directory?

#27 @MichalPawelczyk
3 years ago

OK, it's been 9 days since this theme was approved, and it still can't be found in the theme directory. What are the next steps of the procedure? Any info would be appreciated :-)

#28 @alex27
3 years ago

You wait :) The admins do the final approval and make themes live.

#29 @emiluzelac
3 years ago

  • Resolution set to live
  • Status changed from approved to closed

Marking live per reviewers approval only.

Some approved Themes are almost month old and whatever we didn't catch now, we will on the next Theme update.

We don't have the manpower to scrutinize each ticket anymore :(

Note: See TracTickets for help on using tickets.