WordPress.org

Make WordPress Themes

Opened 4 years ago

Closed 4 years ago

#17897 closed theme (live)

THEME: Slipstream - 1.1.3

Reported by: themelab Owned by: yoarts
Priority: new theme Keywords: theme-slipstream
Cc: tim@…

Attachments (1)

slipstream-1.1.zip (143.6 KB) - added by themelab 4 years ago.
Amendments as requested

Download all attachments as: .zip

Change History (22)

#1 @esmi
4 years ago

  • Owner set to yoarts
  • Status changed from new to reviewing

#2 @yoarts
4 years ago

Required:

  1. Themes must provide a unique slug for anything in the public namspace, including translation textdomain, all custom function names, classes, hooks, public/global variables, database entries (Theme options, post custom metadata, etc.)
  2. Please using: "slipstream_..." instead of "themelab_..."
  3. Remove: config.codekit
  4. Remove:
    * @package ThemeLab
    * @subpackage ThemeLab
    * @author Tim Carr
    * @version 1.0
    * @copyright ThemeLab
    
  5. Themes are required to enqueue all stylesheets and scripts, using wp_enqueue_style()/wp_enqueue_script(), and hooked into an appropriate hook via callback function, rather than hard-coding stylesheet/script links or tags in the template.
    <!--[if lt IE 9]>
    <script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>
    <script src="<?php echo get_stylesheet_directory_uri(); ?>/js/selectivizr-min.js"></script>
    <![endif]-->
    

Please go over the http://codex.wordpress.org/Theme_Review and make sure that the rest is good.
My review based this guideline: http://make.wordpress.org/themes/guidelines/

Please feel free to re-submit the updated version of this theme.

#3 @yoarts
4 years ago

Any update @themelab ?

#4 @themelab
4 years ago

Will re-submit the updated version of the theme tomorrow (Monday 14th April)

#5 @yoarts
4 years ago

Any update @themelab?

#6 @themelab
4 years ago

Will re-submit the updated version of the theme today (Monday 14th April)

@themelab
4 years ago

Amendments as requested

#7 @themelab
4 years ago

Any update @yoarts?

#8 @yoarts
4 years ago

Please resubmit your updated theme on this page: https://wordpress.org/themes/upload/

#9 @themetracbot
4 years ago

  • Summary changed from THEME: Slipstream - 1.1 to THEME: Slipstream - 1.1.1

#10 follow-up: @yoarts
4 years ago

From previous review:

  1. Themes must provide a unique slug for anything in the public namspace, including translation textdomain, all custom function names, classes, hooks, public/global variables, database entries (Theme options, post custom metadata, etc.)

=> Not Resolved. Some class name located on _modules/widgets still not provide a unique slug

  1. Please using: "slipstream_..." instead of "themelab_..."

=> Not Resolved. Please check those files: index.php, archive.php, sidebar_footer.php, sidebar.php

  1. Remove: config.codekit

=> Resolved

  1. Remove:
    * @package ThemeLab
    * @subpackage ThemeLab
    * @author Tim Carr
    * @version 1.0
    * @copyright ThemeLab
    

=> Not Resolved

  1. Themes are required to enqueue all stylesheets and scripts, using wp_enqueue_style()/wp_enqueue_script(), and hooked into an appropriate hook via callback function, rather than hard-coding stylesheet/script links or tags in the template.
<!--[if lt IE 9]>
<script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>
<script src="<?php echo get_stylesheet_directory_uri(); ?>/js/selectivizr-min.js"></script>
<![endif]-->

=> Not Resolved

New issues:

  1. All resources license must be compatible with gpl, and listed on readme.txt
  2. Please remove those part on readme.txt file: Frequently Asked Questions, Screenshots
  3. Issue from "Theme Check" plugin:
* RECOMMENDED: Text domain problems in _modules/widgets/business-hours.php. You have not included a text domain!
* RECOMMENDED: Text domain problems in _modules/widgets/business-hours-extended.php. You have not included a text domain!
* WARNING: The flexible-width and fixed-width tags changed to fluid-layout and fixed-layout tags in WordPress 3.8. Additionally, the responsive-layout tag was added. Please change to using one of the new tags.
* RECOMMENDED: Screenshot size should be 880x660, to account for HiDPI displays. Any 4:3 image size is acceptable, but 880x660 is preferred.
* RECOMMENDED: Screenshot dimensions are wrong! Ratio of width to height should be 4:3.
* RECOMMENDED: No reference to add_theme_support( "custom-header", $args ) was found in the theme. It is recommended that the theme implement this functionality if using an image for the header.
* INFO: Possible hard-coded links were found in the file footer.php.
  1. Issue from "Theme Mentor" plugin:
Script tags should be included on wp_enqueue_scripts or admin_enqueue_scripts instead of embedded directly at file header.php, line 24: <script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>
Script tags should be included on wp_enqueue_scripts or admin_enqueue_scripts instead of embedded directly at file header.php, line 25: <script src="<?php echo get_stylesheet_directory_uri(); ?>/js/selectivizr-min.js"></script>
The only possible spelling of WordPress is with capital W and capital P. at file _modules/widgets/about-box.php, line 26: * @param string $args Native Wordpress Vars
The only possible spelling of WordPress is with capital W and capital P. at file _modules/widgets/authors.php, line 24: * @param string $args Native Wordpress Vars
The only possible spelling of WordPress is with capital W and capital P. at file _modules/widgets/business-hours-extended.php, line 35: * @param string $args Native Wordpress Vars
The only possible spelling of WordPress is with capital W and capital P. at file _modules/widgets/business-hours.php, line 35: * @param string $args Native Wordpress Vars
The only possible spelling of WordPress is with capital W and capital P. at file _modules/widgets/contact.php, line 24: * @param string $args Native Wordpress Vars
The only possible spelling of WordPress is with capital W and capital P. at file _modules/widgets/location.php, line 24: * @param string $args Native Wordpress Vars
The only possible spelling of WordPress is with capital W and capital P. at file _modules/widgets/map.php, line 33: * @param string $args Native Wordpress Vars
The only possible spelling of WordPress is with capital W and capital P. at file _modules/widgets/social-icons.php, line 34: * @param string $args Native Wordpress Vars
The only possible spelling of WordPress is with capital W and capital P. at file _modules/widgets/subscribe.php, line 27: * @param string $args Native Wordpress Vars
wp_footer call should be right before the closing body tag. at file footer.php, line 47
  1. Large image spilled outside the Text widget:

http://i.imgur.com/aHQVRCH.png

#11 in reply to: ↑ 10 @themelab
4 years ago

Please ensure you are reviewing the correct theme.

I have downloaded https://wordpress.org/themes/download/slipstream.1.1.1.zip?nostats=1, as submitted in this ticket prior to your review:

  1. _modules/widgets does not exist any more:

http://cl.ly/image/1T0Q2r0q0W2O

  1. This has already been done, and files double checked.
  1. This has already been done, and files double checked.
  1. This has already been done, and files double checked.
  1. Noted
  1. Noted
  1. Noted
  1. This has already been done, and files double checked. Dupe of 1 - 5
  1. Noted

6, 7, 8 and 10 will be resolved once you're able to confirm you have reviewed the correct theme package and you've confirmed that 1, 2, 4, 5 and 9 are already resolved.

#12 @themelab
4 years ago

Any update @yoarts?

#13 @yoarts
4 years ago

Sorry for later reply.
AboutBoxWidget, CommentsWalker, CustomNavMenuWalker, etc ... classes must have a Prefix (Now those codes located in functions.php file)
And please fix issue 6,7,8, 10 then I will complete review.

#14 @themetracbot
4 years ago

  • Summary changed from THEME: Slipstream - 1.1.1 to THEME: Slipstream - 1.1.2

#15 @yoarts
4 years ago

  • Status changed from reviewing to approved

#16 @themelab
4 years ago

When / how / will this appear on wordpress.org please?

#17 @emiluzelac
4 years ago

  • Status changed from approved to reopened

#18 @emiluzelac
4 years ago

footer.php contains Google Analytics tracker, which we do not allow and it needs to be removed. Also remove the word "premium" from your footer area, that is classified as SPAM. In functions Theme uses http protocol with Google Fonts, that will create issues with https if use.

#19 @themetracbot
4 years ago

  • Summary changed from THEME: Slipstream - 1.1.2 to THEME: Slipstream - 1.1.3

#20 @emiluzelac
4 years ago

  • Status changed from reopened to reviewing

#21 @emiluzelac
4 years ago

  • Resolution set to live
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.