WordPress.org

Make WordPress Themes

Opened 3 years ago

Closed 2 years ago

#23945 closed theme (not-approved)

THEME: Asteria Lite2 – 3.0.3

Reported by: k-productions inc Owned by: Fab1en
Priority: new theme Keywords: theme-asteria-lite2
Cc: krsnyder60@…

Description

Asteria Lite2 - 3.0.3

Asteria Lite2 is a clean responsive theme with a beautiful slider, Narrow and Wide Layout Option, 10 Social Icons and 3 page templates – Full width page, Left sidebar page and a Blog page Template. The theme also allows you to design your site logo with 600+ fonts. The Theme also has a Maintenance Mode feature, Beautiful Gallery feature, Custom CSS feature, Import/Export feature and is fully compatible with Woocommerce and Contact Form 7 Plugin. It also comes with Ajax pagination feature which means you can navigate through posts without page refresh. The theme is SEO Friendly and has plenty of user-friendly options. The theme is translation ready and fully translated into French, Italian, German, Spanish, and Chinese. Asteria Lite is suitable for any types of website – corporate, portfolio, business, blog. Get Free Support without registration on http://www.towfiqi.com/forums/forum/asteria-lite

Theme URL - http://www.towfiqi.com/asteria-lite-free-wordpress-theme.html
Author URL - http://www.towfiqi.com/

SVN - https://themes.svn.wordpress.org/asteria-lite2/3.0.3
ZIP - https://wordpress.org/themes/download/asteria-lite2.3.0.3.zip?nostats=1

History:

Ticket Summary Status Resolution Owner
#23945 THEME: Asteria Lite2 – 3.0.3 closed not-approved Fab1en

(this ticket)


https://themes.svn.wordpress.org/asteria-lite2/3.0.3/screenshot.png

Change History (5)

#1 @themetracbot
3 years ago

  • Owner set to Fab1en
  • Status changed from new to reviewing

#2 @Fab1en
2 years ago

With the unit test data installed, I found an issue when displaying the "Blog" page with your theme. If Front page displays => Your latest posts option is checked, the "blog" page is displayed by the page-blog.php template, and the pagination is broken.

In my opinion, all your page-xxx.php templates are wrong : if you look at the template hierarchy, those templates will be used by default for pages with a name that match the xxx part (page-$slug.php), which is not your intention I guess. You should rename those custom page templates so that them don't match page-$slug.php.

So to sum-up, there are 2, unrelated, bugs :

  1. pagination is broken on "Blog Page Template"
  2. custome page template files should be renamed to avoid using them with pages that have the "blog", "fullwidth" or "leftsidebar" slugs.

#3 @Fab1en
2 years ago

I found another issue in the customizer : when selecting a new color as the "Secondary Element background Color", the change is set live in the preview, but only the color of the dots in the home slider change. Background color for slider titles, blocks and buttons, hover color for pagination, etc do not change. You have to save the settings and reload the page to show the color modification.

The issue is the same for "Asteria text color" panel.

In my opinion, you should regroup all the color settings into one "Color" panel, and put "Asteria" on each control name instead of the panel title.

Last edited 2 years ago by Fab1en (previous) (diff)

#4 @Fab1en
2 years ago

I try to use the "Slider" option, but cannot achieve what I wanted. I added 1 slide, saved the options, checked the home page to see that my slide was there. But then, when I want to add a new slide, I cannot. The "add new slide" button does not display anymore.

#5 @Fab1en
2 years ago

  • Resolution set to not-approved
  • Status changed from reviewing to closed

in functions.php, I found

//LOAD DYNAMIC CSS
get_template_part('style');

I think this is wrong. You should only do this inside an action hook (wp_enqueue_scripts or wp_head).

Also, the theme review handbook says that

No hard coding of scripts, styles and Favicons unless a browser workaround script.
Everything should be enqueued.

But I understand that this is not easy to achieve for dynamic style that needs some php work.

The issue is a little bit different for javascript.
Here, you do include it via an action hook :

//Load RAW Java Scripts 
add_action('wp_footer', 'znn_load_js');
function znn_load_js() { 
	include(get_template_directory() . '/javascript.php');
}

But I think this is not needed as your php logic inside javascript.php can easily be moved elsewhere. For example, you could use the $asteria['slider_type_id'] variable to add a class to the body tag, and then check the existence of this class in your javascript. Your theme options can also be passed to JavaScript using wp_localize_script (see this example in the theme review handbook).

Note: See TracTickets for help on using tickets.