WordPress.org

Make WordPress Themes

Opened 3 years ago

Closed 3 years ago

#24372 closed theme (live)

THEME: Enlightenment – 1.1.2

Reported by: pseudoxiah Owned by: downstairsdev
Priority: theme update Keywords: theme-enlightenment
Cc: contact@…

Description

Enlightenment - 1.1.0

Our flagship multipurpose theme powered by Enlightenment Framework. With a clean, modern and responsive design backed by a powerful and flexible code base. Showcase any type of content anywhere. Create unlimited layouts. Customize all templates to your preference. Take WordPress as CMS to another level.

Theme URL - https://www.onedesigns.com/themes/enlightenment
Author URL - https://www.onedesigns.com/

SVN - https://themes.svn.wordpress.org/enlightenment/1.1.0
ZIP - https://wordpress.org/themes/download/enlightenment.1.1.0.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=enlightenment/1.0.15&new_path=enlightenment/1.1.0

History:

Ticket Summary Status Resolution Owner
#11152 THEME: Enlightenment - 1.0 closed not-approved emiluzelac
#20083 THEME: Enlightenment - 1.0.8 closed live alex27
#22147 THEME: Enlightenment - 1.0.9 closed live karmatosed
#22226 THEME: Enlightenment - 1.0.10 closed live karmatosed
#22229 THEME: Enlightenment - 1.0.13 closed live hardeepasrani
#22481 THEME: Enlightenment - 1.0.15 closed live catchthemes
#24372 THEME: Enlightenment – 1.1.2 closed live downstairsdev

(this ticket)

#24828 THEME: Enlightenment – 1.1.3 closed live jcastaneda
#25762 THEME: Enlightenment – 1.1.4 closed live akhlesh nagar


https://themes.svn.wordpress.org/enlightenment/1.1.0/screenshot.png

Change History (9)

#1 @downstairsdev
3 years ago

  • Owner set to downstairsdev
  • Status changed from new to reviewing

#2 @downstairsdev
3 years ago

Hey there! Thanks for submitting an update. Just a few questions I came across when reviewing the udpates:

The language/enlightenment.pot file looks incorrect. There are a lot of references to the default theme (twentythirteen, twentyfourteen, etc.). Can you either update this or remove so that translators don't get confused?

I started to test the new sidebar feature. When go to theme option, then click "Sidebars", then click "Save Settings" I get a lot of notices:

Notice: Undefined index: background in /review/wp-content/themes/enlightenment/core/admin/unlimited-sidebars.php on line 570

Notice: Undefined index: image in /review/wp-content/themes/enlightenment/core/admin/validate.php on line 108

Notice: Undefined index: position in /review/wp-content/themes/enlightenment/core/admin/validate.php on line 111

Notice: Undefined index: repeat in /review/wp-content/themes/enlightenment/core/admin/validate.php on line 114

Notice: Undefined index: size in /review/wp-content/themes/enlightenment/core/admin/validate.php on line 117

Notice: Undefined index: scroll in /review/wp-content/themes/enlightenment/core/admin/validate.php on line 120

Notice: Undefined index: sidebar_title_color in /review/wp-content/themes/enlightenment/core/admin/unlimited-sidebars.php on line 572

Notice: Undefined index: sidebar_text_color in /review/wp-content/themes/enlightenment/core/admin/unlimited-sidebars.php on line 574

Notice: Undefined index: widgets_background_color in /review/wp-content/themes/enlightenment/core/admin/unlimited-sidebars.php on line 576

Notice: Undefined index: widgets_title_color in /review/wp-content/themes/enlightenment/core/admin/unlimited-sidebars.php on line 578

Notice: Undefined index: widgets_text_color in /review/wp-content/themes/enlightenment/core/admin/unlimited-sidebars.php on line 580

Notice: Undefined index: widgets_link_color in /review/wp-content/themes/enlightenment/core/admin/unlimited-sidebars.php on line 582

Can you try deleting the theme mods / settings and see if you can reproduce this issue?

I want to make sure sanitization is happening correctly for the new values that have been added to the options panel. To do that, I generally just test a value like this:

<script>alert('escaped?');</script>

When I saved that in the "Sidebar Title" option, it doesn't look like it is sanitized/escaped. Could you give me a little more background on how you are sanitizing those values?

Thanks!

#3 @pseudoxiah
3 years ago

Thank your for your review. I have accidentally configured Poedit to parse the entire themes directory and you are right about sidebar titles not being properly escaped, I will fix that in the next release.

My concern is about the notices when adding a new sidebar. I don't get such notices and I believe you are getting them because you have some old theme options stored in the database that don't have the above mentioned indexes which were introduced this version. Do I need to add backwards compatibility code to the theme for it to be accepted?

#4 @downstairsdev
3 years ago

Hi @pseudoxiah. These were my steps to reproduce.

I deleted "enlightenment_theme_options" from the options table.

Then I logged into the install and clicked "Theme Options", and then the "Sidebars" tab. I entered "Hello" for the sidebar description (that's the only thing I entered in the panel) and then clicked "Save". That's when I got the notices.

I am testing this on PHP5.5. Let me know what you find!

#5 @pseudoxiah
3 years ago

Thank you for your answers. This sheds some light on the matter. There are 2 issues here:

  1. Internally all sidebars require a title. If you add a title no more errors will appear. I will make it so sidebars won't be saved unless they have a title.
  1. There is a specific button for adding a new sidebar below the new sidebar form and there is a "Delete Sidebar" next to every existing sidebar. Hitting the "Save Settings" won't work for adding and deleting sidebars; this is properly documented in this tutorial.

#6 @downstairsdev
3 years ago

Okay, makes sense. I was trying to break things that might come up as edge cases. Also wanted to make sure all the data was being sanitized properly.

#7 @themetracbot
3 years ago

  • Summary changed from THEME: Enlightenment – 1.1.0 to THEME: Enlightenment – 1.1.2

Enlightenment - 1.1.2

Our flagship multipurpose theme powered by Enlightenment Framework. With a clean, modern and responsive design backed by a powerful and flexible code base. Showcase any type of content anywhere. Create unlimited layouts. Customize all templates to your preference. Take WordPress as CMS to another level.

Theme URL - https://www.onedesigns.com/themes/enlightenment
Author URL - https://www.onedesigns.com/

SVN - https://themes.svn.wordpress.org/enlightenment/1.1.2
ZIP - https://wordpress.org/themes/download/enlightenment.1.1.2.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=enlightenment/1.1.0&new_path=enlightenment/1.1.2

History:

Ticket Summary Status Resolution Owner
#11152 THEME: Enlightenment - 1.0 closed not-approved emiluzelac
#20083 THEME: Enlightenment - 1.0.8 closed live alex27
#22147 THEME: Enlightenment - 1.0.9 closed live karmatosed
#22226 THEME: Enlightenment - 1.0.10 closed live karmatosed
#22229 THEME: Enlightenment - 1.0.13 closed live hardeepasrani
#22481 THEME: Enlightenment - 1.0.15 closed live catchthemes
#24372 THEME: Enlightenment – 1.1.2 closed live downstairsdev

(this ticket)

#24828 THEME: Enlightenment – 1.1.3 closed live jcastaneda
#25762 THEME: Enlightenment – 1.1.4 closed live akhlesh nagar


https://themes.svn.wordpress.org/enlightenment/1.1.2/screenshot.png

#8 @downstairsdev
3 years ago

  • Status changed from reviewing to approved

Thanks for the updates!

#9 @karmatosed
3 years ago

  • Resolution set to live
  • Status changed from approved to closed

Congratulations, this theme is now live!

Note: See TracTickets for help on using tickets.