WordPress.org

Make WordPress Themes

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#26237 closed theme (not-approved)

THEME: Digital Presence – 1.0.0

Reported by: rociofatas Owned by: TimothyBlynJacobs
Priority: new theme Keywords: theme-digital-presence
Cc: rociofatas@…

Description

Digital Presence - 1.0.0

A one page, single page, customizer based WordPress theme.

Theme URL - http://underscores.me/
Author URL - http://tellmenature.com

SVN - https://themes.svn.wordpress.org/digital-presence/1.0.0
ZIP - https://wordpress.org/themes/download/digital-presence.1.0.0.zip?nostats=1

History:

Ticket Summary Status Resolution Owner
#26237 THEME: Digital Presence – 1.0.0 closed not-approved TimothyBlynJacobs

(this ticket)


https://themes.svn.wordpress.org/digital-presence/1.0.0/screenshot.png

Attachments (1)

digital-presence.zip (492.2 KB) - added by rociofatas 2 years ago.
Version 02

Download all attachments as: .zip

Change History (14)

#1 @themetracbot
2 years ago

  • Owner set to TimothyBlynJacobs
  • Status changed from new to reviewing

This ticket was mentioned in Slack in #themereview by timothybjacobs. View the logs.


2 years ago

#3 follow-up: @TimothyBlynJacobs
2 years ago

  • Resolution set to not-approved
  • Status changed from reviewing to closed

Hi rociofatas,

My name is Timothy. I'm going to be reviewing your theme.

At this time your theme isn't ready for inclusion in the WordPress themes directory. I've outlined a number of things that you must fix, and recommendations that you should fix. If something isn't clear let me know. This might not be all of the issues, but they are the ones that stood out to me upon first look.

Required

  • In your description_walker class you are treating $args as an object it is an array. This is causing notices to be displayed.
  • If a user selects show posts on front page, your theme should display the blog index, instead of the single page theme. Additionally, you shouldn’t hide this section from the customizer.
  • Menus are complicated. As you have them now it is impossible to access other pages on the site. I would recommend leaving the menu as it is, without overwriting the links. And instead display a custom menu built from the home page items selected.
  • Your text domain should be digital-presence not digitalpresence. You are also using text domain in some places as well as the _s text domain and Digital-Presence. You should only use digital-presence.
  • The display theme logo checkbox in the customizer does not seem to work
  • Footer text in the customizer does not work. It is displaying 0 for all values.
  • The customizer background image does not seem to work for the live preview.
  • You need to provide a template for the blog index page. It appears that your home.php file is blank which could be causing this issue.
  • Comments are displayed for password protected posts. Comments should not be displayed until a post password is entered.

Recommendations

  • Prefix the get_the_slug and the_slug functions.
  • Featured images aren’t being displayed on top of blog posts

Notes

  • Consider adding each page title in each homepage section

After all of the required issues are fixed, you can upload a new version of your theme and I will take another look at your theme.

#4 @jcastaneda
2 years ago

  • Resolution not-approved deleted
  • Status changed from closed to reopened

#5 @jcastaneda
2 years ago

  • Status changed from reopened to reviewing

#6 in reply to: ↑ 3 @rociofatas
2 years ago

Replying to TimothyBlynJacobs:

Hi rociofatas,

My name is Timothy. I'm going to be reviewing your theme.

At this time your theme isn't ready for inclusion in the WordPress themes directory. I've outlined a number of things that you must fix, and recommendations that you should fix. If something isn't clear let me know. This might not be all of the issues, but they are the ones that stood out to me upon first look.

Required

  • In your description_walker class you are treating $args as an object it is an array. This is causing notices to be displayed.
  • If a user selects show posts on front page, your theme should display the blog index, instead of the single page theme. Additionally, you shouldn’t hide this section from the customizer.
  • Menus are complicated. As you have them now it is impossible to access other pages on the site. I would recommend leaving the menu as it is, without overwriting the links. And instead display a custom menu built from the home page items selected.
  • Your text domain should be digital-presence not digitalpresence. You are also using text domain in some places as well as the _s text domain and Digital-Presence. You should only use digital-presence.
  • The display theme logo checkbox in the customizer does not seem to work
  • Footer text in the customizer does not work. It is displaying 0 for all values.
  • The customizer background image does not seem to work for the live preview.
  • You need to provide a template for the blog index page. It appears that your home.php file is blank which could be causing this issue.
  • Comments are displayed for password protected posts. Comments should not be displayed until a post password is entered.

Recommendations

  • Prefix the get_the_slug and the_slug functions.
  • Featured images aren’t being displayed on top of blog posts

Notes

  • Consider adding each page title in each homepage section

After all of the required issues are fixed, you can upload a new version of your theme and I will take another look at your theme.

Hi Timothy, thank you for your review and for your patience. I have been unable to sort out the front-page post pages so far (could only dedicate a little time today), so I just wanted to reach out to say thank you and that I will post again tomorrow, so that you know and don't close my review, please!!!!

#7 @rociofatas
2 years ago

Hello again Timothy. I have fixed the front page issue, it was caused by the menu system I had put together. Now, it is the menu I need to do again, but I don't have time right now, so I'll either take care of it tonight, or tomorrow.

Thanks for patience.

#8 @TimothyBlynJacobs
2 years ago

No problem!

#9 @rociofatas
2 years ago

So here I am. Sadly, I got stuck with the menu. I have changed the structure of the site and now the multi-section front page is created through a template. I've been trying to get the template to dynamically insert selected pages on main menu, alongside other items, but unfortunately, to no avail. I have the link structure in place and I am using bootstrap and an external walker for bootstrap, and I just can't for the life of me figure out how to merge it all together. I don't know if you might wish to see for yourself what I've done and give me a little help if you can, but otherwise, I will probably need sometime to get it all right. For now, I just need a break. So this version, is not error free yet, I have not debugged it, but the point of uploading it is so that you can see what I mean.

#10 in reply to: ↑ description @rociofatas
2 years ago

Replying to rociofatas:

Digital Presence - 1.0.0

A one page, single page, customizer based WordPress theme.

Theme URL - http://underscores.me/
Author URL - http://tellmenature.com

SVN - https://themes.svn.wordpress.org/digital-presence/1.0.0
ZIP - https://wordpress.org/themes/download/digital-presence.1.0.0.zip?nostats=1

History:

Ticket Summary Status Resolution Owner
#26237 THEME: Digital Presence – 1.0.0 closed not-approved TimothyBlynJacobs

(this ticket)


https://themes.svn.wordpress.org/digital-presence/1.0.0/screenshot.png

@rociofatas
2 years ago

Version 02

#11 @karmatosed
2 years ago

Please can you send the theme in again via the uploader rather than attaching a zip.

#12 @karmatosed
2 years ago

  • Resolution set to not-approved
  • Status changed from reviewing to closed

I am closing this ticket as you've not responded to the review. In future please respond, even to say you need more time within 7 days.

#13 @rociofatas
2 years ago

Hi well sorry I didn't have the chance to upload it again, to be honest, things have gone so slowly that I thought the seven days rule didn't even matter. And, on the other hand, I've received a notification of this event, once every 15 mins for the past 7.5 hours, that makes it a total of 30 times. Could you please make it stop?

Note: See TracTickets for help on using tickets.