WordPress.org

Make WordPress Themes

Opened 2 years ago

Closed 19 months ago

#28009 closed theme (live)

THEME: Nisarg – 1.2.4

Reported by: falgunihdesai Owned by: benlumia007
Priority: new theme Keywords: theme-nisarg
Cc: falgunihdesai@…, djrmom

Description

Nisarg - 1.0

Nisarg is clean, blog-focused, a lightweight, fully responsive and translation ready theme. Use the theme customizer to add your own header image, background image, to set background color, header backgound color and accent color(Supports seven different accent colors). Distinguish each post with one of the eight supported post formats, such as: Video, Image, Aside, Status, Audio, Quote, Link and Gallery. Uses Google Fonts for improved typeface readability and works perfectly in desktop browsers, tablets and handheld devices.

Theme URL -
Author URL - http://falgunidesai.com/

SVN - https://themes.svn.wordpress.org/nisarg/1.0
ZIP - https://wordpress.org/themes/download/nisarg.1.0.zip?nostats=1

History:

Ticket Summary Status Resolution Owner
#28009 THEME: Nisarg – 1.2.4 closed live benlumia007

(this ticket)

#31860 THEME: Nisarg – 1.2.5 closed live themetracbot
#33258 THEME: Nisarg – 1.2.6 closed live themetracbot
#41808 THEME: Nisarg – 1.2.7 closed live themetracbot
#41834 THEME: Nisarg – 1.2.8 closed live themetracbot
#41840 THEME: Nisarg – 1.2.8.1 closed live themetracbot


https://themes.svn.wordpress.org/nisarg/1.0/screenshot.png

Attachments (1)

nisarg.zip (4.4 MB) - added by falgunihdesai 2 years ago.
Updated Theme

Change History (44)

@falgunihdesai
2 years ago

Updated Theme

#1 @themetracbot
2 years ago

  • Summary changed from THEME: Nisarg – 1.0 to THEME: Nisarg – 1.1

Nisarg - 1.1

Nisarg is clean, blog-focused, fully responsive and translation ready theme. Use the theme customizer to add your own header image of flexible height, background image, to set background color, header backgound color and accent color(Supports seven different accent colors). Distinguish each post with one of the eight supported post formats, such as: Video, Image, Aside, Status, Audio, Quote, Link and Gallery. Uses Google Fonts for improved typeface readability and works perfectly in desktop browsers, tablets and handheld devices.

Theme URL -
Author URL - http://falgunidesai.com/

SVN - https://themes.svn.wordpress.org/nisarg/1.1
ZIP - https://wordpress.org/themes/download/nisarg.1.1.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=nisarg/1.0&new_path=nisarg/1.1

History:

Ticket Summary Status Resolution Owner
#28009 THEME: Nisarg – 1.2.4 closed live benlumia007

(this ticket)

#31860 THEME: Nisarg – 1.2.5 closed live themetracbot
#33258 THEME: Nisarg – 1.2.6 closed live themetracbot
#41808 THEME: Nisarg – 1.2.7 closed live themetracbot
#41834 THEME: Nisarg – 1.2.8 closed live themetracbot
#41840 THEME: Nisarg – 1.2.8.1 closed live themetracbot


https://themes.svn.wordpress.org/nisarg/1.1/screenshot.png

#2 @themetracbot
22 months ago

  • Owner set to monikarao
  • Status changed from new to reviewing

#3 @monikarao
22 months ago

Hello @falgunihdesai

I will start reviewing the theme,and I will get back to you shortly.

#4 @falgunihdesai
22 months ago

ok. Thanks.

#5 @falgunihdesai
21 months ago

Hello @monikarao,

waiting for your review.

#6 @monikarao
21 months ago

Hello @falgunihdesai

I have reviewed the theme and here are the results.

Please fix these issues and re-upload the theme with updated version number so that I can re-review it.

All the variables name should start with Theme name prefix.Please refer to http://themereview.co/prefix-all-the-things

For changes it’s great to have a changelog.txt file also. It is not Required but Recommended.

Add theme-options in Tags in style.css.

Monster Widget > Text > Large image: linked in a caption > there is no link on caption so check it.

Styling issue on Nav Menu and Tag Cloud.

On navigation > Menu Depth Level is not working.

Check style.css through W3C CSS Validator.

That's all!

Looking forward to updated version with these fixes.

Thanks.

Last edited 21 months ago by monikarao (previous) (diff)

#7 @falgunihdesai
21 months ago

Hello,

Thanks for the review.

I have fixed navigation menu issue.

Can you please point out what are the issues with Nav Menu and Tag Cloud. B'caz as per my checking there is no issue with them.

Falguni

#8 @monikarao
21 months ago

Hello,

It is not major issue.Its my review.

Nav Menu > Reduce sapcing after each submenu.
Tag Cloud > There should be space after each tag.

That's all!

Looking forward to updated version with these fixes.

Thanks.

#9 @themetracbot
21 months ago

  • Summary changed from THEME: Nisarg – 1.1 to THEME: Nisarg – 1.2

Nisarg - 1.2

Nisarg is a new fully responsive and translation ready theme that allows you to create stunning blogs and websites. Theme is well suited for travel, photography, recipe, design, art, personal and any other creative websites and blogs. The theme is developed using Bootstrap 3 that makes it mobile and tablets friendly. It has various options in WordPress Customizer to change look of the theme. Theme customizer can be used to add your own header image of flexible height, background image, to set background color, header text color and accent color(Supports seven different accent colors). Theme supports eight post formats, such as: Video, Image, Aside, Status, Audio, Quote, Link and Gallery.

Theme URL -
Author URL - http://falgunidesai.com/

SVN - https://themes.svn.wordpress.org/nisarg/1.2
ZIP - https://wordpress.org/themes/download/nisarg.1.2.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=nisarg/1.1&new_path=nisarg/1.2

History:

Ticket Summary Status Resolution Owner
#28009 THEME: Nisarg – 1.2.4 closed live benlumia007

(this ticket)

#31860 THEME: Nisarg – 1.2.5 closed live themetracbot
#33258 THEME: Nisarg – 1.2.6 closed live themetracbot
#41808 THEME: Nisarg – 1.2.7 closed live themetracbot
#41834 THEME: Nisarg – 1.2.8 closed live themetracbot
#41840 THEME: Nisarg – 1.2.8.1 closed live themetracbot


https://themes.svn.wordpress.org/nisarg/1.2/screenshot.png

#10 @falgunihdesai
21 months ago

Hello,

I have uploaded the new version of my theme. In the new version i have tried to solve all the issues you pointed out. Regarding the prefixing variables, all global variables are prefixed. Navigation menu is now working fine. Regarding issue "Monster Widget > Text > Large image: linked in a caption", please not that there is no link(current is href = "#") added to large image in the widget. So it is not a problem in my theme.

Please review it and let me know if you find anything else that need to be fixed.

Falguni

#11 @monikarao
21 months ago

Hello,

I have reviewed the theme and here are the results.

No reference to add_editor_style() was found in the theme.

On Navigation > Menu Depth Level is not working.(Right now it is working only for 1 level).

In readme.text > for Google Fonts you have to mention licence for each font you have used.

Here is the example-

Author: Google
Source: http://fonts.googleapis.com/css?family=Lato%7CRoboto%7COswald%7CLobster%7CPlay
License: SIL Open Font License 1.1

That's all!

Looking forward to updated version with these fixes.

Thanks.

#12 @falgunihdesai
21 months ago

Hello,

Thanks for the review.

Reference to add_editor_style() is recommended but not required. As i don't want to match editor style with my theme style i have not added css file for editor style.

Regarding menu depth you pointed out, as per my design i have included menu depth up to one level only. ( In wp_nav_menu() i have set menu depth option such that it can display up to level 1).

I have used only google fonts in my theme. For google fonts i have added license information SIL Open Font License. I didn't understand the link you sent. Can you please tell me what is it for ?

Falguni

#13 @monikarao
21 months ago

  • Resolution set to not-approved
  • Status changed from reviewing to closed

#14 @grapplerulrich
21 months ago

  • Resolution not-approved deleted
  • Status changed from closed to reopened

@monikarao - it seems you may have closed the ticket by mistake so I will reopen it.

#15 @falgunihdesai
21 months ago

Thanks @grapplerulrich.

#16 @falgunihdesai
21 months ago

Hi @monikarao ,

Waiting your comments.

Falguni

#17 @falgunihdesai
21 months ago

Hi @monikarao,

Waiting for your reply please.

Falguni

This ticket was mentioned in Slack in #themereview by falgunihdesai. View the logs.


21 months ago

#19 @grapplerulrich
21 months ago

  • Owner monikarao deleted
  • Status changed from reopened to reviewing

Removing reviewer as there is no response. @monikarao You have another ticket. It is best to do one review at a time.

#20 @benlumia007
21 months ago

Hello @falgunihdesai,

Outcome

  • Themes left as reviewing for 7 days, and it may be closed after that if there is no response. Note that if you need more time, please make a comment in the ticket.

Review in Process

I will be reviewing your theme, please give me about 1 - 3 days. I will post the first review here! Here are the need to know bases

  • I will be reviewing your theme recording to the Theme Review Handbook.
  • You will then solve all issues
  • You will then go to https://wordpress.org/themes/upload/ to upload your theme
    • The Theme name must be the same.
    • You will need to change the Version tag in your style.css
    • New version will be attached to this ticket.
  • it is better to log your changes in documentation.
  • We will repeat these steps above until we find no issues.
  • I approve.

@grapplerulrich
I would like to take this ticket. Thanks.

Thanks.
@benlumia007

#21 @falgunihdesai
21 months ago

Thanks @grapplerulrich and @benlumia007.

#22 @grapplerulrich
21 months ago

  • Owner set to benlumia007

#23 @benlumia007
21 months ago

Hello @falgunihdesai

I have conducted a full review but I won't able to post a comment till later on tonight or tomorrow. I just wanted to give you a heads up.

Thanks
@benlumia007

#24 @falgunihdesai
21 months ago

OK. Thanks for the information.

#25 @falgunihdesai
21 months ago

Hello @benlumia007,

Waiting for your review.

Thanks
Falguni

#26 @benlumia007
21 months ago

Hello @falgunihdesai

header.php
Line 46: is missing (/) means that it should be like this <?php echo esc_url(home_url('/')); ?>
Line 58 - 63: <hgroup> is not a html5 tag anymore. please use div

page.php and single.php
these two pages should be identical as per index.php with the loop. Is there a reason why you remove the first line of the loop and the last one. you should use all of the loop function.

<?php if (have_posts() : ?>
     <?php while (have_posts()) : the_post(); ?>
         // The content goes here
         <?php get_template_part('content', 'page'); ?>
         <?php get_template_part('content', 'single'); ?>

<?php endwhile; ?>
      // The Pagination goes here
<?php else : ?>
      // The 404 goes here. 
<?php endif ?>

jQuery 2.1.4
Is there particular reason why you would need to use this version. you should be using the core jQuery. So i need to make sure that you have a good reason why you need 2.1.4. Particularly.

Note (Optional)
Please note that your 404.php and content-none.php is similar in ways. the content-none.php also consider 404 errors. so I would recommend is 404.php is gets redirected to content-none.php, with the same codes as your index.php so you will be using <?php get_template_part('content', 'none); ?>

i couldn't find too much stuff, but you did a good job on it. please fixed the header.php.

#27 @themetracbot
20 months ago

  • Summary changed from THEME: Nisarg – 1.2 to THEME: Nisarg – 1.2.1

Nisarg - 1.2.1

Nisarg is a new fully responsive and translation ready theme that allows you to create stunning blogs and websites. Theme is well suited for travel, photography, recipe, design, art, personal and any other creative websites and blogs. The theme is developed using Bootstrap 3 that makes it mobile and tablets friendly. It has various options in WordPress Customizer to change look of the theme. Theme customizer can be used to add your own header image of flexible height, background image, to set background color, header text color and accent color(Supports seven different accent colors). Theme supports eight post formats, such as: Video, Image, Aside, Status, Audio, Quote, Link and Gallery.

Theme URL -
Author URL - http://falgunidesai.com/

SVN - https://themes.svn.wordpress.org/nisarg/1.2.1
ZIP - https://wordpress.org/themes/download/nisarg.1.2.1.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=nisarg/1.2&new_path=nisarg/1.2.1

History:

Ticket Summary Status Resolution Owner
#28009 THEME: Nisarg – 1.2.4 closed live benlumia007

(this ticket)

#31860 THEME: Nisarg – 1.2.5 closed live themetracbot
#33258 THEME: Nisarg – 1.2.6 closed live themetracbot
#41808 THEME: Nisarg – 1.2.7 closed live themetracbot
#41834 THEME: Nisarg – 1.2.8 closed live themetracbot
#41840 THEME: Nisarg – 1.2.8.1 closed live themetracbot


https://themes.svn.wordpress.org/nisarg/1.2.1/screenshot.png

#28 @falgunihdesai
20 months ago

Hello @benlumia007,

Thanks for your review.

I have uploaded the updated version of my theme and have fixed the issues you suggested.

Regarding the things you have asked about, I would like to clarify,

  1. I have not added if condition in single.php and page.php because single.php is called when a user clicks on single post or page. In that case no need to display an error message.
  1. There was no particular reason to use jquery-2.1.4. But somehow because of the way i had written nisarg.js, my header was not displaying properly with the wordpress core jquery. But after you pointed out i tried to use core jquery insted of 2.1.4 version. But to properly display header i had to change the jquery coding in nisarg.js file. But now the issue is solved and every thing is working fine. Thanks for point out this.

But i forgot to delete jquery-2.1.4 from js folder before uploading update. Can u suggest me some way to delete it from upload. Or have to upload new version again?

  1. You are right about 404.php and content.php. Both are almost same. But still i would like to keep 404.php as it is because in future if theme user wants to style something differently or display different message for both the cases then two separately coded files will help.

One more thing i have added to my theme is editor stylesheet as it was asked by previous reviewer. I felt that there is no harm in adding blank stylesheet, so i have added that too.

Thanks again,
Falguni

#29 @benlumia007
20 months ago

Hello @falgunihdesai

if you have forgot to remove files that are needed to be removed. yes, u will need to re-upload again.

i didn't know about the if statements are not needed when using page.php or single.php. I apologized, didn't really understand why until i saw the twenty sixteen and undscores.me so i think you're find with that.

you will need to reupload the theme again and change the version number if you forgot to remove something or fix something. its just how it works. i know its a pain but its just how the system works.

i was told that when using editor stylesheet, it should be remove if its not in used or blank for that matter.

#30 @falgunihdesai
20 months ago

Hi,

Ok then i will upload the theme again with new version number and will remove the editor-stylesheet from the theme.

But before uploading i would like you to check the theme again for any other issues if still there are. So that i can correct them in new version.

Falguni

#31 @themetracbot
20 months ago

  • Summary changed from THEME: Nisarg – 1.2.1 to THEME: Nisarg – 1.2.2

Nisarg - 1.2.2

Nisarg is a new fully responsive and translation ready theme that allows you to create stunning blogs and websites. Theme is well suited for travel, photography, recipe, design, art, personal and any other creative websites and blogs. The theme is developed using Bootstrap 3 that makes it mobile and tablets friendly. It has various options in WordPress Customizer to change look of the theme. Theme customizer can be used to add your own header image of flexible height, background image, to set background color, header text color and accent color(Supports seven different accent colors). Theme supports eight post formats, such as: Video, Image, Aside, Status, Audio, Quote, Link and Gallery.

Theme URL -
Author URL - http://falgunidesai.com/

SVN - https://themes.svn.wordpress.org/nisarg/1.2.2
ZIP - https://wordpress.org/themes/download/nisarg.1.2.2.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=nisarg/1.2.1&new_path=nisarg/1.2.2

History:

Ticket Summary Status Resolution Owner
#28009 THEME: Nisarg – 1.2.4 closed live benlumia007

(this ticket)

#31860 THEME: Nisarg – 1.2.5 closed live themetracbot
#33258 THEME: Nisarg – 1.2.6 closed live themetracbot
#41808 THEME: Nisarg – 1.2.7 closed live themetracbot
#41834 THEME: Nisarg – 1.2.8 closed live themetracbot
#41840 THEME: Nisarg – 1.2.8.1 closed live themetracbot


https://themes.svn.wordpress.org/nisarg/1.2.2/screenshot.png

#32 @falgunihdesai
20 months ago

Hello @benlumia007,

I have uploaded the new version (1.2.2).

Thanks,
Falguni

#33 @themetracbot
20 months ago

  • Summary changed from THEME: Nisarg – 1.2.2 to THEME: Nisarg – 1.2.3

Nisarg - 1.2.3

Nisarg is a new fully responsive and translation ready theme that allows you to create stunning blogs and websites. Theme is well suited for travel, photography, recipe, design, art, personal and any other creative websites and blogs. The theme is developed using Bootstrap 3 that makes it mobile and tablets friendly. It has various options in WordPress Customizer to change look of the theme. Theme customizer can be used to add your own header image of flexible height, background image, to set background color, header text color and accent color(Supports seven different accent colors). Theme supports eight post formats, such as: Video, Image, Aside, Status, Audio, Quote, Link and Gallery.

Theme URL -
Author URL - http://falgunidesai.com/

SVN - https://themes.svn.wordpress.org/nisarg/1.2.3
ZIP - https://wordpress.org/themes/download/nisarg.1.2.3.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=nisarg/1.2.2&new_path=nisarg/1.2.3

History:

Ticket Summary Status Resolution Owner
#28009 THEME: Nisarg – 1.2.4 closed live benlumia007

(this ticket)

#31860 THEME: Nisarg – 1.2.5 closed live themetracbot
#33258 THEME: Nisarg – 1.2.6 closed live themetracbot
#41808 THEME: Nisarg – 1.2.7 closed live themetracbot
#41834 THEME: Nisarg – 1.2.8 closed live themetracbot
#41840 THEME: Nisarg – 1.2.8.1 closed live themetracbot


https://themes.svn.wordpress.org/nisarg/1.2.3/screenshot.png

#34 @benlumia007
20 months ago

  • Status changed from reviewing to approved

Hello @falgunihdesai

Thank you for submitting your theme with the required fixes. I will go ahead and approved the theme since i do not find any issues whatsoever.

Once I have approved, you may have to wait for another two the three weeks for an admin to take a final look.

thanks
@benlumia007

#35 @djrmom
20 months ago

  • Cc djrmom added
  • Status changed from approved to reopened

Hi @falgunihdesai,

There are just a few fixes before your theme is made live:

Translations

  • archived.php - needs translation on line 19

Prefixing

  • Use a generic handle for third-party scripts and styles (unless modified)
    wp_enqueue_style( 'bootstrap', get_template_directory_uri().'/css/bootstrap.css' );
    wp_enqueue_style( 'font-awesome', get_template_directory_uri().'/font-awesome/css/font-awesome.min.css' );   
    wp_enqueue_script( 'bootstap', get_template_directory_uri() . '/js/bootstrap.js',array('jquery'),'',true);  
    

Scripts

Screenshot

  • Screenshot size should be 1200x900, to account for HiDPI displays. Any 4:3 image size is acceptable, but 1200x900 is preferred. Yours is not 4:3 ratio.

Licensing

Core functionality and features first

Escaping

  • the_permalink() function (in your content*.php files) should not be escaped as it is being echoed already, get_the_permlaink() if used would need to be escaped
  • adding escaping to $colors['accent_color'] in inc/customizer.php

Please let me know if you have any questions.

@benlumia007, will you be able to review and re-approve when the above changes are uploaded?

Thanks,
Jenny

#36 @benlumia007
20 months ago

@djrmom

yes, i will be able to review and re-approved the changes when uploaded.

Thanks
@benlumia007

Last edited 20 months ago by benlumia007 (previous) (diff)

#37 @falgunihdesai
19 months ago

Hello @djrmom ,

Thanks for your review and making the process of fixing issues easy by pointing out fixes with line number and urls.

I am not clear about how to do this two below fixes.

  1. Core functionality and features first

Backwards compatibility is only allowed for 3 versions, you can remove the version checking for pre-4.1 in back-compat.php

  1. Escaping:

adding escaping to $colorsaccent_color? in inc/customizer.php

Can you please help me by clarifying in more detail what i have to do?

Thanks in advanced.

Falguni

#38 @djrmom
19 months ago

Hi @falgunihdesai,

Since the current version of wp is 4.4 (and 4.5 is due soon) you do not need to check for backward compatibility prior to 4.1 as you are doing in back-compat.php

Your $colors are actually fine, I see they are not settings but pulled from an array, so you don't need to escape them.

Thanks,
Jenny

#39 @themetracbot
19 months ago

  • Summary changed from THEME: Nisarg – 1.2.3 to THEME: Nisarg – 1.2.4

Nisarg - 1.2.4

Nisarg is a new fully responsive and translation ready theme that allows you to create stunning blogs and websites. Theme is well suited for travel, photography, recipe, design, art, personal and any other creative websites and blogs. The theme is developed using Bootstrap 3 that makes it mobile and tablets friendly. It has various options in WordPress Customizer to change look of the theme. Theme customizer can be used to add your own header image of flexible height, background image, to set background color, header text color and accent color(Supports seven different accent colors). Theme supports eight post formats, such as: Video, Image, Aside, Status, Audio, Quote, Link and Gallery.

Theme URL -
Author URL - http://falgunidesai.com/

SVN - https://themes.svn.wordpress.org/nisarg/1.2.4
ZIP - https://wordpress.org/themes/download/nisarg.1.2.4.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=nisarg/1.2.3&new_path=nisarg/1.2.4

History:

Ticket Summary Status Resolution Owner
#28009 THEME: Nisarg – 1.2.4 closed live benlumia007

(this ticket)

#31860 THEME: Nisarg – 1.2.5 closed live themetracbot
#33258 THEME: Nisarg – 1.2.6 closed live themetracbot
#41808 THEME: Nisarg – 1.2.7 closed live themetracbot
#41834 THEME: Nisarg – 1.2.8 closed live themetracbot
#41840 THEME: Nisarg – 1.2.8.1 closed live themetracbot


https://themes.svn.wordpress.org/nisarg/1.2.4/screenshot.png

#40 @falgunihdesai
19 months ago

Hello @benlumia007 and @djrmom ,

I have uploaded new version of the theme Nisarg with all issues fixed.

Request to review.

Falguni

#41 @djrmom
19 months ago

@falgunihdesai,

Thanks. I don't see any remaining issues, except wp_enqueue_script( 'bootstap' is misspelled which is what I accidentally wrote above in my example. But if @benlumia007 doesn't see any other issues this can be approved and you can fix on your next update.

Thanks,
Jenny

#42 @benlumia007
19 months ago

  • Status changed from reopened to approved

Hello @falgunihdesai and @djrmom

yes, i just took went through everything as well and I don't see any issue besides the bootstrap spell wrong which can be updated on the next update.

I will approved the theme.

@benlumia007

#43 @djrmom
19 months ago

  • Resolution set to live
  • Status changed from approved to closed

Thanks @benlumia007.

Congrats, @falgunihdesai, your theme is now live!

Note: See TracTickets for help on using tickets.