WordPress.org

Make WordPress Themes

Opened 2 years ago

Closed 20 months ago

#28685 closed theme (closed-newer-version-uploaded)

THEME: WIC2015 – 1.1.2

Reported by: miyauchi Owned by: ashiquzzaman
Priority: new theme Keywords: theme-wic2015 child-theme parent-twentythirteen
Cc: miya@…

Description

WIC2015 - 1.0.0

WIC2015は柔軟なワンカラムのテーマです。このテーマは、パララックス風の背景画像とロゴ、フッターテキストなどをカスタマイズできます。

Theme URL - https://github.com/wakayama-it-carnival/wic2015
Author URL - https://firegoby.jp/

SVN - https://themes.svn.wordpress.org/wic2015/1.0.0
ZIP - https://wordpress.org/themes/download/wic2015.1.0.0.zip?nostats=1
Parent Theme: https://wordpress.org/themes/twentythirteen

History:

Ticket Summary Status Resolution Owner
#28685 THEME: WIC2015 – 1.1.2 closed closed-newer-version-uploaded ashiquzzaman

(this ticket)

#31948 THEME: WIC2015 – 1.1.6 closed live emiluzelac


https://themes.svn.wordpress.org/wic2015/1.0.0/screenshot.png

Change History (20)

#1 @themetracbot
22 months ago

  • Owner set to alexballera
  • Status changed from new to reviewing

#2 @grapplerulrich
22 months ago

  • Keywords changed from theme-wic2015, child-theme, parent-twentythirteen to theme-wic2015 child-theme parent-twentythirteen
  • Owner alexballera deleted

I am sorry this review is taking so long. Sometimes people are unable to carry on the review, this may have happened this time. As a result, I am going to add this to the new queue again as a priority. This may mean it still takes time, but will prevent this ticket being held for so long by a reviewer that isn't able to carry on. Thanks for your patience.

If you are the reviewer and able to do this review, please carry on and request you get added back in Slack #themereview.

#3 @themetracbot
22 months ago

  • Owner set to ashiquzzaman

#4 follow-up: @ashiquzzaman
22 months ago

Hi there, Ran a quick "Theme Mentor" and "Theme Check" plugin test and found these errors -

  1. Script tags should be included on wp_enqueue_scripts or admin_enqueue_scripts instead of embedded directly at file header.php, line 28: <script src="<?php echo get_template_directory_uri(); ?>/js/html5.js"></script>
  2. .gitignore Hidden Files or Folders found.
  3. Please remove any extraneous directories like .git or .svn from the ZIP file before uploading it.
  4. Found a Customizer setting that did not have a sanitization callback function. Every call to the add_setting() method needs to have a sanitization callback function passed.

Every customizer setting should have sanitization callback passed into them. None of your settings have sanitization callback included.

And some recommendation as well -
RECOMMENDED: No reference to add_theme_support( "title-tag" ) was found in the theme. It is recommended that the theme implement this functionality for WordPress 4.1 and above.
RECOMMENDED: No reference to add_theme_support( "custom-background", $args ) was found in the theme. If the theme uses background images or solid colors for the background, then it is recommended that the theme implement this functionality.

On my Chrome console log this error showed up - "wp-content/themes/wic2015.1.0.0/twentythirteen/images/search-icon.png" I checked your theme doesn't have this file, could you revolve this issue ?

There's no license.txt file on your theme. You need to declare copyright and license explicitly.
Declare licenses of any resources included such as fonts or images(your frontpage image). You have used bootstrap/genericons and you need to mention these in your licence.txt file.

Your style.css doesn't not contain these two fields(and they are mandatory to include at the top of style.css file)
License:
License URI:

Last edited 22 months ago by ashiquzzaman (previous) (diff)

#5 @grapplerulrich
22 months ago

@miyauchi - Are you able to upload an update or the ticket will need to be closed?

#6 @ashiquzzaman
22 months ago

@miyauchi If you need more time then just leave a comment, remember a trac ticket be active only for 7 days if uploader doesn't response the ticket will be closed down.

#7 @miyauchi
22 months ago

@grapplerulrich @ashiquzzaman

Very sorry, I didn't notice at all.
I will fix in this weekend! Thanks!

#8 @themetracbot
21 months ago

  • Summary changed from THEME: WIC2015 – 1.0.0 to THEME: WIC2015 – 1.1.0

WIC2015 - 1.1.0

WIC2015 is a flexsible one-column theme, so it allows you to customize fixed background, logo and footer text.

Theme URL - https://github.com/wakayama-it-carnival/wic2015
Author URL - https://firegoby.jp/

SVN - https://themes.svn.wordpress.org/wic2015/1.1.0
ZIP - https://wordpress.org/themes/download/wic2015.1.1.0.zip?nostats=1
Parent Theme: https://wordpress.org/themes/twentythirteen

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=wic2015/1.0.0&new_path=wic2015/1.1.0

History:

Ticket Summary Status Resolution Owner
#28685 THEME: WIC2015 – 1.1.2 closed closed-newer-version-uploaded ashiquzzaman

(this ticket)

#31948 THEME: WIC2015 – 1.1.6 closed live emiluzelac


https://themes.svn.wordpress.org/wic2015/1.1.0/screenshot.png

#9 @themetracbot
21 months ago

  • Summary changed from THEME: WIC2015 – 1.1.0 to THEME: WIC2015 – 1.1.1

WIC2015 - 1.1.1

WIC2015 is a flexsible one-column theme, so it allows you to customize fixed background, logo and footer text.

Theme URL - https://github.com/wakayama-it-carnival/wic2015
Author URL - https://firegoby.jp/

SVN - https://themes.svn.wordpress.org/wic2015/1.1.1
ZIP - https://wordpress.org/themes/download/wic2015.1.1.1.zip?nostats=1
Parent Theme: https://wordpress.org/themes/twentythirteen

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=wic2015/1.1.0&new_path=wic2015/1.1.1

History:

Ticket Summary Status Resolution Owner
#28685 THEME: WIC2015 – 1.1.2 closed closed-newer-version-uploaded ashiquzzaman

(this ticket)

#31948 THEME: WIC2015 – 1.1.6 closed live emiluzelac


https://themes.svn.wordpress.org/wic2015/1.1.1/screenshot.png

#10 in reply to: ↑ 4 @miyauchi
21 months ago

Hi @ashiquzzaman

Thanks for reviewing and I am sorry for late.

  1. Script tags should be included on wp_enqueue_scripts or admin_enqueue_scripts instead of embedded directly at file header.php, line 28: <script src="<?php echo get_template_directory_uri(); ?>/js/html5.js"></script>

This line was removed so I don't need to support IE9.

  1. .gitignore Hidden Files or Folders found.
  2. Please remove any extraneous directories like .git or .svn from the ZIP file before uploading it.

Fixed.

  1. Found a Customizer setting that did not have a sanitization callback function. Every call to the add_setting() method needs to have a sanitization callback function passed.

Every customizer setting should have sanitization callback passed into them. None of your settings have sanitization callback included.

Fixed. But footer text allows HTML, so it has no sanitization.

And some recommendation as well -
RECOMMENDED: No reference to add_theme_support( "title-tag" ) was found in the theme. It is recommended that the theme implement this functionality for WordPress 4.1 and above.

Fixed

RECOMMENDED: No reference to add_theme_support( "custom-background", $args ) was found in the theme. If the theme uses background images or solid colors for the background, then it is recommended that the theme implement this functionality.

This theme doesn't need it. This theme has a custom structure for the background.

On my Chrome console log this error showed up - "wp-content/themes/wic2015.1.0.0/twentythirteen/images/search-icon.png" I checked your theme doesn't have this file, could you revolve this issue ?

I can't re-present this issue. But I found out that other image was missing, so It has been fixed.

There's no license.txt file on your theme. You need to declare copyright and license explicitly.
Declare licenses of any resources included such as fonts or images(your frontpage image). You have used bootstrap/genericons and you need to mention these in your licence.txt file.

I added readme.txt.

Your style.css doesn't not contain these two fields(and they are mandatory to include at the top of style.css file)
License:
License URI:

Fixed.

Thanks again!

#11 @ashiquzzaman
21 months ago

Fixed. But footer text allows HTML, so it has no sanitization.
Even HTML texts need to be sanitized for security, Check this tutorial to learn more - http://themefoundation.com/wordpress-theme-customizer/

#12 @themetracbot
21 months ago

  • Summary changed from THEME: WIC2015 – 1.1.1 to THEME: WIC2015 – 1.1.2

WIC2015 - 1.1.2

WIC2015は柔軟なワンカラムのテーマです。このテーマは、パララックス風の背景画像とロゴ、フッターテキストなどをカスタマイズできます。

Theme URL - https://github.com/wakayama-it-carnival/wic2015
Author URL - https://firegoby.jp/

SVN - https://themes.svn.wordpress.org/wic2015/1.1.2
ZIP - https://wordpress.org/themes/download/wic2015.1.1.2.zip?nostats=1
Parent Theme: https://wordpress.org/themes/twentythirteen

以前のバージョンとの差分: https://themes.trac.wordpress.org/changeset?old_path=wic2015/1.1.1&new_path=wic2015/1.1.2

History:

Ticket Summary Status Resolution Owner
#28685 THEME: WIC2015 – 1.1.2 closed closed-newer-version-uploaded ashiquzzaman

(this ticket)

#31948 THEME: WIC2015 – 1.1.6 closed live emiluzelac


https://themes.svn.wordpress.org/wic2015/1.1.2/screenshot.png

#13 @miyauchi
21 months ago

@ashiquzzaman

Thanks for review.

I fixed following.

  • Add sanitize callback to footer.
  • I found some problems in readme.txt and fixed them.

#14 @ashiquzzaman
21 months ago

Hi there, Your theme passed the "Theme Check" plugin test but running through "Theme Mentor" plugin I am getting this error "Script tags should be included on wp_enqueue_scripts or admin_enqueue_scripts instead of embedded directly at file header.php, line 28: <script src="<?php echo get_template_directory_uri(); ?>/js/html5.js"></script>", I looked at your header.php file but couldn't find anything related on line 28. Could you resolve this issue ?

#15 @miyauchi
21 months ago

Hi,

I guess that the cause of the error is in the parent theme. :)
https://themes.svn.wordpress.org/twentythirteen/1.8/header.php

Thanks!

#16 @ashiquzzaman
21 months ago

  • Status changed from reviewing to approved

#17 @emiluzelac
21 months ago

  • Keep descriptions in English please WIC2015は柔軟なワンカラムのテーマです。このテーマは、パララックス風の背景画像とロゴ、フッターテキストなどをカスタマイズできます。
  • Move inline styles $image = '<img id="site-logo" src="%s" alt="%s" style="max-width:100%%; height:auto;">'; into an external stylesheet.
  • Parent themes textdomains twentythirteen should be replaced with wic2015.

#18 @miyauchi
21 months ago

This theme has been uploaded as new.
New ticket is following.
https://themes.trac.wordpress.org/ticket/31948

#19 @grapplerulrich
20 months ago

  • Status changed from approved to reopened

#20 @grapplerulrich
20 months ago

  • Resolution set to closed-newer-version-uploaded
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.