WordPress.org

Make WordPress Themes

Opened 10 months ago

Closed 6 months ago

Last modified 6 months ago

#39294 closed theme (live)

THEME: Ribbon Lite – 2.0.6

Reported by: suraj78 Owned by: ilovewpcom
Priority: previously reviewed Keywords: theme-ribbon-lite
Cc: suraj7vibhute@…

Description

Ribbon Lite - 2.0.1

Ribbon Lite is a lightening fast, SEO ready, traditional, responsive WordPress theme that is perfect for niche blogs with a lot of content to show off. Full fledged demo >>>>>> http://demo.mythemeshop.com/s/?theme=Ribbon <<<<<<

Theme URL - https://mythemeshop.com/themes/ribbon/
Author URL - https://mythemeshop.com/

SVN - https://themes.svn.wordpress.org/ribbon-lite/2.0.1
ZIP - https://wordpress.org/themes/download/ribbon-lite.2.0.1.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=ribbon-lite/2.0&new_path=ribbon-lite/2.0.1

History:

Ticket Summary Status Resolution Owner
#35073 THEME: Ribbon Lite – 2.0 closed closed-newer-version-uploaded rushijagani
#39294 THEME: Ribbon Lite – 2.0.6 closed live ilovewpcom

(this ticket)

#42896 THEME: Ribbon Lite – 2.0.7 closed live themetracbot


https://themes.svn.wordpress.org/ribbon-lite/2.0.1/screenshot.png
Theme Check Results:

  • RECOMMENDED: No reference to add_editor_style() was found in the theme. It is recommended that the theme implement editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.

Change History (19)

This ticket was mentioned in Slack in #themereview by poena. View the logs.


10 months ago

#2 @grapplerulrich
10 months ago

  • Owner set to rushijagani
  • Status changed from new to reviewing

@rushijagani Please continue the review here.

#3 @rushijagani
10 months ago

Ribbon Lite – 2.0
Theme Review
==================
Hi @suraj78,

I apologize for the delay.
Here is the few issues.

Required:
Required items that must be met before theme can be approved.

Customize->Theme Options-> Styling Settings -> Posts on Homepage
Full Posts
On selecting Full Posts the layout gets messy.

Customize->Theme Options-> Styling Settings -> Right To Left Language Support
Not working

All other functionality and styling is seems great.

#4 @themetracbot
10 months ago

  • Summary changed from THEME: Ribbon Lite – 2.0.1 to THEME: Ribbon Lite – 2.0.2

Ribbon Lite - 2.0.2

Ribbon Lite is a lightening fast, SEO ready, traditional, responsive WordPress theme that is perfect for niche blogs with a lot of content to show off. Full fledged demo >>>>>> http://demo.mythemeshop.com/s/?theme=Ribbon <<<<<<

Theme URL - https://mythemeshop.com/themes/ribbon/
Author URL - https://mythemeshop.com/

SVN - https://themes.svn.wordpress.org/ribbon-lite/2.0.2
ZIP - https://wordpress.org/themes/download/ribbon-lite.2.0.2.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=ribbon-lite/2.0.1&new_path=ribbon-lite/2.0.2

History:

Ticket Summary Status Resolution Owner
#35073 THEME: Ribbon Lite – 2.0 closed closed-newer-version-uploaded rushijagani
#39294 THEME: Ribbon Lite – 2.0.6 closed live ilovewpcom

(this ticket)

#42896 THEME: Ribbon Lite – 2.0.7 closed live themetracbot


https://themes.svn.wordpress.org/ribbon-lite/2.0.2/screenshot.png
Theme Check Results:

  • RECOMMENDED: No reference to add_editor_style() was found in the theme. It is recommended that the theme implement editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.

#5 @MyThemeShop
10 months ago

Hello Rushi,
Here is the updated version,
we were not able to reproduce first issue related to Full posts, please check this screenshot: http://take.ms/TnQDz
Fixed the second issue related to RTL.
Thank you.

This ticket was mentioned in Slack in #themereview by djrmom. View the logs.


9 months ago

#7 @djrmom
9 months ago

  • Owner changed from rushijagani to ilovewpcom

Reassign this ticket to a new reviewer. Thanks @ilovewpcom

#8 @ilovewpcom
9 months ago

Hi @MyThemeShop,

I will be your new reviewer for the theme. I will post my initial findings in the next 1-2 hours.

#9 @ilovewpcom
9 months ago

Your theme has been partially reviewed against these requirements: https://make.wordpress.org/themes/handbook/review/required/

Conclusion

The theme looks pretty clean and well-coded, with some minor issues here and there. After fixing/addressing these issues I think I can approve the theme.

Required

  1. Please remove the following options from the Customizer:

Theme Options > Header > Header Code
Theme Options > Footer > Footer Code
This is considered plugin territory.

  1. readme.txt must contain license information for all CSS, JS files that are bundled with the theme and the images that are visible in screenshot.png. Your screenshot contains 2 photos, so you need to provide an URL to their source, their author and license info.
  1. Output needs to be escaped.
  • searchform.php L1
  • single.php L67, L77, L79 - replace the_title() with the_title_attribute()
  • functions.php L717, L727, L734, L736 - replace the_title() with the_title_attribute()
  1. All strings must be translatable.
  • searchform.php L4
  1. single.php - wp_reset_query() on L89 is not needed. Remove it or replace with wp_reset_postdata()

https://codex.wordpress.org/Function_Reference/wp_reset_query

*6. If included in the theme, the .pot file should match the theme slug, please rename /languages/ribbon.pot to ribbon-lite.pot.

  1. /inc/customizer.php

7.1. L36-40 are repeated in L41-44, L77-81 are repeated in L82-85 and multiple times more in the same file. You have add_setting() twice for multiple fields with the same ID.
Is esc_url_raw() the appropriate sanitization callback for all these options?

  1. Themes are not allowed to use redirects on theme activation. You are not allowed to redirect to the Install Plugins page.
  1. /functions/widget-ad125.php L216 - replace esc_attr() with esc_url()
  1. I am not sure that it is allowed to have default values for the Ad widgets, values that create banners pointing to your own website. I believe it would be better if you provide an example as a field description and keep the widgets blank.

Just to be on the safe side I would make this change.

  1. I believe that you are not allowed to simply promote plugins through the "Install Plugins > Recommended" tab, but I am not sure. I will ask around in the Slack channel for a second opinion, but of course you could remove this block.

#10 @themetracbot
9 months ago

  • Summary changed from THEME: Ribbon Lite – 2.0.2 to THEME: Ribbon Lite – 2.0.3

Ribbon Lite - 2.0.3

Ribbon Lite is a lightening fast, SEO ready, traditional, responsive WordPress theme that is perfect for niche blogs with a lot of content to show off. Full fledged demo >>>>>> http://demo.mythemeshop.com/s/?theme=Ribbon <<<<<<

Theme URL - https://mythemeshop.com/themes/ribbon/
Author URL - https://mythemeshop.com/

Trac Browser - https://themes.trac.wordpress.org/browser/ribbon-lite/2.0.3

SVN - https://themes.svn.wordpress.org/ribbon-lite/2.0.3
ZIP - https://wordpress.org/themes/download/ribbon-lite.2.0.3.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=ribbon-lite/2.0.2&new_path=ribbon-lite/2.0.3

History:

Ticket Summary Status Resolution Owner
#35073 THEME: Ribbon Lite – 2.0 closed closed-newer-version-uploaded rushijagani
#39294 THEME: Ribbon Lite – 2.0.6 closed live ilovewpcom

(this ticket)

#42896 THEME: Ribbon Lite – 2.0.7 closed live themetracbot


https://themes.svn.wordpress.org/ribbon-lite/2.0.3/screenshot.png
Theme Check Results:

  • RECOMMENDED: No reference to add_editor_style() was found in the theme. It is recommended that the theme implement editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.
  • WARNING: Found a translation function that is missing a text-domain. Function , with the arguments 'You can change or remove our link from footer and use your own custom text.(You can also use your affiliate link to earn 70% of sales. Ex: https://mythemeshop.com/?ref=username)'

#11 @themetracbot
9 months ago

  • Summary changed from THEME: Ribbon Lite – 2.0.3 to THEME: Ribbon Lite – 2.0.4

Ribbon Lite - 2.0.4

Ribbon Lite is a lightening fast, SEO ready, traditional, responsive WordPress theme that is perfect for niche blogs with a lot of content to show off. Full fledged demo >>>>>> http://demo.mythemeshop.com/s/?theme=Ribbon <<<<<<

Theme URL - https://mythemeshop.com/themes/ribbon/
Author URL - https://mythemeshop.com/

Trac Browser - https://themes.trac.wordpress.org/browser/ribbon-lite/2.0.4

SVN - https://themes.svn.wordpress.org/ribbon-lite/2.0.4
ZIP - https://wordpress.org/themes/download/ribbon-lite.2.0.4.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=ribbon-lite/2.0.3&new_path=ribbon-lite/2.0.4

History:

Ticket Summary Status Resolution Owner
#35073 THEME: Ribbon Lite – 2.0 closed closed-newer-version-uploaded rushijagani
#39294 THEME: Ribbon Lite – 2.0.6 closed live ilovewpcom

(this ticket)

#42896 THEME: Ribbon Lite – 2.0.7 closed live themetracbot


https://themes.svn.wordpress.org/ribbon-lite/2.0.4/screenshot.png
Theme Check Results:

  • RECOMMENDED: No reference to add_editor_style() was found in the theme. It is recommended that the theme implement editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.

#12 @ilovewpcom
9 months ago

Hi,

Thank you for the theme update.

  1. I see from the diff between 2.0.2 and 2.0.3 that you have replaced instances of the_title() with the_title_attribute(). Unfortunately you have done this even inside <h2></h2>, which is not correct.

This is correct usage:

<h2><?php the_title(); ?></h2>
<img src="" alt="<?php the_title_attribute(); ?>" />

This is incorrect usage:

<h2><?php the_title_attribute(); ?></h2>
<img src="" alt="<?php the_title(); ?>" />

Please check the diff and fix where needed: https://themes.trac.wordpress.org/changeset?old_path=ribbon-lite/2.0.2&new_path=ribbon-lite/2.0.3

  1. I have discussed this with the review team and the consensus was that your 3 Advertising widgets should be removed from the theme, as that is considered plugin territory, not something that a theme should do.
  1. I believe that your option in the customizer for "Right To Left Language Support" is not implemented correctly. It is sufficient to have a rtl.css file in the root of the theme. If the user sets his website to a RTL language, then WordPress will automatically search for that file and use it. So it doesn't make much sense to have an option like that in the Customizer.
  1. I'm still not sure about the "Recommended" plugins tab on the "Install Plugins" page. So I am pinging @poena, @djrmom, @rabmalin and @greenshady for some feedback, if anyone has a few minutes to look into it.
  1. Please check the styling for captions. A caption with a full-width image goes outside of the content. Not a "required" issue, but it is recommended to look into it.

Please wait with the next theme update until an admin will provide some feedback in regards to the 4th issue.

Once everything is addressed I think I will be able to mark the theme as Approved on the next review.

#13 @rabmalin
9 months ago

  • First thing, using admin pointers is not allowed.
  • Making plugins required is not allowed. Plugins can be only recommended.
  • In recommendations also, theme should have some integration with those plugins. It should not be added only for advertising.

#14 @themetracbot
9 months ago

  • Summary changed from THEME: Ribbon Lite – 2.0.4 to THEME: Ribbon Lite – 2.0.5

Ribbon Lite - 2.0.5

Ribbon Lite is a lightening fast, SEO ready, traditional, responsive WordPress theme that is perfect for niche blogs with a lot of content to show off. Full fledged demo &gt;&gt;&gt;&gt;&gt;&gt; http://demo.mythemeshop.com/s/?theme=Ribbon &lt;&lt;&lt;&lt;&lt;&lt;

Theme URL - https://mythemeshop.com/themes/ribbon/
Author URL - https://mythemeshop.com/

Trac Browser - https://themes.trac.wordpress.org/browser/ribbon-lite/2.0.5

SVN - https://themes.svn.wordpress.org/ribbon-lite/2.0.5
ZIP - https://wordpress.org/themes/download/ribbon-lite.2.0.5.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=ribbon-lite/2.0.4&new_path=ribbon-lite/2.0.5

History:

Ticket Summary Status Resolution Owner
#35073 THEME: Ribbon Lite – 2.0 closed closed-newer-version-uploaded rushijagani
#39294 THEME: Ribbon Lite – 2.0.6 closed live ilovewpcom

(this ticket)

#42896 THEME: Ribbon Lite – 2.0.7 closed live themetracbot


https://themes.svn.wordpress.org/ribbon-lite/2.0.5/screenshot.png
Theme Check Results:

  • RECOMMENDED: No reference to add_editor_style() was found in the theme. It is recommended that the theme implement editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.

#15 @ilovewpcom
9 months ago

Hi,

I have just spotted these lines in comments.php:

<?php
// Do not delete these lines
if (!empty($_SERVER['SCRIPT_FILENAME']) && 'comments.php' == basename($_SERVER['SCRIPT_FILENAME']))
die ('Please do not load this page directly. Thanks!');

I don't think they are required (and they are causing an error).

#16 @themetracbot
9 months ago

  • Summary changed from THEME: Ribbon Lite – 2.0.5 to THEME: Ribbon Lite – 2.0.6

Ribbon Lite - 2.0.6

Ribbon Lite is a lightning fast, SEO ready, traditional, responsive WordPress theme that is perfect for niche blogs with a lot of content to show off. Full fledged demo &gt;&gt;&gt;&gt;&gt;&gt; http://demo.mythemeshop.com/s/?theme=Ribbon &lt;&lt;&lt;&lt;&lt;&lt;

Theme URL - https://mythemeshop.com/themes/ribbon/
Author URL - https://mythemeshop.com/

Trac Browser - https://themes.trac.wordpress.org/browser/ribbon-lite/2.0.6

SVN - https://themes.svn.wordpress.org/ribbon-lite/2.0.6
ZIP - https://wordpress.org/themes/download/ribbon-lite.2.0.6.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=ribbon-lite/2.0.5&new_path=ribbon-lite/2.0.6

History:

Ticket Summary Status Resolution Owner
#35073 THEME: Ribbon Lite – 2.0 closed closed-newer-version-uploaded rushijagani
#39294 THEME: Ribbon Lite – 2.0.6 closed live ilovewpcom

(this ticket)

#42896 THEME: Ribbon Lite – 2.0.7 closed live themetracbot


https://themes.svn.wordpress.org/ribbon-lite/2.0.6/screenshot.png
Theme Check Results:

  • RECOMMENDED: No reference to add_editor_style() was found in the theme. It is recommended that the theme implement editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.

#17 @ilovewpcom
9 months ago

  • Status changed from reviewing to approved

Thank you for uploading your update.
Everything seems alright from my end, so I'm marking it as approved.

What happens next?

  1. Your theme will now move to a new queue for approval by key reviewers. At the moment of writing this the queue is ~6-8 weeks long.
  2. Due to the way Trac works, after theme gets into the Approved queue, any future updates to this ticket will -visually- drop the theme to the end of the queue. This however does not mean that it will lose its position in the queue. Even linking to this ticket on Slack will drop its position in the queue.

Nonetheless I suggest that you avoid uploading any more theme updates before a key reviewer picks up this ticket.

  1. Until your theme actually goes LIVE you are not allowed to upload more themes for review, according to the "1 theme in queue per author" rule.

We'll get pinged by email when a key reviewer will pick up or update this ticket.

Good luck!

#18 @poena
6 months ago

  • Resolution set to live
  • Status changed from approved to closed

Hi!
Your theme should be live shortly.

First of all you need to select one account/username to submit your themes from.
Since we have a one theme rule, you can't submit themes for the same company but from different accounts,
the other account being "MyThemeShop".

Please fix this in your next update:

In widget-social.php
Please add translation functions (and escape) the names of the social networks etc in the title attributes.

FILE: ribbon-lite\functions.php
Line: 290 ERROR Overriding WordPress globals is prohibited

Line 270: home_url() needs to be escaped
Line 273: I believe "Theme by" is missing the translation function?

Escape the custom color options:

$ribbon_lite_color_scheme = get_theme_mod('ribbon_lite_color_scheme', '#EA141F');
$ribbon_lite_color_scheme2 = get_theme_mod('ribbon_lite_color_scheme2', '#364956');
$ribbon_lite_layout = get_theme_mod('ribbon_lite_layout', 'cslayout');

Line 584: text in attribute is not escaped: title="<?php _e( 'View your shopping cart', 'ribbon-lite' );

Line 597, Line 618 This is not allowed:
remove generator meta tag
remove_action( 'wp_head', array( $GLOBALSwoocommerce?, 'generator' ) );

Remove WooCommerce generator tag.
remove_action('wp_head', 'wc_generator_tag');

Line 656: Please do not change the alt text, we need to respect the user settings, and user can change the alt text in the media library. Also see single.php line 79.

FILE: ribbon-lite\inc\custom-header.php
Line: 56 ERROR Found usage of constant "HEADER_TEXTCOLOR". Use add_theme_support( 'custom-header' ) instead.

#19 @suraj78
6 months ago

Hello @poena,
Thank you for the update,
About the different account issue, I had already requested to transfer this theme and @grapplerulrich said once the theme is live he will transfer it to 'MyThemeShop' account(https://themes.trac.wordpress.org/ticket/35073#comment:6). I have dropped a Slack message to him.

Regarding remaining issues, sure will get those fixed in next update.

Thank you.

Last edited 6 months ago by suraj78 (previous) (diff)
Note: See TracTickets for help on using tickets.