WordPress.org

Make WordPress Themes

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4021 closed theme (not-approved)

THEME: Green Nature - 2.3.0.8

Reported by: alihan1988 Owned by: ArnoldGoodway
Priority: Keywords: theme-green-nature
Cc: solitaryman88@…

Description

Green Nature - 2.3.0.8

Say hello to spring with this nature theme. This theme includes the sky, sun, clouds, birds, flowers, animals and green nature. Try this theme which is decorated with flowers. Main features: theme options control panel, CSS3 Dropdown Menu, custom menu/header/background, two column and fixed layout, stylish, customizable, readable, 8 widgetized areas, front page featured widget areas, post thumbnail, threaded comments, comment rules area, stylish search box, author bio under article, font styles with Google Fonts, numbered pagination, custom favicon & CSS, Google Analytics or other tracking codes.

Theme URL - http://www.alihan.com.tr/blog/green-nature-wordpress-theme.html
Author URL - http://www.alihan.com.tr

SVN - http://themes.svn.wordpress.org/green-nature/2.3.0.8
ZIP - http://wordpress.org/extend/themes/download/green-nature.2.3.0.8.zip?nostats=1

Diff with previous version: http://themes.trac.wordpress.org/changeset?old_path=/green-nature/2.3.0.7&new_path=/green-nature/2.3.0.8

All previous tickets for this theme: http://themes.trac.wordpress.org/query?col=id&col=summary&col=keywords&col=owner&col=status&col=resolution&keywords=~theme-green-nature&order=priority

https://themes.svn.wordpress.org/green-nature/2.3.0.8/screenshot.png

Change History (14)

comment:1 ArnoldGoodway3 years ago

  • Owner set to ArnoldGoodway
  • Status changed from new to assigned

comment:2 ArnoldGoodway3 years ago

Issues from Previous Ticket

  • Validation errors - fixed, the only HTML validation errors still there are those caused by the core files.
  • Enqueue styles via wp_enqueue_style - fixed.
  • Remove function_exists checks for *_sidebar() functions - fixed.
  • You may want to update the prefix to no longer be alihan_ but rather green_nature_ - unchanged.
  • Embedded fonts should be working in editor-style. Just use @font-face - unchanged.
  • Images with caption not styled - fixed.
  • Still contains CC licensed code, but with attribution removed (see function parse_cache_feed) - unchanged.
  • Issue with Debogger errors - I am seeing no Debogger errors so I can only assume this has been resolved.

Code Quality

  • Feed links are not to be hard-coded into the document head, 'automatic-feed-links' in functions.php takes care of this.
  • paginate_comments_links() has not been included in comments.php.

Theme Template Files

  • The search form included in header.php should be included with get_search_form().

Licensing

  • Please see the Issues from Previous Tickets for issue regarding the parse_cache_feed function in functions.php. This function is licensed under the Apache License, Version 2.0.
  • There are two credit links in the footer, the one links to the theme URI and the other to the author URI, only a single link is allowed.

Theme Unit Tests

  • Oversized images are not properly resized. The large images do not overflow the content area so this is thus merely a recommendation.

Review Summary

Unfortunately the theme has not yet met the necessary criteria. Additional review may be required once the above issues are resolved.

This following should be of assistance in getting your theme to meet all the criteria:

Once the points above have been addressed appropriately using the available information found at the links above; please thoroughly review your theme and re-submit it using the uploader tool: http://wordpress.org/extend/themes/upload/ ... this will generate a new Trac ticket.

NB: Re-submitted themes are given review priority over new themes that have not been reviewed yet.

Please feel free to make use of the contact details below if you have any questions, comments, or feedback:

  • Leave a comment on this ticket.
  • Send an email to the Theme Review email list.
  • Use the #wordpress-themes IRC channel on Freenode.

comment:3 ArnoldGoodway3 years ago

  • Keywords synchold added
  • Resolution set to not-approved
  • Status changed from assigned to closed

comment:4 alihan19883 years ago

Hi Arnold;
Thank you for your review.

"You may want to update the prefix to no longer be alihan_ but rather green_nature_ - unchanged. "

I want to use this prefix for all my themes. This way is easier for me. Dont let this happen?

comment:5 ArnoldGoodway3 years ago

The entire matter of theme slugs is one of those debatable matters. On this theme I only mentioned it because it was one of the issues raised by a previous reviewer. I am taking this issue to the Theme Review email list so that the folks with more experience than myself can provide guidance.

comment:6 emiluzelac3 years ago

The prefix should not be a problem. If author wants to use alihan_ IMHO that would be acceptable. There is absolutely nothing wrong with that at all. Prefix isn't Theme name or name of the folder and it doesn't affect anything at all.

comment:7 ArnoldGoodway3 years ago

At least now I and the theme author, know more about this issue, thanks for clarifying this.

comment:8 emiluzelac3 years ago

You're very welcome. I am not sure why the previous reviewer brought this up on the first place, but now we're good :)

comment:9 chipbennett3 years ago

The Reviewer brought it up because it is important that extensions have unique function names, in order to avoid clashes. The biggest problem comes from entirely un-prefixed function names (or generic function prefixes, usually taken from a tutorial).

Now, if you only ever release Themes, then using alihan_ as your function-name prefix is fine. No user will ever have more than one Theme active at one time.

But, what if you also release a Plugin, and for this Plugin, you choose also to use alihan_ as your function-name prefix. Now, the potential exists for a function-name clash. So, that will be something to keep in mind.

Personlly, I would prefer to see you use something like alihan_gn_ (for "Green Nature"). But I'm just commenting here to help clarify, not to counter the other Reviewers' comments.

Also for consideration: if you have an extensive library of functions that you would like to re-use in multiple Themes, then you should probably consider creating a Theme Framework, that you can "drop in" to each of your Themes. Justin Tadlock has a good explanation here:
http://justintadlock.com/archives/2010/08/16/frameworks-parent-child-and-grandchild-themes

comment:10 emiluzelac3 years ago

@Chip I definitely agree with you, however joedoe_ or joe_doe_ must not be the reason to fail a Theme, that's all.

comment:11 chipbennett3 years ago

@emiluzelac absolutely! The "theme-slug"-as-prefix requirement can be taken... loosely.

comment:12 chipbennett3 years ago

  • Keywords synchold removed

comment:13 alihan19883 years ago

@Chip Thank you.

@ArnoldGoodway
There is a problem.
I do not link the different domains.

Example:
"Green Nature Theme by Ali Han"
Html:
<a href="http://www.alihan.com.tr/blog/green-nature-wordpress-theme.html">Green Nature</a> Theme by <a href="http://www.alihan.com.tr">Ali Han</a>

This theme includes 2 different link:
JohnLoan Theme Page
SVN for footer.php

I'm sorry for bad english :)

comment:14 chipbennett3 years ago

The Guidelines are very specific, in that the footer may include only one credit link, which must be either Theme URI or Author URI. You cannot include both, unless the second link is:

  • Implemented as a Theme option
  • Disabled by default
Note: See TracTickets for help on using tickets.