WordPress.org

Make WordPress Themes

Opened 5 months ago

Closed 3 months ago

#41260 closed theme (live)

THEME: Stride lite – 1.3.1

Reported by: orahmax Owned by: rushijagani
Priority: previously reviewed Keywords: theme-stride-lite
Cc: mohitchawla127@…

Description

Stride lite - 1.3.0

Stride lite is a clean, modern and fully responsive WordPress Personal Blog theme built using Bootstrap 3 which makes it optimized for tablets and mobile.

Theme URL -
Author URL - https://www.tidyhive.com

Trac Browser - https://themes.trac.wordpress.org/browser/stride-lite/1.3.0

SVN - https://themes.svn.wordpress.org/stride-lite/1.3.0
ZIP - https://wordpress.org/themes/download/stride-lite.1.3.0.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=stride-lite/1.2.2&new_path=stride-lite/1.3.0

History:

Ticket Summary Status Resolution Owner
#40803 THEME: Stride lite – 1.2.2 closed not-approved rabmalin
#41260 THEME: Stride lite – 1.3.1 closed live rushijagani

(this ticket)


https://themes.svn.wordpress.org/stride-lite/1.3.0/screenshot.png
Theme Check Results:

  • RECOMMENDED: No reference to add_editor_style() was found in the theme. It is recommended that the theme implement editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.
  • RECOMMENDED: Theme URI: is missing from your style.css header.

Change History (12)

#1 @themetracbot
5 months ago

  • Summary changed from THEME: Stride lite – 1.3.0 to THEME: Stride lite – 1.3.1

Stride lite - 1.3.1

Stride lite is a clean, modern and fully responsive WordPress Personal Blog theme built using Bootstrap 3 which makes it optimized for tablets and mobile.

Theme URL -
Author URL - https://www.tidyhive.com

Trac Browser - https://themes.trac.wordpress.org/browser/stride-lite/1.3.1

SVN - https://themes.svn.wordpress.org/stride-lite/1.3.1
ZIP - https://wordpress.org/themes/download/stride-lite.1.3.1.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=stride-lite/1.3.0&new_path=stride-lite/1.3.1

History:

Ticket Summary Status Resolution Owner
#40803 THEME: Stride lite – 1.2.2 closed not-approved rabmalin
#41260 THEME: Stride lite – 1.3.1 closed live rushijagani

(this ticket)


https://themes.svn.wordpress.org/stride-lite/1.3.1/screenshot.png
Theme Check Results:

  • RECOMMENDED: No reference to add_editor_style() was found in the theme. It is recommended that the theme implement editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.
  • RECOMMENDED: Theme URI: is missing from your style.css header.

#2 @joyously
4 months ago

  • The menu needs to have a fallback for when no menu is selected, so site visitors can still navigate.
  • On a small screen, the menu colors for current page are unreadable.
  • On desktop, the submenu items can overflow the submenu container.
  • pingback <link> should be conditional (singular and pings_open)
  • Floats are not being cleared properly after the content area for Pages.
  • Page links (generated by <!--nextpage-->) are being output in the same div as the content instead of after it.
  • Formatting:
    • <h6> tag is quite small.
    • blockquote can contain <em> tags, but they don't look emphasized.
    • <ul> last list items are missing their bullet.
    • <ol> last list items are missing their number.
    • Large images are distorted in a narrow window. Use height:auto with max-width:100%.
    • images with captions are distorted. The height:auto trick fixes this.
  • Theme is tagged sticky-post, but sticky post is not visually different.
  • Gallery thumbnails are left, but their captions are centered. Themes should support the gallery default of 3 columns.
  • NOTICE: wp-content/themes/stride-lite/inc/template-tags.php:55 - Undefined offset: 0
  • NOTICE: wp-content/themes/stride-lite/inc/template-tags.php:55 - Trying to get property of non-object
  • NOTICE: wp-content/themes/stride-lite/inc/template-tags.php:56 - Undefined offset: 0
  • NOTICE: wp-content/themes/stride-lite/inc/template-tags.php:56 - Trying to get property of non-object
  • Using .widget > ul > li > a {display: block;} doesn't work well on the 404 page (categories with counts) or when using the Category or Archive widgets with counts.
  • You might want to hide the menu and sidebar for the print styles.
  • The readme.txt file says the theme is GPL3, but the license.txt file says GPL2. Since Navwalker is listed as GPL2, the theme has to be GPL2. See the compatibility chart.

Please read the guidelines and use the theme test data as described here. Review tickets can be closed for having 5 or more required fix issues.

#3 @kevinhaig
4 months ago

Note to Author

  1. The above preview by @joyously is not an official review. You must still wait to get to the top of the review queue before an official review will begin.
  1. Many of the concerns above relate to results from Theme Unit Test and you should always test your theme with that package. However please note that many of the comments are considered recommended. Recommended comments DO NOT have to be addressed for theme approval. In many cases it is good advice, but the decision to address those issues is yours.
  1. There may be some comment items that are required. Required items must be addressed or the theme will not be approved. Please visit https://make.wordpress.org/themes/handbook/review/required/ to double check required items. Note that when an official review starts your theme may be closed if 5 or more distinct requirements are not met.
  1. If you are in doubt of a comment, or do not want to address something please ask for a confirmation in the ticket, or on the open Slack channel.

Fallback menu - Your handling of the fallback menu is fine, you do not have to change anything.

Notices - You are required to fix the notices

Licensing comments are also required.

The rest of the comments are recommendations and are not do not have to be addressed for theme approval.

Also do not consider my comments as an official review :)

#4 @themetracbot
4 months ago

  • Owner set to rushijagani
  • Status changed from new to reviewing

#5 @rushijagani
4 months ago

  • Status changed from reviewing to approved

Hi @orahmax

Your theme is reviewed under the https://codex.wordpress.org/Theme_Unit_Test WordPress standards.

As mention above few notices and recommendations by the theme review team, All the notices are handled but recommendations are not handled.

The recommendations do not have to be addressed for theme approval but It's good practice for any developer to provide the best product to the end user.

I am approving your theme from my side.

#6 follow-up: @poena
4 months ago

  • Status changed from approved to reopened

@rushijagani Hi! This theme was not fully reviewed, are you able to continue?

#7 in reply to: ↑ 6 @rushijagani
4 months ago

Replying to poena:

@rushijagani Hi! This theme was not fully reviewed, are you able to continue?

Hi @poena,

Thank you for your reply.
I'll check again and post comments here.

#8 @rushijagani
4 months ago

Hi @poena ,

Sorry for delay,

Can you assist me, I couldn't find any any notice or warning which can prevent this theme to approve.

#9 @poena
4 months ago

@rushijagani please ping me on Slack so that we can go trough the theme together.

You need to review the theme against these requirements, https://make.wordpress.org/themes/handbook/review/required/
the theme unit test is only recommended.

Even if you don't find errors, the reviewer who will do the final review of the theme needs to know details of what you have checked, so that they don't need to review the whole theme again. That would be a waste of all of our time :)

example:
License: OK
scripts: OK
Prefix: OK

and so on.

#10 @rushijagani
3 months ago

Here is the full list of things that I checked.

Required

Code: OK
Core Functionality and Features: OK
Documentation: OK
Licensing : OK
Naming: OK
Options and Settings : OK
Screenshot: OK
Selling, credits and links: OK
Stylesheets and Scripts: OK
Templates: OK

On the 404 page widget sidebar area doesn't work well.

#11 @poena
3 months ago

  • Status changed from reopened to reviewing

#12 @poena
3 months ago

  • Resolution set to live
  • Status changed from reviewing to closed

Great! Then I will set the theme live, -I was not able to reproduce the php notices either.

@orahmax please fix the following in your next update, thanks:

There is added support for the html5 search form, but a different form is used in searchform.php.
(You only need searchform.php if you need to make changes to the default forms.)

Please prefix the add_image_size names.

function excerpt($limit)
-You are not using the excerpt with a custom length/limit in the theme? If you are, I can't find where?
To make changes to the excerpt, you should use one of the available filters.
See https://developer.wordpress.org/reference/functions/the_excerpt/

In navwalker.php, add the missing translation function to the "Add a menu" text.

Include the non minified version of owl.carousel.min.js.

The readme.txt file says the theme is GPL3, but the license.txt file says GPL2. Please pick one license.

The notice to install the recommended plugin needs to be dismissable.

FILE: stride-lite\comments.php
Line: 31 ERROR Missing singular placeholder, needed for some languages. See https://codex.wordpress.org/I18n_for_WordPress_Developers#Plurals
Comment: This is because you are using the word "One" instead of the placeholder. (An issue has been opened to fix this in underscores)

FILE: stride-lite\inc\custom-comments.php
Line: 44 ERROR Overriding WordPress globals is prohibited

FILE: stride-lite\inc\custom-header.php
Line: 50 ERROR Found usage of constant "HEADER_TEXTCOLOR". Use add_theme_support( 'custom-header' ) instead.

Note: See TracTickets for help on using tickets.