WordPress.org

Make WordPress Themes

Opened 7 weeks ago

Closed 7 weeks ago

#41723 closed theme (live)

THEME: Progeny MMXV – 1.3.0

Reported by: audiotheme Owned by: themetracbot
Priority: theme update Keywords: theme-progeny-mmxv, child-theme, parent-twentyfifteen
Cc: notify@…

Description

Progeny MMXV - 1.3.0

Twenty Fifteen child theme with unique grid and list page template layouts. Display page children in a unique grid or list view. With AudioTheme support included, you can nicely display your music, videos, and gigs.

Theme URL - https://audiotheme.com/view/progeny-mmxv/
Author URL - https://audiotheme.com/

Trac Browser - https://themes.trac.wordpress.org/browser/progeny-mmxv/1.3.0

SVN - https://themes.svn.wordpress.org/progeny-mmxv/1.3.0
ZIP - https://wordpress.org/themes/download/progeny-mmxv.1.3.0.zip?nostats=1
Parent Theme: https://wordpress.org/themes/twentyfifteen

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=progeny-mmxv/1.2.4&new_path=progeny-mmxv/1.3.0

History:

Ticket Summary Status Resolution Owner
#22204 THEME: Progeny MMXV - 1.0.0.1 closed not-approved alex27
#31556 THEME: Progeny MMXV – 1.2.4 closed live rabmalin
#41723 THEME: Progeny MMXV – 1.3.0 closed live themetracbot

(this ticket)


https://themes.svn.wordpress.org/progeny-mmxv/1.3.0/screenshot.png
Theme Check Results:

  • REQUIRED: Could not find wp_footer. See: wp_footer
     <?php wp_footer(); ?>
    
  • REQUIRED: Could not find wp_head. See: wp_head
     <?php wp_head(); ?>
    
  • REQUIRED: Could not find language_attributes. See: language_attributes
    <html <?php language_attributes(); ?>
    
  • REQUIRED: Could not find charset. There must be a charset defined in the Content-Type or the meta charset tag in the head.
  • REQUIRED: Could not find add_theme_support( 'automatic-feed-links' ). See: add_theme_support
     <?php add_theme_support( $feature ); ?>
    
  • REQUIRED: Could not find comments_template. See: comments_template
     <?php comments_template( $file, $separate_comments ); ?>
    
  • REQUIRED: Could not find wp_list_comments. See: wp_list_comments
     <?php wp_list_comments( $args ); ?>
    
  • REQUIRED: Could not find comment_form. See: comment_form
     <?php comment_form(); ?>
    
  • REQUIRED: Could not find body_class call in body tag. See: body_class
     <?php body_class( $class ); ?>
    
  • REQUIRED: Could not find wp_link_pages. See: wp_link_pages
     <?php wp_link_pages( $args ); ?>
    
  • REQUIRED: The theme doesn't have comment pagination code in it. Use paginate_comments_links() or the_comments_navigation or the_comments_pagination or next_comments_link() and previous_comments_link() to add comment pagination.
  • REQUIRED: No content width has been defined. Example:
    if ( ! isset( $content_width ) ) $content_width = 900;
    
  • RECOMMENDED: No reference to add_theme_support( "custom-header", $args ) was found in the theme. It is recommended that the theme implement this functionality if using an image for the header.
  • RECOMMENDED: No reference to add_theme_support( "custom-background", $args ) was found in the theme. If the theme uses background images or solid colors for the background, then it is recommended that the theme implement this functionality.
  • RECOMMENDED: No reference to add_editor_style() was found in the theme. It is recommended that the theme implement editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.
  • WARNING: Could not find the file index.php in the theme.
  • REQUIRED: This theme doesn't seem to support the standard avatar functions. Use get_avatar or wp_list_comments to add this support.
  • RECOMMENDED: No reference to nav_menu's was found in the theme. Note that if your theme has a menu bar, it is required to use the WordPress nav_menu functionality for it.
  • RECOMMENDED: No reference to post-thumbnails was found in the theme. If the theme has a thumbnail like functionality, it should be implemented with add_theme_support( "post-thumbnails" )in the functions.php file.
  • REQUIRED: .sticky css class is needed in your theme css.
  • REQUIRED: .bypostauthor css class is needed in your theme css.
  • REQUIRED: .alignleft css class is needed in your theme css.
  • REQUIRED: .alignright css class is needed in your theme css.
  • REQUIRED: .aligncenter css class is needed in your theme css.
  • REQUIRED: .wp-caption css class is needed in your theme css.
  • REQUIRED: .wp-caption-text css class is needed in your theme css.
  • REQUIRED: .gallery-caption css class is needed in your theme css.
  • REQUIRED: .screen-reader-text css class is needed in your theme css. See See: the Codex for an example implementation.
  • REQUIRED: This theme doesn't seem to display tags. Modify it to display tags in appropriate locations.
  • REQUIRED: No reference to add_theme_support( "title-tag" ) was found in the theme.
  • REQUIRED: The theme must not used the <title> tags.
  • REQUIRED: The theme must not call to wp_title().
  • RECOMMENDED: This theme contains no sidebars/widget areas. See Widgets API

Change History (2)

#1 @themetracbot
7 weeks ago

  • Owner set to themetracbot
  • Status changed from new to reviewing

Theme Update for existing Live theme - automatically reviewed

#2 @themetracbot
7 weeks ago

  • Resolution set to live
  • Status changed from reviewing to closed

Theme Update for existing Live theme - automatically approved

Note: See TracTickets for help on using tickets.