WordPress.org

Make WordPress Themes

Opened 3 years ago

Closed 3 years ago

#4192 closed theme (not-approved)

THEME: EasyPress - 1.1

Reported by: iconstantin Owned by: greuben
Priority: Keywords: theme-easypress
Cc: constantin.ionescu@…

Description

EasyPress - 1.1

Easypress is a great theme which was designed having the typical user in mind. You don`t have to be a boy genius to configure this theme. All you have to do is install the theme, configure the options in a few minutes and then write your content, because this is blogging is all about, writing and not having to learn html or watch hours of tutorials on how to use a theme.

Theme URL - http://www.byprelco.com/easypress
Author URL - http://www.byprelco.com

SVN - http://themes.svn.wordpress.org/easypress/1.1
ZIP - http://wordpress.org/extend/themes/download/easypress.1.1.zip?nostats=1

All previous tickets for this theme: http://themes.trac.wordpress.org/query?keywords=~theme-easypress

https://themes.svn.wordpress.org/easypress/1.1/screenshot.png

Change History (2)

comment:1 greuben3 years ago

  • Owner set to greuben
  • Status changed from new to accepted

comment:2 greuben3 years ago

  • Resolution set to not-approved
  • Status changed from accepted to closed

Theme Review

Below is a detailed review based on Theme Review Guidelines and Theme Unit Tests.

The theme cannot be approved as it failed many guidelines and test cases. Solutions and suggestions are made wherever possible. Steps on how to reproduce these issues is provided below.

General

  • Please fix the theme URL, its a 404.
  • There are few empty textdomains. Please use appropriate textdomain for translation.

Code Quality

  • Theme are required not to generate any PHP notices, warning or errors
    • Two notices on viewer side
    • At least one notice on all admin pages
    • 5 notices in theme options page
  • Do not include meta generator tags and feed links in header. Use add_theme_support('automatic-feed-links'); instead.
  • Unnecessary code in header.php
    <?php wp_get_archives('type=monthly&format=link'); ?>
    
  • wp_enqueue_script calls should be made before wp_head. As a result comment-reply is never enqueued.
    <?php wp_head(); ?>
     <?php if ( is_singular() ) wp_enqueue_script( "comment-reply" ); ?>
    
  • All the theme's functions, definitions, constants, etc should be properly prefixed with theme slug or any other appropriate slug. This avoids conflicts with other plugins and/or themes.
  • Please do not rely on copy-paste snippets. The theme contains a lot of copy-paste snippets which are out of date.
  • Widgets should be properly registered. Recommended way of coding widgets is object type i.e extend/inheriting WP_Widget class.

Functionality

  • Use proper function to include sidebars i.e get_sidebar().
  • comment-reply script not properly enqueue(reason noted above).

Template Tags & Hooks

  • wp_head() should be called immediately before </head>

Including Files

  • TEMPLATEPATH should not be used unless there is no other way around. Use get_template_directory_uri() instead.
  • get_template_part() function should be used to include template part files not sidebars (Noted the same in code quality review above).
  • Do not name files as single_sidebar.php or single-sidebar.php. Please avoid this, it might conflict with template hierarchy.

Theme Settings & Date Security

Theme Naming

Theme Unit Tests

General

  • The theme cannot incorporate longer menus(max of 4-7). This should be noted in the readme.txt or somewhere else.

404 Page

  • Some content should be displayed along with helpful assets like search form or a list of pages. Currently, the 404 pages are empty.

Search Results Page

  • Search term is not displayed.

Layout Tests

  • The following HTML tags are not styled as appropriate to reflect their semantic meaning
    • cite, address, big, acronym, abbr, kbd, tt, em, pre, sup and sub

Image Tests

  • Center aligned captioned images are not center aligned.
  • Floats are not cleared at the end of the content.
  • Images overflow in index/archive pages.

Video Tests

  • The videos overflow the content area. This is probably because $content_width variable is bigger than actual content width in the theme.

Comments Tests

  • Few HTML tags is not styled in comments.
  • Trackbacks/Pingbacks are not displayed.
  • Comments disabled message is not displayed on posts with comments disabled.

Widget Areas

  • Adding core widgets to 'sidebar' widget area disturbs the whole layout.

To reproduce the issues noted above, follow the below steps:

All the issues noted above should be fixed before approving the theme.

Responding to this review

  • Leave a comment on this ticket
  • Send a message to theme-reviewers mailing list.

Additional Notes

  • In case of name change, please refer to this ticket in the newly generated ticket.
  • The theme will require more review once the above issues are fixed.
Note: See TracTickets for help on using tickets.