WordPress.org

Make WordPress Themes

Opened 6 months ago

Closed 4 months ago

#43166 closed theme (live)

THEME: Consulting – 1.0.4

Reported by: thinkupthemes Owned by: greenshady
Priority: previously reviewed Keywords: theme-consulting
Cc: wordpress@…

Description

Consulting - 1.0.3

Consulting is the free version of the multi-purpose professional theme (Consulting Pro) ideal for a business or blog website. The theme has a responsive layout, HD retina ready and comes with a powerful theme options panel with can be used to make awesome changes without touching any code. The theme also comes with a full width easy to use slider. Easily add a logo to your site and create a beautiful homepage using the built-in homepage layout.

Theme URL - http://www.thinkupthemes.com/free/consulting-free/
Author URL - http://www.ThinkUpThemes.com

Trac Browser - https://themes.trac.wordpress.org/browser/consulting/1.0.3

SVN - https://themes.svn.wordpress.org/consulting/1.0.3
ZIP - https://wordpress.org/themes/download/consulting.1.0.3.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=consulting/1.0.1&new_path=consulting/1.0.3

History:

Ticket Summary Status Resolution Owner
#38350 THEME: Consulting – 1.0.1 closed not-approved rabmalin
#38510 THEME: Consulting Lite – 1.0.1 closed not-approved acosmin
#43166 THEME: Consulting – 1.0.4 closed live greenshady

(this ticket)

#43325 THEME: Consulting – 1.0.5 closed live themetracbot
#43732 THEME: Consulting – 1.0.6 closed live themetracbot
#44723 THEME: Consulting – 1.0.7 closed live themetracbot
#45468 THEME: Consulting – 1.0.8 closed live themetracbot
#46275 THEME: Consulting – 1.0.9 closed live themetracbot
#47242 THEME: Consulting – 1.1.0 closed live themetracbot
#47358 THEME: Consulting – 1.1.1 closed live themetracbot
#47904 THEME: Consulting – 1.1.2 closed live themetracbot
#48468 THEME: Consultings – 1.1.3 closed not-approved Mahesh901122


https://themes.svn.wordpress.org/consulting/1.0.3/screenshot.png
Theme Check Results:

  • RECOMMENDED: No reference to add_editor_style() was found in the theme. It is recommended that the theme implement editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.
  • WARNING: "Consulting" currently has 10,000+ active installations. Please check for name collisions outside of WordPress.org before approval.

Change History (22)

#1 @thinkupthemes
6 months ago

Hello,

Given the clarification of the theme guidelines surrounding naming I am submitting this theme to take the place of Smarter. I've uploaded this ticket to replace the following one:

https://themes.trac.wordpress.org/ticket/42383

I welcome input from seniors. As mentioned in #themereview I simply request all themes be treated equally, the current situation is open for interpretation and leads to conflict. I hope the issue surrounding naming will be addressed either via the introduction of a clear definitive guidelines or in the following meta ticket:

https://meta.trac.wordpress.org/ticket/2114

Submitting this theme is my protest against the current guidelines. I imagine a negative backlash will happen, but the attention to this issue is important.

I welcome all feedback. I understand this ticket may be contraversial.

Kind regards.

Last edited 6 months ago by thinkupthemes (previous) (diff)

#2 @thinkupthemes
6 months ago

@greenshady @poena @grapplerulrich

Just pinging the admins so you can keep track of this ticket if you like, given the recent chat in #themereview. As mentioned both above and in Slack I know this ticket is potentially controversial, but I don't see why this theme wouldn't be allowed. I say this having reviewed the guidelines in great detail and based on recent decisions by seniors.

I trust in the guidelines and follow them, which is why I refer to this comment whenever in doubt if a rule is really a rule:

https://wordpress.slack.com/archives/C02RP4Y3K/p1432664344000740

I have further raised the above issue in meta, and do truly believe that's the best place to handle not only this issue, but other similar issues where there is such a huge grey area. Encouraging mods to take their own action will be a huge step forward in improving the team dynamic. At present, the admins take on way too much and are put in very difficult positions, being asked to make decisions where they really shouldn't need to.

I'm not hiding anything which is why I'm bringing this ticket to your attention.

Kind regards.

Last edited 6 months ago by thinkupthemes (previous) (diff)

#3 @acosmin
6 months ago

  • Owner set to acosmin
  • Status changed from new to reviewing

#5 @acosmin
6 months ago

@thinkupthemes not much to say :)

  1. admin\main\options\04.footer.php
    • L236, //www.wordpress.org/ needs to be translatable
  1. admin\main\options\05.blog.php
    • L48, remove esc_attr() and change the __() to esc_attr__(). the_title_attribute() is already escaped, no need to escape it twice.
    • L137, 145, use the_title_attribute()
    • L168-170, 179-181, you can do that in one line: printf( '<span class="tags">%s</span>', $tags_list );
    • L392 - you can use echo or replace %1$s with %s
      • Not really a big issue, but when you have only one argument to replace, use %s. This happens in multiple files.
  1. template-sitemap.php
    • You need to end that WP_Query with wp_reset_postdata()

#6 @themetracbot
6 months ago

  • Summary changed from THEME: Consulting – 1.0.3 to THEME: Consulting – 1.0.4

Consulting - 1.0.4

Consulting is the free version of the multi-purpose professional theme (Consulting Pro) ideal for a business or blog website. The theme has a responsive layout, HD retina ready and comes with a powerful theme options panel with can be used to make awesome changes without touching any code. The theme also comes with a full width easy to use slider. Easily add a logo to your site and create a beautiful homepage using the built-in homepage layout.

Theme URL - http://www.thinkupthemes.com/free/consulting-free/
Author URL - http://www.ThinkUpThemes.com

Trac Browser - https://themes.trac.wordpress.org/browser/consulting/1.0.4

SVN - https://themes.svn.wordpress.org/consulting/1.0.4
ZIP - https://wordpress.org/themes/download/consulting.1.0.4.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=consulting/1.0.3&new_path=consulting/1.0.4

History:

Ticket Summary Status Resolution Owner
#38350 THEME: Consulting – 1.0.1 closed not-approved rabmalin
#38510 THEME: Consulting Lite – 1.0.1 closed not-approved acosmin
#43166 THEME: Consulting – 1.0.4 closed live greenshady

(this ticket)

#43325 THEME: Consulting – 1.0.5 closed live themetracbot
#43732 THEME: Consulting – 1.0.6 closed live themetracbot
#44723 THEME: Consulting – 1.0.7 closed live themetracbot
#45468 THEME: Consulting – 1.0.8 closed live themetracbot
#46275 THEME: Consulting – 1.0.9 closed live themetracbot
#47242 THEME: Consulting – 1.1.0 closed live themetracbot
#47358 THEME: Consulting – 1.1.1 closed live themetracbot
#47904 THEME: Consulting – 1.1.2 closed live themetracbot
#48468 THEME: Consultings – 1.1.3 closed not-approved Mahesh901122


https://themes.svn.wordpress.org/consulting/1.0.4/screenshot.png
Theme Check Results:

  • RECOMMENDED: No reference to add_editor_style() was found in the theme. It is recommended that the theme implement editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.
  • WARNING: "Consulting" currently has 10,000+ active installations. Please check for name collisions outside of WordPress.org before approval.

#7 @acosmin
6 months ago

  • Resolution set to live
  • Status changed from reviewing to closed

@thinkupthemes :) you'll also need to escape the www.wordpress.org url using esc_url() in admin/main/options/04.footer.php:L236. You can do this in the next update...

Anyway, everything looks ok based on diff, so congrats :) your theme should be live shortly.

#8 @dingdang
5 months ago

@greenshady

This theme's name/slug had a warning that is already used (10K times) of which are aware both the theme author and the reviewer as well may be the next level reviewer but anyway it was approved.

The question is - why?

The reviewer has a history of rejecting other proposed themes with the similar problem, examples:

@acosmin:
https://themes.trac.wordpress.org/ticket/40283
https://themes.trac.wordpress.org/ticket/40338

The author also knows what he is doing (kind of "protest") but staring that and having it successfully approved is eventually causing problems to all previously installed themes with the same slug and some percent of the sites owners possibly followed the update procedure and jumbled their sites.

While anyone is free to upload any kind of theme proposals, why:

  1. The reviewer joined the action
  2. The next level reviewer also let that to pass trough.

Why other themes are getting rejected in similar conditions (and treated differently).

#9 @thinkupthemes
5 months ago

@dingdang

I'll refrain from getting involved beyond this comment. But just want to share what was being discussed in Slack around the time around naming before this theme was approved:

https://wordpress.slack.com/archives/C02RP4Y3K/p1495699731430444

You'll see that at that time many (rightly or wrongly) assumed that naming was not being policied. It may be helpful for you to read the logs for your own development and to better understand the circumstances as they were understood by some at that time.

Lessons are constantly being learned, and guidelines clarified. The clarity that comes with hindsight is a beautiful thing, so it's best to view this ticket through the eyes of those at that time.

Kind regards.

#10 @dingdang
5 months ago

@thinkupthemes yes I know your reasons to do what you did but on the other hand I can share my thoughts. Since WordPress' way to identify themes (and so to try to update them) is far from good, your action of "protest" as a side effect may be messed hundreds of sites on the web. The easiest thing in the world is the destruction and you should think twice before submitting it, @acosmin to approve it and whoever is an "admin" to close his eyes.

All of this doesn't mean that now it couldn't be repaired and the theme - suspended. @greenshady

P.S. Nothing personal, I see in the mentioned discussion you do defend the same view as mine which is simple - everyone to be treated equally.

#11 @acosmin
5 months ago

@dingdang Those are just two tickets I closed for active installs :) I have at least a dozen more.

Please look at the date mark in this meta ticket https://meta.trac.wordpress.org/ticket/2114

I've been trying to make it right for almost a year, with a meta ticket and "policing names".

The problem with this ticket is in the Slack logs presented at comment nr.9 and https://wordpress.slack.com/archives/C02RP4Y3K/p1495694325710438

I've been very vocal on this subject as you can see.

Also, before I set this theme live, all admins were pinged (not just one like you did) and waited a week before doing anything. Didn't get even a "Hi" message, there are only 3 people talking in this ticket.

I guess you'll get your answers the same way, one each week. You'll get bored at some point and give up.

Last edited 5 months ago by acosmin (previous) (diff)

#12 @thinkupthemes
5 months ago

@dingdang

Thank you for sharing your concerns.

Your suggestion doesn't address any of the potential issues you raise, it actually causes more damage, denying existing .org users to updates (important given the many changes in the .org horizon). The theme was submitted and approved based on the best understanding of the guidelines at the time. As mentioned before hindsight is a wonderful thing.

To clarify, the intention of the protest submission was exactly to get more people talking and involved. I've been involved in many sub-projects and find that authors are reluctant to engage and help develop the community until a case like this comes around. The solution to all of this is to address the meta ticket linked to above by acosmin.

I want more people to stop talking so much and actually get involved.

P.S. I will genuinely try not to comment further, despite what I said in the comment above. But you do make it difficult. :-)

#13 @dingdang
5 months ago

@thinkupthemes such arguments may work with someone that has an IQ less than 100, I think you underestimate me.

What you say "denying existing user updates" as a defense not to suspend the theme would mean that anyone under the same potential action could say it and so you are trying to point into direction that suspensions shouldn't exist at all. Which is not the case as I understood, and which means that such an argument is pointless. If there are reasons for suspension it should be implemented and that's actually another damage you did to these potential downloaders, that you knew that one day the theme could be taken off the directory. There is an example in the directory of a suspended theme with pretty large number of active installs, so there is a precedent. In SLACK @greenshady confirmed that he would suspend someone's theme with conflicting name if approved, so this one shouldn't be an exception with so big number of collisions.

Also trying to get attention to a problem by damaging others that are not aware of your wars is more like what kids do in the kindergarten, not adults in a community like this. Or you look like someone that blows himself out in the middle of a square as a last measure to be seen. No one likes that.

Last edited 5 months ago by dingdang (previous) (diff)

#14 @thinkupthemes
5 months ago

@dingdang

Golly, you had to go and drag another comment out of me. lol :-)

Thanks again for your comments. It really is coming across like you have a chip on your shoulder and are just trolling. Well I avoid conflict and won't be getting dragged into such behavior.

As I understand it, theme suspensions are in place where rules have been knowingly broken or themes have clear security / licensing issues (again, this is to the best of my knowledge). None of these are relevant in this case. Check the logs, read this ticket, everything was transparent, and as I've mentioned many times above, this theme was submitted and reviewed in line with the guidelines as I understood them at that time. Have such guidelines been clarified since this theme was reviewed? Possibly.

Look I'm sure you're a nice person and don't mean to come across violent. So here's a friendly high 5 [raising my hand]. :-)

Enjoy the rest of your weekend.

#15 @greenshady
5 months ago

A couple of notes:

1) Other themes are not relevant to this ticket. We will not discuss them here. This ticket is for discussing issues specifically with the Consulting theme. Anything beyond that doesn't belong in the ticket.

2) We will not discuss individuals in the ticket either. If you have an issue with a reviewer or a theme author, you can PM one of the team leads on Slack. They will look into the situation and make a decision.

With that out of the way, I'll try to reply to any theme-specific questions you have.

Replying to dingdang:

This theme's name/slug had a warning that is already used (10K times) of which are aware both the theme author and the reviewer as well may be the next level reviewer but anyway it was approved.

The question is - why?

It was incorrectly approved. We're taking steps internally to make sure this doesn't happen again and still discussing what should happen, if anything, in this specific case.

#16 follow-up: @dingdang
5 months ago

@greenshady

Theme submitted: 05/25/17
Theme approved: 05/31/17, days = 6 (!)
Theme goes live: 05/31/17
Today: 07/08/17, days = 38

Please clarify "taking steps internally". Where one can see what steps are made so far? Where is the discussion or a memo about "this specific case". Please share this info inside this ticket if anyone else is interested in that case. Since you directly said at slack, that you would suspend a theme that has a naming collisions (and this one has that in a 5 digit range), what are the options here that you have? Or is this a special case for you, too?

Additional question - most of the themes in the queue wait for 2 months, this one was reviewed and approved in 6 days. Another point that the theme was treated differently.

@thinkupthemes I guess the word "trolling" is a modern, too, and by trying to assign it to someone's important questions is may be an easy way to leave the questions w/o answers, but for that specific case the questions are pretty simple, answers are clear, but for some reason it is left as is. Is it just a way for someone to show the power of a combination of a developer, a reviewer and an admin can do anything within the directory w/o any sanction?

And if someone brings that up, he just get "go complain to the Armenian pope (i.e. to nobody), you are trolling". It's like if in a society you see someone to kill another one at the street and try to do something, a bunch of strange people to come and say "don't do anything, be calm, we are happy with that". Then after some time passes, another one - "it's too late to do anything, the person passed anyway" - reminds me of some dark ages. Frankly, I didn't expect this is so at wordpress.org.

This ticket was mentioned in Slack in #themereview by dingdang. View the logs.


5 months ago

#18 @thinkupthemes
5 months ago

@dingdang

Thank you again for sharing your comments. Please do take the time to consider how you are coming across. There are a number of statements you've made in numerous comments that are highly aggressive and come across as promoting hatred and violence.

Some examples of such comments are:

you look like someone that blows himself out in the middle of a square...

It's like if in a society you see someone to kill another one at the street...

These comments are extremely violent and aggressive. Please kindly familiarise yourself with the code of conduct expected from all members of the community. Here is alink to a code of conduct page at a recent WordCamp I attended:

https://2017.london.wordcamp.org/code-of-conduct/

Please behave in a manner online as you would offline.

Kind regards.

#19 in reply to: ↑ 16 @greenshady
5 months ago

@thinkupthemes, @acosmin - I'd ask that you both refrain from replying here unless someone brings up a specific issue (unrelated to naming) with the theme that needs to be addressed.

As far as the naming discussion goes, the team leads will post in this ticket if/when we feel it necessary to do so. Thanks to everyone for the feedback.

#20 @ilovewpcom
4 months ago

  • Resolution live deleted
  • Status changed from closed to reopened

Hi,

In light of this ticket: https://themes.trac.wordpress.org/ticket/43517#comment:30

I request that this theme be urgently suspended from the repository and/or be renamed to something else.

Thank you.

cc @grapplerulrich, @greenshady, @poena

#21 @greenshady
4 months ago

  • Owner changed from acosmin to greenshady
  • Status changed from reopened to reviewing

#22 @greenshady
4 months ago

  • Resolution set to live
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.