WordPress.org

Make WordPress Themes

Opened 7 months ago

Closed 5 months ago

#43251 closed theme (not-approved)

THEME: WPAgency – 1.0

Reported by: lpkapil008 Owned by: catchthemes
Priority: new theme Keywords: theme-wpagency
Cc: kapil.yadav@…

Description

WPAgency - 1.0

WP Agency brings your site to life with header video and immersive featured images. With a focus on business sites, it features multiple sections on the front page as well as widgets, navigation and social menus, a logo, and more.

Theme URL - http://infobeans.com
Author URL - https://profiles.wordpress.org/lpkapil008

Trac Browser - https://themes.trac.wordpress.org/browser/wpagency/1.0

SVN - https://themes.svn.wordpress.org/wpagency/1.0
ZIP - https://wordpress.org/themes/download/wpagency.1.0.zip?nostats=1

History:

Ticket Summary Status Resolution Owner
#43251 THEME: WPAgency – 1.0 closed not-approved catchthemes

(this ticket)


https://themes.svn.wordpress.org/wpagency/1.0/screenshot.png

Change History (5)

#1 @lpkapil008
6 months ago

Hi,

How much time it would take to review this theme ? I did not hear any feedback from review team.

Thanks

#2 @rabmalin
6 months ago

When your theme reaches to the top of the Review Queue, reviewer will be assigned and review process will follow procedures found in the Theme Review Handbook. Ticket will be closed as not-approved if theme has more than 5 distinct issues. So, please check your theme against Theme Review Guidelines to avoid closing of ticket.

Note: This is not a review.

#3 @joyously
5 months ago

Here is some user feedback to consider before your review.

  • A theme cannot "require" plugins. Themes must work without plugins.
  • The menu needs to have a fallback for when no menu is selected. The default value of fallback_cb parameter of wp_nav_menu() works really well, and it's core functionality.
  • Show correct content on front page. See this article.
  • Social media icons should be disabled by default (since you don't have the proper URLs).
  • The menu I selected is not shown. Change the menu parameter to theme_location in wp_nav_menu().
  • Any limitations (such as menu depth=1) need to be documented for the user.
  • The mobile menu is not disappearing on window size change, so I see two menus.
  • The content text is too low contrast (light gray on white). It is very tiring to read.
  • Page links (generated by <!--nextpage-->) are not being output on Pages.
  • Theme is not defining WordPress standard classes. See the codex.
  • Large images are overflowing the container. Use img {max-width:100%; height:auto;} to fix.
  • Large images with captions are overflowing the container. Use .wp-caption {max-width:100%; height:auto;} to fix.
  • The links at the bottom of an archive page are from the_posts_pagination() but are labeled Posts Navigation. This is confusing, because in WordPress, Post Navigation is for the links on a single post page, which this theme does not have (but would be useful).

https://s15.postimg.org/qus4mc963/pagination.jpg

  • Comments are showing the ordered list number, which is confusing for paged and nested comments. Try using CSS to hide the number or CSS counters to make it more logical.
  • Floats are not being cleared properly after the content area.
  • You might want to hide the menu, comment form, widget areas for the print styles.
  • <h1> tag did not get a font-size after the CSS reset, so it is the same as regular text.
  • <h5> is a bit small, <h6> is quite small. How is that a heading?
  • blockquote is styled as italic, but can have nested <em> and <cite> tags which are indistinguishable. It doesn't really need italics, because it has a left bar.
  • <cite> tag looks like regular text.
  • Lists have a bottom margin that looks odd on nested lists.
  • The space between paragraphs feels too large for the font size.
  • <big> is not big.
  • A long line in a <pre> tag overflows the container, causing a scrollbar.
  • <q> tag is unstyled (default removed).
  • <small> is not small.
  • <tt> and <var> are unstyled (default removed).
  • A lot of the styling problems just listed are caused by using a CSS reset. Consider using normalize instead. See http://necolas.github.io/normalize.css/
  • Theme should support the gallery default of 3 columns.
  • There are no archive page titles.
  • The search.php file has no code, so searches do not work.
  • I never saw any sidebars on any pages.
  • Remove jQuery.min.js because it is bundled with WordPress.

#4 @catchthemes
5 months ago

  • Owner set to catchthemes
  • Status changed from new to reviewing

#5 @catchthemes
5 months ago

  • Resolution set to not-approved
  • Status changed from reviewing to closed

Hello @lpkapil008,

Thanks for uploading theme, I don't think your theme is ready to be realeased yet, here are the list of issues you need to fix.

ISSUES:

  • Header Text color option not working
  • No minification of scripts or files unless you provide original files
    • Add unminified version of all the minified files
  • Proper license and attribution of resources(images, javascripts, css) used by theme not found
    • Go to this link for proper copyright and attribution
    • Add direct link of image used in screenshot
    • All the resources must be under GPL Compatible license
  • Function prefix missing in most of the places please check functions.php file and other files too
  • Header Image is not shown in theme
  • Logo is not shown in theme
  • Can you please explain how to edit or remove the default banner image of theme? Please remove that image use header image option instead
  • Sub menu in theme is not displayed
  • Make social icons in footer disabled by default
  • Themes can only recommend plugins not make them required
  • Escape missing in content-front-page.php line 25, 102
  • Use the_excerpt instead of wp_trim_words

Do not get discouraged. A closed ticket is not the end. We want you to resubmit your theme. We do ask that you spend a bit more time making sure that your theme meets all the requirements before we make it live.

If you need help with anything or want me to explain further, don’t hesitate to post here in this ticket. I’m happy to answer any questions you have. Or, feel free to post over on our Slack channel.

Note: See TracTickets for help on using tickets.