WordPress.org

Make WordPress Themes

Opened 6 months ago

Closed 4 months ago

Last modified 4 months ago

#44377 closed theme (not-approved)

THEME: Reader WP Lite – 1.0.3

Reported by: Litonice13 Owned by: sampression
Priority: previously reviewed Keywords: theme-reader-wp-lite accessibility-ready
Cc: litonice09@…

Description

Reader WP Lite - 1.0.2

Reader WP Lite is a Personal Blogging WordPress Theme

Theme URL - http://demo.prowptheme.com/reader/
Author URL - https://profiles.wordpress.org/Litonice13

Trac Browser - https://themes.trac.wordpress.org/browser/reader-wp-lite/1.0.2

SVN - https://themes.svn.wordpress.org/reader-wp-lite/1.0.2
ZIP - https://wordpress.org/themes/download/reader-wp-lite.1.0.2.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=reader-wp-lite/1.0.1&new_path=reader-wp-lite/1.0.2

History:

Ticket Summary Status Resolution Owner
#42730 THEME: Reader WP Lite – 1.0.1 closed not-approved poena
#44377 THEME: Reader WP Lite – 1.0.3 closed not-approved sampression

(this ticket)

#45893 THEME: Reader WP Lite – 1.0.9 closed live poena
#46750 THEME: Reader WP Lite – 2.0.0 closed live themetracbot


https://themes.svn.wordpress.org/reader-wp-lite/1.0.2/screenshot.jpg
Theme Check Results:

  • RECOMMENDED: Tags: is either empty or missing in style.css header.
  • WARNING: Found a translation function that is missing a text-domain. Function , with the arguments '
  • WARNING: Found a translation function that is missing a text-domain. Function , with the arguments ' | Develpoed With Love by'

Change History (8)

#1 @joyously
4 months ago

Here is some user feedback to consider before your review.

  • You should look at what Theme Check is saying about text-domain. It looks like it is in the footer.
  • The menu needs to have a fallback for when no menu is selected. The default value of fallback_cb parameter of wp_nav_menu() works really well, and it's core functionality.
  • The menu is not behaving as intended. I have a menu item with a submenu. Clicking on the menu item, the submenu opens instead of navigating to the link. Clicking it again closes the submenu. This behavior would make sense if I were clicking the submenu indicator arrow, but I'm clicking the menu item, which itself is a link.
  • A long submenu item overflows its container.
  • Static Pages should not show the date.
  • The comment date is just showing the time, not the date.
  • There is no link to the comment anchor (for easy copy/paste). This is typically put on the comment date.
  • Javascript TypeError: $ is not a function wp-content/themes/reader-wp-lite/assets/js/main.js?ver=4.7.5 line 35
  • Post navigation links would be nice.
  • The post date is not using my choice of date format.
  • Floats are not being cleared properly after the content area.
  • The Page content is truncated on my normal desktop window (~1070px). A Post does the same thing. https://s2.postimg.org/4qctyqs7t/page-content-truncated.jpg
  • <h5> and <h6> are quite small. How is that a heading?
  • The headings need a bit of margin.
  • blockquote looks like normal text.
  • This CSS is problematic because the other HTML tags (tables, lists, headings, address, forms) have different styling, which is messy. The color is very low contrast and tiring to read. Also, there should be no text alignment specified for user content.
    article p {
        color: #a6a8b3;
        font-size: 18px;
        line-height: 36px;
        padding-top: 5px;
        text-align: justify;
    }
    
    https://s29.postimg.org/codkkvfev/mismatched-styling.jpg
  • Tables look all smashed together. (see calendar widget also)
  • Lists do not have bullets or numbers.
  • <q> tag is unstyled. (default removed)
  • You might want to hide the comment form for the print styles. The widget area is not showing for print preview, but the space is blank so the content is limited to half the page. Everything in the comment section is overlapping.
  • The background colors used for the different post formats do not all have enough contrast to read the text easily. https://s27.postimg.org/n12krkxr7/post-format-overlay-colors.jpg
  • Theme should support the gallery default of 3 columns.
  • The 404 page is not at all helpful. It says, "Maybe try one of the links below or a search?", but there are no links below or a search.
  • Customizer, Site Identity - changing the "Display Site Title and Tagline" option has no effect on the preview.
  • Customizer, Header Image - choosing a header image has no effect on the preview.

#2 @themetracbot
4 months ago

  • Keywords changed from theme-reader-wp-lite, accessibility-ready to theme-reader-wp-lite accessibility-ready
  • Summary changed from THEME: Reader WP Lite – 1.0.2 to THEME: Reader WP Lite – 1.0.3

Reader WP Lite - 1.0.3

Reader WP Lite is a Personal Blogging WordPress Theme

Theme URL - http://demo.prowptheme.com/reader/
Author URL - https://profiles.wordpress.org/Litonice13

Trac Browser - https://themes.trac.wordpress.org/browser/reader-wp-lite/1.0.3

SVN - https://themes.svn.wordpress.org/reader-wp-lite/1.0.3
ZIP - https://wordpress.org/themes/download/reader-wp-lite.1.0.3.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=reader-wp-lite/1.0.2&new_path=reader-wp-lite/1.0.3

History:

Ticket Summary Status Resolution Owner
#42730 THEME: Reader WP Lite – 1.0.1 closed not-approved poena
#44377 THEME: Reader WP Lite – 1.0.3 closed not-approved sampression

(this ticket)

#45893 THEME: Reader WP Lite – 1.0.9 closed live poena
#46750 THEME: Reader WP Lite – 2.0.0 closed live themetracbot


https://themes.svn.wordpress.org/reader-wp-lite/1.0.3/screenshot.jpg
Theme Check Results:

  • RECOMMENDED: Tags: is either empty or missing in style.css header.
  • WARNING: Found a translation function that is missing a text-domain. Function , with the arguments '

#3 @Litonice13
4 months ago

Hello @joyously ,
Thanks for your nice and deep review.
Tried to Fix each and every issues. If something remains then please let me know.

  1. Checked Theme check. Fixed on footer.php file
  2. wp_nav_menu() given as fallback menu as you suggested
  3. Long Submenu overflow issue remains, I will try to fix on next review.
  4. Static Page date issue fixed
  5. Comment anchor link fixed
  6. JS issue fixed
  7. Post Navigation styled beautifully
  8. Post date show - given the choice of user end
  9. Text Formatting and color contrast issue fixed
  10. Customizer Tagline fixed
  11. 404 page fixed
  12. Blockquote styled beautifully

Thanks

#4 @themetracbot
4 months ago

  • Owner set to sampression
  • Status changed from new to reviewing

#5 @sampression
4 months ago

  • Resolution set to not-approved
  • Status changed from reviewing to closed

Hi @Litonice13 ,
Some Issue to be fixed.

  1. Clearing issue shows top bar in menu.

https://content.screencast.com/users/dennishkarki/folders/Jing/media/d4d5e431-1b58-41f3-bc2e-537588c66bb3/00000021.png

  1. Archive page paragraph text not clear.

https://content.screencast.com/users/dennishkarki/folders/Jing/media/0a48ebd9-8d30-47bd-9f94-640b405fb56f/00000022.png

  1. 404 error message not fixed.
  2. WARNING: Found a translation function that is missing a text-domain. Function , with the arguments
  3. Overflow issue in responsive menu

https://content.screencast.com/users/dennishkarki/folders/Jing/media/caf4e3af-eb1d-405b-a9a3-ac0708538e71/00000023.png

#6 @Litonice13
4 months ago

Hello @sampression,
Don't understand why this Ticket is showing Closed.
I've fixed your given issues.

  1. Fixed Clearing issue shows on Top bar
  2. text-domain warning fixed
  3. Responsive Menu overflow issue fixed
  4. 404 error message fixed
  5. Archive Page Texts issue fixed.

Thanks

#7 @kevinhaig
4 months ago

@jcastaneda can you please re-open this ticket and put it back in the queue.

@sampression stop closing themes without sufficient justification. Please pay attention to the requirements.

https://make.wordpress.org/themes/handbook/review/required/

Last edited 4 months ago by kevinhaig (previous) (diff)

#8 @poena
4 months ago

Hi
This ticket can't be reopened since you already submitted a new version. I will make a note so that you do not have to wait at the end of the review queue.

Note: See TracTickets for help on using tickets.