WordPress.org

Make WordPress Themes

Opened 3 months ago

Closed 45 hours ago

Last modified 44 hours ago

#46541 closed theme (not-approved)

THEME: yui – 0.0.1.2

Reported by: conti99 Owned by: Mirucon
Priority: new theme Keywords: theme-yui child-theme parent-understrap
Cc: contiki9@…

Description

yui - 0.0.1

UnderStrap Child Theme

Theme URL - https://github.com/contiki9/wp-theme-yui
Author URL - https://cntlog.net/

Trac Browser - https://themes.trac.wordpress.org/browser/yui/0.0.1

SVN - https://themes.svn.wordpress.org/yui/0.0.1
ZIP - https://wordpress.org/themes/download/yui.0.0.1.zip?nostats=1
Parent Theme: https://wordpress.org/themes/understrap

History:

Ticket Summary Status Resolution Owner
#39195 THEME: yuiyui – 0.1 closed not-approved acosmin
#46541 THEME: yui – 0.0.1.2 closed not-approved Mirucon

(this ticket)


https://themes.svn.wordpress.org/yui/0.0.1/screenshot.png
Theme Check Results:

  • REQUIRED: Could not find wp_footer. See: wp_footer
     <?php wp_footer(); ?>
    
  • REQUIRED: Could not find wp_head. See: wp_head
     <?php wp_head(); ?>
    
  • REQUIRED: Could not find language_attributes. See: language_attributes
    <html <?php language_attributes(); ?>
    
  • REQUIRED: Could not find charset. There must be a charset defined in the Content-Type or the meta charset tag in the head.
  • REQUIRED: Could not find add_theme_support( 'automatic-feed-links' ). See: add_theme_support
     <?php add_theme_support( $feature ); ?>
    
  • REQUIRED: Could not find comments_template. See: comments_template
     <?php comments_template( $file, $separate_comments ); ?>
    
  • REQUIRED: Could not find wp_list_comments. See: wp_list_comments
     <?php wp_list_comments( $args ); ?>
    
  • REQUIRED: Could not find comment_form. See: comment_form
     <?php comment_form(); ?>
    
  • REQUIRED: Could not find body_class call in body tag. See: body_class
     <?php body_class( $class ); ?>
    
  • REQUIRED: The theme doesn't have comment pagination code in it. Use paginate_comments_links() or the_comments_navigation or the_comments_pagination or next_comments_link() and previous_comments_link() to add comment pagination.
  • REQUIRED: No content width has been defined. Example:
    if ( ! isset( $content_width ) ) $content_width = 900;
    
  • RECOMMENDED: No reference to add_theme_support( "custom-header", $args ) was found in the theme. It is recommended that the theme implement this functionality if using an image for the header.
  • RECOMMENDED: No reference to add_theme_support( "custom-background", $args ) was found in the theme. If the theme uses background images or solid colors for the background, then it is recommended that the theme implement this functionality.
  • RECOMMENDED: No reference to add_editor_style() was found in the theme. It is recommended that the theme implement editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.
  • WARNING: Could not find the file index.php in the theme.
  • RECOMMENDED: Could not find the file readme.txt in the theme. Please see Theme_Documentation for more information.
  • REQUIRED: This theme doesn't seem to support the standard avatar functions. Use get_avatar or wp_list_comments to add this support.
  • RECOMMENDED: No reference to nav_menu's was found in the theme. Note that if your theme has a menu bar, it is required to use the WordPress nav_menu functionality for it.
  • REQUIRED: The theme doesn't have post pagination code in it. Use posts_nav_link() or paginate_links() or the_posts_pagination() or the_posts_navigation() or next_posts_link() and previous_posts_link() to add post pagination.
  • RECOMMENDED: No reference to post-thumbnails was found in the theme. If the theme has a thumbnail like functionality, it should be implemented with add_theme_support( "post-thumbnails" )in the functions.php file.
  • REQUIRED: .sticky css class is needed in your theme css.
  • REQUIRED: .bypostauthor css class is needed in your theme css.
  • REQUIRED: .alignleft css class is needed in your theme css.
  • REQUIRED: .alignright css class is needed in your theme css.
  • REQUIRED: .aligncenter css class is needed in your theme css.
  • REQUIRED: .wp-caption css class is needed in your theme css.
  • REQUIRED: .wp-caption-text css class is needed in your theme css.
  • REQUIRED: .gallery-caption css class is needed in your theme css.
  • REQUIRED: .screen-reader-text css class is needed in your theme css. See See: the Codex for an example implementation.
  • REQUIRED: This theme doesn't seem to display tags. Modify it to display tags in appropriate locations.
  • REQUIRED: No reference to add_theme_support( "title-tag" ) was found in the theme.
  • REQUIRED: The theme must not used the <title> tags.
  • REQUIRED: The theme must not call to wp_title().
  • RECOMMENDED: This theme contains no sidebars/widget areas. See Widgets API

Change History (16)

#1 @themetracbot
4 weeks ago

  • Keywords changed from theme-yui, child-theme, parent-understrap to theme-yui child-theme parent-understrap
  • Summary changed from THEME: yui – 0.0.1 to THEME: yui – 0.0.1.1

yui - 0.0.1.1

UnderStrap Child Theme

Theme URL - https://github.com/contiki9/wp-theme-yui
Author URL - https://cntlog.net/

Trac Browser - https://themes.trac.wordpress.org/browser/yui/0.0.1.1

SVN - https://themes.svn.wordpress.org/yui/0.0.1.1
ZIP - https://wordpress.org/themes/download/yui.0.0.1.1.zip?nostats=1
Parent Theme: https://wordpress.org/themes/understrap

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=yui/0.0.1&new_path=yui/0.0.1.1

History:

Ticket Summary Status Resolution Owner
#39195 THEME: yuiyui – 0.1 closed not-approved acosmin
#46541 THEME: yui – 0.0.1.2 closed not-approved Mirucon

(this ticket)


https://themes.svn.wordpress.org/yui/0.0.1.1/screenshot.png
Theme Check Results:

  • REQUIRED: Could not find wp_footer. See: wp_footer
     <?php wp_footer(); ?>
    
  • REQUIRED: Could not find add_theme_support( 'automatic-feed-links' ). See: add_theme_support
     <?php add_theme_support( $feature ); ?>
    
  • REQUIRED: Could not find wp_list_comments. See: wp_list_comments
     <?php wp_list_comments( $args ); ?>
    
  • REQUIRED: Could not find comment_form. See: comment_form
     <?php comment_form(); ?>
    
  • REQUIRED: The theme doesn't have comment pagination code in it. Use paginate_comments_links() or the_comments_navigation or the_comments_pagination or next_comments_link() and previous_comments_link() to add comment pagination.
  • REQUIRED: No content width has been defined. Example:
    if ( ! isset( $content_width ) ) $content_width = 900;
    
  • RECOMMENDED: No reference to add_theme_support( "custom-header", $args ) was found in the theme. It is recommended that the theme implement this functionality if using an image for the header.
  • RECOMMENDED: No reference to add_theme_support( "custom-background", $args ) was found in the theme. If the theme uses background images or solid colors for the background, then it is recommended that the theme implement this functionality.
  • RECOMMENDED: No reference to add_editor_style() was found in the theme. It is recommended that the theme implement editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.
  • WARNING: Could not find the file index.php in the theme.
  • RECOMMENDED: Could not find the file readme.txt in the theme. Please see Theme_Documentation for more information.
  • REQUIRED: This theme doesn't seem to support the standard avatar functions. Use get_avatar or wp_list_comments to add this support.
  • REQUIRED: The theme doesn't have post pagination code in it. Use posts_nav_link() or paginate_links() or the_posts_pagination() or the_posts_navigation() or next_posts_link() and previous_posts_link() to add post pagination.
  • RECOMMENDED: No reference to post-thumbnails was found in the theme. If the theme has a thumbnail like functionality, it should be implemented with add_theme_support( "post-thumbnails" )in the functions.php file.
  • REQUIRED: .sticky css class is needed in your theme css.
  • REQUIRED: .bypostauthor css class is needed in your theme css.
  • REQUIRED: .alignleft css class is needed in your theme css.
  • REQUIRED: .alignright css class is needed in your theme css.
  • REQUIRED: .aligncenter css class is needed in your theme css.
  • REQUIRED: .wp-caption css class is needed in your theme css.
  • REQUIRED: .wp-caption-text css class is needed in your theme css.
  • REQUIRED: .gallery-caption css class is needed in your theme css.
  • REQUIRED: .screen-reader-text css class is needed in your theme css. See See: the Codex for an example implementation.
  • RECOMMENDED: Tags: is either empty or missing in style.css header.
  • REQUIRED: This theme doesn't seem to display tags. Modify it to display tags in appropriate locations.
  • REQUIRED: No reference to add_theme_support( "title-tag" ) was found in the theme.
  • REQUIRED: The theme must not used the <title> tags.
  • REQUIRED: The theme must not call to wp_title().
  • RECOMMENDED: This theme contains no sidebars/widget areas. See Widgets API

#2 @Mirucon
4 weeks ago

  • Owner set to Mirucon
  • Status changed from new to reviewing

#3 @Mirucon
4 weeks ago

Hi @conti99,

Thanks for uploading a theme. Your theme has been reviewed against these requirements: https://make.wordpress.org/themes/handbook/review/required

Please fix the issues, then upload a new version here: https://wordpress.org/themes/upload/

Requied:

  • All untrusted data need to be escaped before output. Check these and escape with the suitable escaping function: loop-templates/content.php L15, 20
  • Please provide a unique prefix for everything the Theme defines in the public namespace, including options, functions, global variables, constants. Check these names: functions.php L15, 35
  • You are trying to enqueue undefined script - remove the line, or add js/child-theme.min.js.
  • You cannot use translations from the parent theme. If you want to use a translatable string, then you will need to use your own textdomain.
Fred WordPress Theme, Copyright 2012 Joe Smith
Fred is distributed under the terms of the GNU GPL
  • In your readme file, please keep the copyright declaration for the parent theme.
Ginger WordPress Theme is child theme of Fred WordPress Theme, Copyright 2012 Joe Smith
Fred is distributed under the terms of the GNU GPL
  • When you bundle minified CSS/JS file in your theme, non-minified version of it should be included in the theme too. Missing non-minified files for: css/style.css

Recommended:


If there is no response from the author for 7 days, the ticket will be closed due to inactivity. If you think you'll need more time, you can let me know so I can keep the ticket open.

#4 @conti99
4 weeks ago

Hi @Mirucon,
Thank you.

I will respond to your advice.
Wait a moment.

#5 @conti99
4 weeks ago

Hi @Mirucon,

I have a question

Please provide a unique prefix for everything the Theme defines in the public namespace, including options, functions, global variables, constants. Check these names: functions.php L15, 35

It is a function of this indication, but it is a function of the parent theme.
Myme theme is not defined by Theme in the public namespace. What should I do in this case?

Function name all_excerpts_get_more_link

#6 @Mirucon
3 weeks ago

You can simply prefix the function names, what do you mean by it is a function of the parent theme?

Since the function is just modifying the hook, it would work no matter what the function name is.

#7 @conti99
3 weeks ago

Hi @Mirucon,

Thank you
The function of the parent theme is the call of the Read more button.

We will modify it to be defined in the public namespace.

#8 @Mirucon
3 weeks ago

Well you don't need to use PHP namespaces. All you need to is to prefix the function names. I am not sure whether you could understand my review properly.

#9 @conti99
3 weeks ago

All you need to is to prefix the function names.

OK.
I understand.

#10 @themetracbot
3 weeks ago

  • Summary changed from THEME: yui – 0.0.1.1 to THEME: yui – 0.0.1.2

yui - 0.0.1.2

UnderStrap Child Theme

Theme URL - https://github.com/contiki9/wp-theme-yui
Author URL - https://cntlog.net/

Trac Browser - https://themes.trac.wordpress.org/browser/yui/0.0.1.2

SVN - https://themes.svn.wordpress.org/yui/0.0.1.2
ZIP - https://wordpress.org/themes/download/yui.0.0.1.2.zip?nostats=1
Parent Theme: https://wordpress.org/themes/understrap

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=yui/0.0.1.1&new_path=yui/0.0.1.2

History:

Ticket Summary Status Resolution Owner
#39195 THEME: yuiyui – 0.1 closed not-approved acosmin
#46541 THEME: yui – 0.0.1.2 closed not-approved Mirucon

(this ticket)


https://themes.svn.wordpress.org/yui/0.0.1.2/screenshot.png
Theme Check Results:

  • REQUIRED: Could not find wp_footer. See: wp_footer
     <?php wp_footer(); ?>
    
  • REQUIRED: Could not find add_theme_support( 'automatic-feed-links' ). See: add_theme_support
     <?php add_theme_support( $feature ); ?>
    
  • REQUIRED: Could not find wp_list_comments. See: wp_list_comments
     <?php wp_list_comments( $args ); ?>
    
  • REQUIRED: Could not find comment_form. See: comment_form
     <?php comment_form(); ?>
    
  • REQUIRED: The theme doesn't have comment pagination code in it. Use paginate_comments_links() or the_comments_navigation or the_comments_pagination or next_comments_link() and previous_comments_link() to add comment pagination.
  • REQUIRED: No content width has been defined. Example:
    if ( ! isset( $content_width ) ) $content_width = 900;
    
  • RECOMMENDED: No reference to add_theme_support( "custom-header", $args ) was found in the theme. It is recommended that the theme implement this functionality if using an image for the header.
  • RECOMMENDED: No reference to add_theme_support( "custom-background", $args ) was found in the theme. If the theme uses background images or solid colors for the background, then it is recommended that the theme implement this functionality.
  • RECOMMENDED: No reference to add_editor_style() was found in the theme. It is recommended that the theme implement editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.
  • WARNING: .ds_store Hidden Files or Folders found.
  • WARNING: Could not find the file index.php in the theme.
  • RECOMMENDED: Could not find the file readme.txt in the theme. Please see Theme_Documentation for more information.
  • REQUIRED: This theme doesn't seem to support the standard avatar functions. Use get_avatar or wp_list_comments to add this support.
  • REQUIRED: The theme doesn't have post pagination code in it. Use posts_nav_link() or paginate_links() or the_posts_pagination() or the_posts_navigation() or next_posts_link() and previous_posts_link() to add post pagination.
  • RECOMMENDED: No reference to post-thumbnails was found in the theme. If the theme has a thumbnail like functionality, it should be implemented with add_theme_support( "post-thumbnails" )in the functions.php file.
  • REQUIRED: .sticky css class is needed in your theme css.
  • REQUIRED: .bypostauthor css class is needed in your theme css.
  • REQUIRED: .alignleft css class is needed in your theme css.
  • REQUIRED: .alignright css class is needed in your theme css.
  • REQUIRED: .aligncenter css class is needed in your theme css.
  • REQUIRED: .wp-caption css class is needed in your theme css.
  • REQUIRED: .wp-caption-text css class is needed in your theme css.
  • REQUIRED: .gallery-caption css class is needed in your theme css.
  • REQUIRED: .screen-reader-text css class is needed in your theme css. See See: the Codex for an example implementation.
  • WARNING: Found wrong tag, remove Two Columns from your style.css header.
  • REQUIRED: This theme doesn't seem to display tags. Modify it to display tags in appropriate locations.
  • REQUIRED: No reference to add_theme_support( "title-tag" ) was found in the theme.
  • REQUIRED: The theme must not used the <title> tags.
  • REQUIRED: The theme must not call to wp_title().
  • RECOMMENDED: This theme contains no sidebars/widget areas. See Widgets API

#11 @conti99
3 weeks ago

Hi @Mirucon,

I'm sorry to disturb you.
I fixed it.
Please check again.

#12 @Mirucon
2 weeks ago

There are still a few things that need to be fixed.

  • Prefixing issue - functions.php L15
  • $thum should be escaped with esc_url(), loop-templates/content.php L18
  • When you bundle minified CSS/JS file in your theme, non-minified version of it should be included in the theme too. Missing non-minified files for css/style.css
  • I am getting PHP fatal errors.
    ( ! ) Fatal error: Uncaught Error: Class 'WP_Bootstrap_Navwalker' not found in /var/www/html/wp-content/themes/yui/header.php on line 70
    ( ! ) Error: Class 'WP_Bootstrap_Navwalker' not found in /var/www/html/wp-content/themes/yui/header.php on line 70
    
  • "Two Columns" is not a valid tag. use "two-columns" instead.
  • This theme name is not Fred, your name is not Joe Smith, and the parent theme of this theme is not Ginger. Please replace them with the names which are supposed to be.
  • These meta tags would be plugin territory. Consider to remove them.
    <meta name="mobile-web-app-capable" content="yes">
    <meta name="apple-mobile-web-app-capable" content="yes">
    <meta name="apple-mobile-web-app-title" content="<?php bloginfo( 'name' ); ?> - <?php bloginfo( 'description' ); ?>">
    

#13 @conti99
12 days ago

Thank you.
I will respond to your advice.
Wait a moment.

#14 @Mirucon
12 days ago

Note that the parent theme has some required issues. This theme keeps in reviewing until the issues in the parent theme are fixed.

Last edited 12 days ago by Mirucon (previous) (diff)

#15 @Mirucon
45 hours ago

  • Resolution set to not-approved
  • Status changed from reviewing to closed

I was waiting but as there's no update for two weeks, the ticket had to be closed.

The parent theme's issues have been fixed, so your theme could go live right away in the next review.

#16 @conti99
44 hours ago

I'm sorry
I will redo the application from new again.

Note: See TracTickets for help on using tickets.