WordPress.org

Make WordPress Themes

Opened 4 weeks ago

Closed 4 weeks ago

Last modified 3 weeks ago

#46668 closed theme (live)

THEME: Astra – 1.0.20

Reported by: brainstormforce Owned by: themetracbot
Priority: theme update Keywords: theme-astra
Cc: info@…

Description

Astra - 1.0.20

Astra is the fastest, fully customizable & beautiful theme suitable for blogs, personal portfolios and business websites. It is very lightweight (less than 50KB on frontend) and offers unparalleled speed. Built with SEO in mind, Astra comes with schema.org code integrated so search engines will love your site. Astra offers plenty of sidebar options and widget areas giving you a full control for customizations. Furthermore, we have included special features and templates so feel free to choose any of your favorite page builder plugin to create pages flexibly. Some of the other features: # WooCommerce Ready # Responsive # Compatible with major plugins # Translation Ready # Extendible with premium addons # Regularly updated # Designed, Developed, Maintained & Supported by Brainstorm Force. Looking for a perfect base theme? Look no further. Astra is fast, fully customizable and beautiful theme!

Theme URL - http://wpastra.com/
Author URL - http://wpastra.com/about/

Trac Browser - https://themes.trac.wordpress.org/browser/astra/1.0.20

SVN - https://themes.svn.wordpress.org/astra/1.0.20
ZIP - https://wordpress.org/themes/download/astra.1.0.20.zip?nostats=1

Diff with previous version: https://themes.trac.wordpress.org/changeset?old_path=astra/1.0.19&new_path=astra/1.0.20

History:

Ticket Summary Status Resolution Owner
#41945 THEME: Astra – 1.0.0 closed not-approved poena
#42018 THEME: Astra – 1.0.5.1 closed live wenthemes
#43321 THEME: Astra – 1.0.5.2 closed live themetracbot
#43563 THEME: Astra – 1.0.6 closed live themetracbot
#43673 THEME: Astra – 1.0.7 closed live themetracbot
#43887 THEME: Astra – 1.0.8 closed live themetracbot
#43934 THEME: Astra – 1.0.9 closed live themetracbot
#44586 THEME: Astra – 1.0.10 closed live themetracbot
#44658 THEME: Astra – 1.0.17 closed closed-newer-version-uploaded grapplerulrich
#45921 THEME: Astra – 1.0.18 closed live themetracbot
#46421 THEME: Astra – 1.0.19 closed live themetracbot
#46668 THEME: Astra – 1.0.20 closed live themetracbot

(this ticket)

#46968 THEME: Astra – 1.0.21 closed live themetracbot
#47038 THEME: Astra – 1.0.22 closed live themetracbot
#47287 THEME: Astra – 1.0.23 closed live themetracbot
#47339 THEME: Astra – 1.0.24 closed live themetracbot


https://themes.svn.wordpress.org/astra/1.0.20/screenshot.jpg
Theme Check Results:

  • RECOMMENDED: No reference to add_theme_support( "custom-header", $args ) was found in the theme. It is recommended that the theme implement this functionality if using an image for the header.
  • RECOMMENDED: No reference to add_theme_support( "custom-background", $args ) was found in the theme. If the theme uses background images or solid colors for the background, then it is recommended that the theme implement this functionality.

Change History (8)

#1 @themetracbot
4 weeks ago

  • Owner set to themetracbot
  • Status changed from new to reviewing

Theme Update for existing Live theme - automatically reviewed

#2 @themetracbot
4 weeks ago

  • Resolution set to live
  • Status changed from reviewing to closed

Theme Update for existing Live theme - automatically approved

#3 @williampatton
3 weeks ago

Hi @brainstormforce

A few users have commented on the screenshot in your theme. It seems to be very hard to replicate with the options exposed by the theme as-is. If you were unaware the current guideline is that screenshots must depict a reasonable representation of what an average user could possibly build with a theme.

I can see this screenshot is of the landing page of the themes site. That site is using a child of this theme, are you certain that this is buildable without the modifications added by the child?

I tried myself to replicate it for 30 minutes and was unable to reach the point where what I had on my test site closely matched what is in the screenshot. I had to write raw html and custom css to make it happen. It's unrealistic to expect the majority of users to have the skills to allow them to build such a thing easily.

I noted a support ticket from last week regarding this as well where it was stated a guide would be forthcoming that details how to replicate the screenshot. Could that guide be included with the theme as part of the documentation so that users have an easy to follow set of steps to recreate something similar to the screenshot?

#4 @brainstormforce
3 weeks ago

Hello @williampatton,

Astra is a theme made to work with Page Builders. We offer several ready websites that users can import easily using our Astra Sites plugin available on WordPress Repository.

Plugin Download - https://wordpress.org/plugins/astra-sites/
Documentation that explains how it works - https://wpastra.com/docs/installing-importing-astra-sites/

We are still in the process of improving the overall documentation and as we do not have one available for the previous screenshot just yet, I have updated the screenshot which is ready for users to replicate using the mentioned plugin above.

Please feel free to let me know if you have any further questions.

Last edited 3 weeks ago by brainstormforce (previous) (diff)

#5 @williampatton
3 weeks ago

Hi @brainstormforce,

Thank you for the reply, I have looked at the Astra Sites plugin and the layout matching the screenshot of your theme is not available to import. There are layouts similar to it however they are only available behind a paywall.

Without the use of custom CSS, additional code for filtering values or a page template not present in your theme I believe that what is shown in the screenshot is not possible to be created with the theme.

If the screenshot depicts something that is only possible through the use of an external plugin or some other kind of modification for the base theme behaviour then some documentation about that would be incredibly useful to those that download your theme.

Bear in mind the screenshot should be of the actual theme and show a reasonable representation of what can be achieved with it. This screenshot is taken from the landing site of the theme which uses a child of this theme. Can the screenshot be reverted to the previous version or changed to one that shows this current theme in action?

#6 @brainstormforce
3 weeks ago

Hi @williampatton: My response below:

# I have looked at the Astra Sites plugin and the layout matching the screenshot of your theme is not available to import. There are layouts similar to it however they are only available behind a paywall.

I think you might have missed it. Please check this video I quickly made that would give you an idea - https://www.youtube.com/watch?v=pdagy_mREIs

# Without the use of custom CSS, additional code for filtering values or a page template not present in your theme I believe that what is shown in the screenshot is not possible to be created with the theme.

A complete website similar as screenshot can be achieved in less than 10 minutes. Please note that in the latest release today, we have updated the screenshot.

# If the screenshot depicts something that is only possible through the use of an external plugin or some other kind of modification for the base theme behaviour then some documentation about that would be incredibly useful to those that download your theme.

Sure, thanks for the feedback. I will take care of this.

# Bear in mind the screenshot should be of the actual theme and show a reasonable representation of what can be achieved with it. This screenshot is taken from the landing site of the theme which uses a child of this theme.

No problem.

# Can the screenshot be reverted to the previous version or changed to one that shows this current theme in action?

I have updated the screenshot and have created a video that explains how users can replicate a website as in the screenshot for them.

#7 @williampatton
3 weeks ago

Hi @brainstormforce,

I had not noticed you updated the screenshot in a later update. The new screenshot looks like an exact match for something that can be created in the theme. And with the importer it is very easy to do it :)

The video guide that you provide should be enough documentation for users to build similar layouts and to help them build their own. I am sure users will be happier getting started with the theme thanks to that video :)

I apologize for any inconvenience caused by this. The screenshot had been mentioned in the slack channel and again to me by a confused user and I thought it worth following up with. Thank you for being understanding!

#8 @brainstormforce
3 weeks ago

No problem at all!

Thank you for all you do for the WordPress community.

Note: See TracTickets for help on using tickets.