WordPress.org

Make WordPress Themes

Opened 3 years ago

Closed 2 years ago

Last modified 23 months ago

#5567 closed theme (closed-newer-version-uploaded)

THEME: Startup - 1.0

Reported by: TidyThemes Owned by: saymar90
Priority: Keywords: theme-startup
Cc: contact@…

Description

Startup - 1.0

A more rich theme than our others for startups who want a more out-of-the-box experience. Comes with an AdSense ad placeholder designed right into the theme. Change the entire theme color scheme to any color you like by simply editing the first two CSS lines of the stylesheet. Change #000 to whatever color you like. This theme is clean; valid code, semi minified, no code comments and SEO-friendly. One custom menu and one widgetized sidebar to get you started. Please visit us in the forum for further help: http://tidythemes.com/forum/ - Thank You

Theme URL - http://tidythemes.com/startuppro/
Author URL - http://tidythemes.com/

SVN - http://themes.svn.wordpress.org/startup/1.0
ZIP - http://wordpress.org/extend/themes/download/startup.1.0.zip?nostats=1

All previous tickets for this theme: http://themes.trac.wordpress.org/query?keywords=~theme-startup

https://themes.svn.wordpress.org/startup/1.0/screenshot.png

Attachments (9)

menu.png (8.2 KB) - added by saymar90 2 years ago.
table-layout-test.png (3.6 KB) - added by saymar90 2 years ago.
unordered-list-in-comment.png (3.8 KB) - added by saymar90 2 years ago.
clearing-floats-page.png (33.5 KB) - added by saymar90 2 years ago.
clearing-floats-post.png (49.4 KB) - added by saymar90 2 years ago.
wide-image-not-resized.jpg (222.8 KB) - added by saymar90 2 years ago.
Post-Format-Test-Image-Linked.jpg (204.9 KB) - added by saymar90 2 years ago.
search-and-calendar-widget.png (5.4 KB) - added by saymar90 2 years ago.
pages-widget.png (5.4 KB) - added by saymar90 2 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 saymar902 years ago

  • Owner set to saymar90
  • Status changed from new to assigned

saymar902 years ago

saymar902 years ago

saymar902 years ago

comment:2 saymar902 years ago

Suggest

Not apporoved

Theme Check Recommended

  • Text domain problems in functions.php. You have not included a text domain!
    array( 'main-menu' => __( 'Main Menu' ))
    
  • No reference to add_editor_style() was found in the theme. It is recommended that the theme implement editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.
  • No reference to add_custom_image_header was found in the theme. It is recommended that the theme implement this functionality if using an image for the header.
  • No reference to add_custom_background() was found in the theme. If the theme uses background images or solid colors for the background, then it is recommended that the theme implement this functionality.

Layout

Code Quality

  • Dropdown menu don't work.
  • Error in attachment.php
    Parse error: syntax error, unexpected '(' in ..\wp-content\themes\startup\attachment.php on line 40
    
  • All functions must be prefixed.

My recommendation for next version

  • Can you add in readme.txt, How can a user add an ad banner ?

comment:3 follow-up: tidythemes2 years ago

  • Here's my text domain info:
load_theme_textdomain( 'startup', TEMPLATEPATH . '/languages' );
$locale = get_locale();
$locale_file = TEMPLATEPATH . "/languages/$locale.php";
if ( is_readable($locale_file) )
require_once($locale_file);
function get_page_number() {
if (get_query_var('paged')) {
print ' | ' . __( 'Page ' , 'startup') . get_query_var('paged');
}

Is there a syntax error perhaps? Not sure what the problem is.

  • The free version of the theme does not support dropdown menus. Also, with almost all themes it's up to the user to not overcrowd the menu as it's suppose to fit with the design respectively. So there isn't anything to be done here.
  • Is that mandatory to create a style for tables? I've never heard this. I would prefer to leave plain jane for the user.
  • Unordered list nesting fixed.
  • Clearing floats fixed.
  • Images overflowing fixed.
  • Search widget fixed.
  • Page widget list fixed.
  • Here's my line 40 of attachment.php:
get_post_comments_feed_link()() ) ?>

Not sure what the issue is?

  • I've updated readme.txt to show a reference directly to Startup instructions.

I think that covers it if you can give me any insight on correcting the remaining issues so that I can get 1.1 uploaded.

Thanks

comment:4 in reply to: ↑ 3 saymar902 years ago

Replying to tidythemes:

  • Here's my text domain info:
load_theme_textdomain( 'startup', TEMPLATEPATH . '/languages' );
$locale = get_locale();
$locale_file = TEMPLATEPATH . "/languages/$locale.php";
if ( is_readable($locale_file) )
require_once($locale_file);
function get_page_number() {
if (get_query_var('paged')) {
print ' | ' . __( 'Page ' , 'startup') . get_query_var('paged');
}

Is there a syntax error perhaps? Not sure what the problem is.

The problem is at line 27 in function.php you must use array( 'main-menu' => __( 'Main Menu', 'startup' )) instead of array( 'main-menu' => __( 'Main Menu' ))

  • The free version of the theme does not support dropdown menus. Also, with almost all themes it's up to the user to not overcrowd the menu as it's suppose to fit with the design respectively. So there isn't anything to be done here.

Can you mention it in readme.txt ?

  • Is that mandatory to create a style for tables? I've never heard this. I would prefer to leave plain jane for the user.

it's just a suggestion for making finest tables. You can add some border, padding or ...

  • Here's my line 40 of attachment.php:
get_post_comments_feed_link()() ) ?>

Not sure what the issue is?

Use this: get_post_comments_feed_link() ) ?>

comment:5 tidythemes2 years ago

  • Text domain issue fixed.
  • I never state the theme as dropdown menu supported in the description, nor will the demo in the live WordPress repo indicate a dropdown. The user should never think that there will be a dropdown menu when downloading from WordPress, so saying so would be moot.
  • Okay, I'd prefer not to add table styles then. I'd rather encourage people not to use tables if anything.
  • attachment.php error fixed.

I've uploaded version 1.1 here:

http://themes.trac.wordpress.org/ticket/5824

Thank you very much for all your help.

comment:6 saymar902 years ago

  • Resolution set to closed-newer-version-uploaded
  • Status changed from assigned to closed

comment:7 tidythemes23 months ago

I need this theme deleted out so the name can be freed up for the new theme I've created which is an entirely different project under a different author/WP username.

When I initially created this theme I was unable to get it approved for lack of skills. Not being able to do much about that, it's been long since abandoned.

I've since designed a completely new and unrelated theme (apart from the name I created) that I would very much like to share on the free repo.

I was unable to find a way to delete my theme out of trac myself so I could use some help please.

Thanks

comment:8 tidythemes23 months ago

If there's no way to free up the name please at least hide the theme from trac and other places it may be visible and I'll simply need to append the new project name.

Also, in respect to my rights and privacy I strongly ask that the following topic be deleted:

http://wordpress.org/support/topic/mod-look-need-theme-deleted-out

If neither can be accommodated I sincerely thank you very much for your time and I apologize for any inconvenience.

Thank You

Note: See TracTickets for help on using tickets.