WordPress.org

Make WordPress Themes

#7910 closed theme (closed-newer-version-uploaded)

THEME: Thematic - 1.0

Reported by: iandstewart Owned by: sabreuse
Priority: Keywords: theme-thematic
Cc: ian@…, emhr

Description

Thematic - 1.0

The ultimate in SEO-ready themes, Thematic is a highly extensible, WordPress Theme Framework featuring 13 widget-ready areas, drop-down menus, grid-based layout samples, plugin integration, shortcodes for your footer, &amp; a whole lot more. Perfect for any blog and <strong><em>the</em></strong> starting point for theme development.

Theme URL - http://thematictheme.com
Author URL - http://themeshaper.com/

SVN - http://themes.svn.wordpress.org/thematic/1.0
ZIP - http://wordpress.org/extend/themes/download/thematic.1.0.zip?nostats=1

Diff with previous version: http://themes.trac.wordpress.org/changeset?old_path=/thematic/0.9.7.7&new_path=/thematic/1.0

All previous tickets for this theme: http://themes.trac.wordpress.org/query?col=id&col=summary&col=keywords&col=owner&col=status&col=resolution&keywords=~theme-thematic&order=id

https://themes.svn.wordpress.org/thematic/1.0/screenshot.png

Change History (9)

comment:1 emhr23 months ago

  • Cc emhr added

comment:2 emhr23 months ago

To whomever reviews: First, thanks for taking the time to review. It's much appreciated. Most of what you'll see in the changeset is for the sake of updating Thematic for compliance with theme review guidelines and requirements that have been updated since the last release. The theme options have been updated to use the settings api and for that reason alone we'd like to see this released as soon as we can. If you find anything that blocks approval, let us know and we'll jump on it.

comment:3 sabreuse23 months ago

  • Owner set to sabreuse
  • Status changed from new to assigned

comment:4 sabreuse23 months ago

Thanks for the update! Based on diff + a brief review

This version has one required issue, and a couple of things that you'll need to know about them for future releases:

REQUIRED: add_contextual_help found in the file library/extensions/theme-options.php. Deprecated since version 3.3. Use get_current_screen()->add_help_tab() instead.

And a recommended item:

RECOMMENDED: TEMPLATEPATH was found in the file functions.php. Use get_template_directory() instead. Line 150: define( 'THEMELIB', TEMPLATEPATH . '/library' );

As a heads-up for future versions, you also have a couple of recommended things that are

RECOMMENDED: get_theme_data found in the file functions.php. Deprecated since version 3.4. Use wp_get_theme() instead.

RECOMMENDED: get_current_theme found in the file library/extensions/theme-options.php. Deprecated since version 3.4. Use wp_get_theme() instead.

These are not required at this time, and we won't officially require any changes specific to 3.4 until 30 days after release, but since these are throwing deprecated notices, you will definitely need to fix them at that point.

I'll hold this ticket open for a couple of days; if you can fix the one required item and leave a comment here pointing to the new ticket, I'll pick up the review from there.

comment:5 emhr23 months ago

I sent the latest revision to Ian. Since themes can have only one owner he has to be the one to submit it.

The requirement has been met. Hopefully he'll get to it in soon. If not we'll be happy to go through the queue once more.

Thanks again.

comment:6 sabreuse23 months ago

That works for me - thanks for the comment. I'll be happy to pick up the new version whenever Ian uploads it, just leave a comment here when that happens so I'll get pinged.

comment:9 Frumph23 months ago

  • Resolution set to closed-newer-version-uploaded
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.