WordPress.org

Make WordPress Themes

Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#8637 closed theme (live)

THEME: Victorian Xmas - 5.0

Reported by: esmi Owned by: applextrent
Priority: Keywords: theme-victorian-xmas
Cc: esmi@…

Description

Victorian Xmas - 5.0

A WordPress 3 theme for Christmas. Customised attachment and image templates are included. Sticky post highlighting, post thumbnail support and threaded comments. Folding page and category menus. Support available at http://forum.quirm.net.

Theme URL - http://quirm.net/themes/victorian-xmas/
Author URL - http://blackwidows.co.uk

SVN - http://themes.svn.wordpress.org/victorian-xmas/5.0
ZIP - http://wordpress.org/extend/themes/download/victorian-xmas.5.0.zip?nostats=1

Diff with previous version: http://themes.trac.wordpress.org/changeset?old_path=/victorian-xmas/4.5&new_path=/victorian-xmas/5.0

All previous tickets for this theme: http://themes.trac.wordpress.org/query?col=id&col=summary&col=keywords&col=owner&col=status&col=resolution&keywords=~theme-victorian-xmas&order=id

https://themes.svn.wordpress.org/victorian-xmas/5.0/screenshot.png

Change History (22)

comment:1 esmi21 months ago

WP 3.4 update.

comment:2 applextrent21 months ago

  • Owner set to applextrent
  • Status changed from new to assigned

comment:3 applextrent21 months ago

  • Resolution set to not-approved
  • Status changed from assigned to closed

Review Summary

Image / text wrap alignment issues. http://codex.wordpress.org/Wrapping_Text_Around_Images

"No alignment" option is not displaying properly.

Please install the Theme Unit Test data and make sure everything is displaying in compliance with the theme review guidelines. http://codex.wordpress.org/Theme_Unit_Test

Diff-review only
Ticket being resolved as NOT-APPROVED

comment:4 esmi21 months ago

Can you clarify please? I assume you are referring to the Images Test post in the Theme Unit Test. I've just re-checked that Post in the theme and I cannot see anything wrong in any of it 4 sub-pages.

comment:5 manish_gori21 months ago

I guess he is refering that your image in the no alignment test is failing, when its no-alignment make sure your image is not floating left.

comment:6 esmi21 months ago

But which "no alignment" test? Can you give me a clue?

comment:7 chipbennett21 months ago

  • Resolution not-approved deleted
  • Status changed from closed to reopened

comment:8 greenshady21 months ago

@applextrent, you're not approving this theme based on a single CSS alignment issue? If this is the case, you should approve the theme and ask that the issue be corrected in the next version.

comment:9 chipbennett21 months ago

Reopening this ticket for two reasons:

  1. Please clarify which no-alignment image test (there are four) you see as failing
  2. Even if one of the no-alignment image tests now fails, IMHO that is insufficient cause to not-approve a currently approved Theme. You should either hold the ticket open and ask the developer to fix the issue and re-submit, or resolve the ticket as approved, with the image alignment issue being a required fix in the next revision.

comment:10 follow-up: cyberchimps21 months ago

I did specify which item was not displaying correctly, the "No alignment, no caption" is not displaying correctly. Furthermore, I even linked to codex where the solution is presented which I did as a courtesy.

I have had numerous themes unapproved over the last 2 years for CSS issues, and for not passing the theme unit data properly.

It is an easy fix, and the author can easily correct it and submit a new version of the theme.

I'm sorry but what is the point of the review test data if we are not going to hold theme authors accountable for adhering to it?

The amount of code required to fix the problem shouldn't be subject to whether or not the theme meets the criteria for approval.

comment:11 in reply to: ↑ 10 greenshady21 months ago

Replying to cyberchimps:

I did specify which item was not displaying correctly, the "No alignment, no caption" is not displaying correctly. Furthermore, I even linked to codex where the solution is presented which I did as a courtesy.

The theme author asked for clarification. What do you mean by "not displaying correctly"?

I have had numerous themes unapproved over the last 2 years for CSS issues, and for not passing the theme unit data properly.

For one issue alone? Or, were there multiple issues?

I'm sorry but what is the point of the review test data if we are not going to hold theme authors accountable for adhering to it?

Holding authors accountable for issues is one thing. Nit-picking about a single design issue is another.

The amount of code required to fix the problem shouldn't be subject to whether or not the theme meets the criteria for approval.

No. Whether the issue is critical is the basis for approval.

comment:12 follow-up: applextrent21 months ago

Oops, sorry I replied with my other account by accident.

The no alignment / no caption is not displaying correctly. I don't really know what else to tell you, it is not displaying properly. Did you actually install the theme and actually look at it? It is pretty clear what I'm talking about.

Every other theme on .org that is approved handles no align / no caption properly, please reference them to see what I'm talking about.

It is a requirement to display all theme unit data properly. I do not make the rules.

In the time its taken to write these replies the author could easily fix this issue and resubmit the theme, or at least promise to fix it in their next revision so we can approve this one, but until either of those things happen this ticket is going to remain open.

Thank you.

comment:13 greenshady21 months ago

I'm actually looking at it now. Based on the markup of the post, the text, and image from the theme unit test data, it appears to be displayed as it should be displayed.

comment:14 in reply to: ↑ 12 chipbennett21 months ago

Replying to applextrent:

The no alignment / no caption is not displaying correctly. I don't really know what else to tell you, it is not displaying properly. Did you actually install the theme and actually look at it? It is pretty clear what I'm talking about.

I just installed the Theme, to view the image, no-caption, no-alignment test. It renders just fine for me.

comment:15 follow-up: applextrent21 months ago

http://i.imgur.com/bXPJW.png

Look at it with any other approved theme, and the text is cleared afterwords.

comment:16 in reply to: ↑ 15 ; follow-up: chipbennett21 months ago

Replying to applextrent:

http://i.imgur.com/bXPJW.png

Look at it with any other approved theme, and the text is cleared afterwords.

Text being cleared, or not, either before or after, is not part of the guidelines, and IMHO falls under the design aesthetic as determined by the developer. What is critical with this particular test is ensuring that, when applying left, right, or center alignment, the image behaves accordingly.

comment:17 in reply to: ↑ 16 ; follow-up: applextrent21 months ago

Replying to chipbennett:

Replying to applextrent:

http://i.imgur.com/bXPJW.png

Look at it with any other approved theme, and the text is cleared afterwords.

Text being cleared, or not, either before or after, is not part of the guidelines, and IMHO falls under the design aesthetic as determined by the developer. What is critical with this particular test is ensuring that, when applying left, right, or center alignment, the image behaves accordingly.

Chip - no alignment means the image should NOT align left, right, or center. That image is clearly to the right. Meaning it is incorrect.

comment:18 esmi21 months ago

Replying to applextrent:

http://i.imgur.com/bXPJW.png

Look at it with any other approved theme, and the text is cleared afterwords.

Please understand that I am not objecting to fixing any issues but unless I can see it, I can't fix it. The screenshot you posted above did help tremendously in determining where the issue might be - which is all I was really asking for initially.

Did you actually install the theme and actually look at it?

I think that is really a little unfair. How does one develop or update a theme without installing it, I wonder? I know I couldn't do that. Please do not treat theme developers as your opponents. Sometimes, we are asking questions because we actually want to try & fix the issues you've raised. Can't we just assume that we all want the same thing - a high quality theme - and work together?

That said, I am having real problems replicating this in either Firefox 13 or IE9 on Win 7. I can see a similar issue in Opera 12 but I'm at a loss as to how to deal with it. The CSS is perfectly valid (once you rule out the complaints over browser specific border radii). I'm also not able to test locally via Safari at the moment.

Can I ask what browser you are using? It's possible we're seeing a browser-specific issue here.

comment:19 in reply to: ↑ 17 chipbennett21 months ago

Replying to applextrent:

Replying to chipbennett:

Chip - no alignment means the image should NOT align left, right, or center. That image is clearly to the right. Meaning it is incorrect.

No alignment is being applied to that image. It is simply being rendered immediately after the preceding text.

Change the screen horizontal resolution and you will see that the image has no alignment property being assigned. It is simply rendering inline with the text.

comment:20 applextrent21 months ago

  • Resolution set to approved
  • Status changed from reopened to closed

Hi Esmi,

No worries, I am simply trying to help and review the theme. I am trying to follow the guidelines, and I saw that the alignment was off, thats why I linked to the codex to show you how to fix it.

With this said, this is a very minor issue, but it is still needs to be addressed.

I wish there was a better name for what we're talking about, but "no alignment" is what this is called. I don't really know what else to call it other than what it is.

Anyhow, yes this is happening in Safari, and in Chrome. It is actually a browser width issue. If you condense the browser is pushes the image to the left, if you make it wider it pushes it to the right. This is likely happening since you don't have any styling defined.

I apologize if this was confusing, I just simply saw that it was rendering to the right since my browser window was wider. Anyhow a lot of theme authors actually clear the image so that it is on its own line so this doesn't happen. That way the image inherits the alignment of the text on its own line without having any direct styling applied to it. Which is why most people use the no-alignment option so their images inherit the text alignment.

Sorry I thought this was a different issue, this is just a recommendation at this point.

I'm resolving as approved.

comment:21 esmi21 months ago

I don't really know what else to call it other than what it is.
Speaking purely from a theme dev's pov, perhaps something like "Checkout the Images Test post - sub-page 1: No alignment, no caption" might help in these situations? Messy, I know but I can't think of a better way in the absence of screenshots.

a lot of theme authors actually clear the image so that it is on its own line so this doesn't happen.
That's a good point. I've always tended to assume that 'alignone' meant 'Hands off - let the browser do its own thing' but perhaps I'm in the wrong here? Maybe it should be styled? I had a quick look to see how Twenty Eleven handles that class (not exactly the ideal example, I know) and it seems to be making the same assumption that I do.

Maybe the theme review team & the review guidelines could offer some guidance here? I'll post to the list and see what people think.

comment:22 nacin21 months ago

For a future update of this theme: The screenshot has "WordPress" spelled incorrectly.

Note: See TracTickets for help on using tickets.