WordPress.org

Make WordPress Themes

#9353 closed theme (closed-newer-version-uploaded)

THEME: Montezuma - 1.1.2

Reported by: BytesForAll Owned by: garinungkadol
Priority: Keywords: theme-montezuma
Cc: lmmmuc@…

Description

Montezuma - 1.1.2

Montezuma is a responsive, customizable and search engine optimized HTML5 / CSS3 theme. Choose between responsive, flexible and static layouts. Edit or create new page templates online, without FTP uploads. Add custom widget areas everywhere. Slideshow for standard WP galleries, auto post thumbs, advanced excerpts, Google fonts, transparent color picker, import/export settings and more. This is the second theme from the author of the popular "Atahualpa" theme. Active community at forum.bytesforall.com.

Theme URL - http://wordpress.bytesforall.com/wordpress-themes/montezuma/
Author URL - http://wordpress.bytesforall.com/

SVN - http://themes.svn.wordpress.org/montezuma/1.1.2
ZIP - http://wordpress.org/extend/themes/download/montezuma.1.1.2.zip?nostats=1

Diff with previous version: http://themes.trac.wordpress.org/changeset?old_path=/montezuma/1.1.1&new_path=/montezuma/1.1.2

All previous tickets for this theme: http://themes.trac.wordpress.org/query?col=id&col=summary&col=keywords&col=owner&col=status&col=resolution&keywords=~theme-montezuma&order=id

https://themes.svn.wordpress.org/montezuma/1.1.2/screenshot.png

Attachments (3)

top-menu.jpg (20.3 KB) - added by garinungkadol 20 months ago.
unordered-lists.jpg (27.8 KB) - added by garinungkadol 20 months ago.
wp-link-pages.jpg (20.9 KB) - added by garinungkadol 20 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 BytesForAll20 months ago

This 1.1.2 is the most current version. Please review this one.

This is fairly well tested, if you find showstopper issues please leave the ticket open and give me a day to fix them.

Last edited 20 months ago by BytesForAll (previous) (diff)

comment:2 garinungkadol20 months ago

  • Owner set to garinungkadol
  • Status changed from new to assigned

garinungkadol20 months ago

comment:3 garinungkadol20 months ago

Hi Flynn,

These are the things I've noticed while checking your theme:

Theme Unit Tests

Single Post View

Navigation Menu

  • REQUIRED: When menu items exceed one line, menu content gets cut off and it becomes difficult to hover over child links. See top-menu.jpg. My recommendation would be to include a note in your readme.txt encouraging users to limit their links to one line.

Functionality

* REQUIRED: Since you are supporting color selection for backgrounds you must implement Custom Backgrounds via add_theme_support('custom-background')
Not an issue. See comments below.

  • Text entered in the "Custom text or HTML right before the comment form text area" only shows up for non-logged in visitors. Is this the intention?

Code Quality

  • REQUIRED: If supporting translation/internationalization, all public-facing text must be localized.
    • In the "includes" folder see admin.php, breadcrumbs.php, get_whitelist.php, not-found.php, widget_meta.php
    • In the "admin\default-templates\sub-templates" folder see footer.php,
    • All files in the "admin\options" folder
    • functions.php: bfa_read_more_link().
  • REQUIRED: Be consistent in your use of textdomain. I see both 'montezuma-backend' and 'montezuma' use a the textdomain.

As per your request, I'll keep this ticket open a day or two.

Last edited 20 months ago by garinungkadol (previous) (diff)

comment:4 follow-up: BytesForAll20 months ago

Hi Vix,

thanks for the review & the screenshots.

I uploaded a fixed version here: http://themes.trac.wordpress.org/ticket/9378

With these changes:

Single Post View:

  • Added/edited styles for UL/OL/DL/Table/PRE and applied it to comments, too. There was also a broken image link due to a typo. See _changelog.txt for details
  • The output was not intended to be like that. Replaced bfa_link_pages() with wp_link_pages() in /admin/default-templates/main-templates/single.php and page.php.

Navigation Menu:

  • Added note on top of readme.txt

Custom Backgrounds:

  • Theme doesn't have custom backgrounds. You may have mistaken the 2 color pickers for that? Users can manually edit the CSS, but there is no specific support for background color. The color pickers are just global helpers to find the right RGB or HSAL values for any CSS, they are not tied to any specific CSS selector or page element.
  • Custom text before comment form. This uses the "comment_notes_before" and "comment_notes_after" parameters of the WP function "comment_form()" so it is indeed intended behavior. I added some text to the corresponding section in the admin area to make this clearer for users.

Translation:

  • My understanding is that public facing text means the web site front end and does not include the admin area. I did not intend to make the admin area translation ready for now (even though it seemed so because small parts of the admin were translation ready).
  • Added missing textdomains to public facing text, in functions.php, not_found.php, footer.php and breadcrumbs.php.
  • REMOVED textdomain from admin area text, in /includes/widget_meta.php.
  • Removed textdomain 'montezuma-backend', from /includes/meta_box_template.php
  • Re-created /languages/montezuma.pot
Last edited 20 months ago by BytesForAll (previous) (diff)

comment:5 in reply to: ↑ 4 garinungkadol20 months ago

Replying to BytesForAll:

Custom Backgrounds:

  • Theme doesn't have custom backgrounds. You may have mistaken the 2 color pickers for that? Users can manually edit the CSS, but there is no specific support for background color. The color pickers are just global helpers to find the right RGB or HSAL values for any CSS, they are not tied to any specific CSS selector or page element.


Okay. That's fine. I'll strike that from the review.

Translation:

  • My understanding is that public facing text means the web site front end and does not include the admin area. I did not intend to make the admin area translation ready for now (even though it seemed so because small parts of the admin were translation ready).


My understanding is that "public facing text" is all text the user will see but I'll get a clarification on this. Consider this a pass for now.

I'll re-check your next ticket.
Thanks

comment:6 garinungkadol20 months ago

  • Resolution set to closed-newer-version-uploaded
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.