WordPress.org

Make WordPress Themes

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9410 closed theme (not-approved)

THEME: Dragonfly - 0.1.0

Reported by: fmarchan Owned by: slobodanmanic
Priority: Keywords: theme-dragonfly
Cc: fnonemaker@…

Description

Dragonfly - 0.1.0

Dragonfly is a mobile-first responsive WordPress theme. That means it has a special layout and style just for mobile, and automatically adjusts to an appropriate look depending on the screen size and device used. My goal was to make a fast, responsive and stylish theme aimed at mobile devices that would still look great on a large screen.

Theme URL - http://
Author URL - http://flarnie.com/

SVN - http://themes.svn.wordpress.org/dragonfly/0.1.0
ZIP - http://wordpress.org/extend/themes/download/dragonfly.0.1.0.zip?nostats=1

All previous tickets for this theme: http://themes.trac.wordpress.org/query?keywords=~theme-dragonfly

https://themes.svn.wordpress.org/dragonfly/0.1.0/screenshot.png

Change History (4)

#1 @emiluzelac
5 years ago

  • Owner set to peterbeno
  • Status changed from new to assigned

#2 @emiluzelac
5 years ago

  • Owner changed from peterbeno to slobodanmanic

#3 @slobodanmanic
5 years ago

  • Resolution set to not-approved
  • Status changed from assigned to closed
  • Activating the theme produces PHP Warning - Warning: Cannot modify header information - headers already sent by (output started at /Users/slobodanmanic/Work/WPTRT/wp-content/themes/dragonfly/functions.php:123) in /Users/slobodanmanic/Work/WPTRT/wp-includes/option.php on line 563
  • Deactivating the theme produces a blank screen with a PHP warning - Warning: Cannot modify header information - headers already sent by (output started at /Users/slobodanmanic/Work/WPTRT/wp-content/themes/dragonfly/functions.php:123) in /Users/slobodanmanic/Work/WPTRT/wp-includes/pluggable.php on line 881
  • Both are caused by empty lines after PHP closing tag in functions.php
  • Hardcoded link in footer.php (http://flarnie.com/dragonfly-wp-theme/)

header.php

  • Hardcoded feed links (posts and comments)
  • Several wp_enqueue_script calls from header.php (question for a senior reviewer - is this allowed? Shouldn't it be done from functions.php?)
  • Several hardcoded meta tags - (HandheldFriendly, MobileOptimized, cleartype, viewport)

Theme Settings page

  • Saving theme settings returns blank screen with a PHP warning - Warning: Cannot modify header information - headers already sent by (output started at /Work/WPTRT/wp-content/themes/dragonfly/functions.php:123) in /home/naput0/public_html/dev/latest/wrdp/wp-includes/pluggable.php on line 881 - when closing tag and empty lines at the end of functions.php are removed that error is gone

Misc.

  • No 'comment_reply' script

I think if the problem with functions.php is fixed, some more issues may arise, but everything I've ran into seems like it could be fixed easily. And sorry I wasn't able to do this review a few days sooner.

#4 @fmarchan
5 years ago

Thank you so much for finding these issues! I have removed the hardcoded linkes and metatags (except 2 meta tags neccessary for rendering the mobile styles), and fixed the issue with functions.php. I also put the script calls into functions.php, and uploaded the newest version of the theme here ( http://themes.trac.wordpress.org/ticket/9911 ).
Thanks again! : )

Last edited 5 years ago by fmarchan (previous) (diff)
Note: See TracTickets for help on using tickets.