WordPress.org

Make WordPress Themes

#9666 closed theme (closed-newer-version-uploaded)

THEME: San Francisco - 1.0.7

Reported by: Nu Studio Owned by: garinungkadol
Priority: Keywords: theme-san-francisco
Cc: steve@…

Description

San Francisco - 1.0.7

A free SEO and Mobile Optimised WordPress Theme. This theme automatically resizes and realigns itself to fit to any screen width. Beautiful when viewing on a mobile device (iPod, iPad, Android etc) with a smaller screen or on a large desktop screen.

Theme URL -
Author URL - http://www.nustudio.com.au

SVN - http://themes.svn.wordpress.org/san-francisco/1.0.7
ZIP - http://wordpress.org/extend/themes/download/san-francisco.1.0.7.zip?nostats=1

Diff with previous version: http://themes.trac.wordpress.org/changeset?old_path=/san-francisco/1.0.6&new_path=/san-francisco/1.0.7

All previous tickets for this theme: http://themes.trac.wordpress.org/query?col=id&col=summary&col=keywords&col=owner&col=status&col=resolution&keywords=~theme-san-francisco&order=id

https://themes.svn.wordpress.org/san-francisco/1.0.7/screenshot.png

Change History (12)

comment:1 garinungkadol19 months ago

  • Owner set to garinungkadol
  • Status changed from new to assigned

comment:2 garinungkadol19 months ago

  • No outstanding issues from previous review
  • Performed a diff review - no major changes
  • Checked on license of header image - This is licensed under CC BY 2.0 which is incompatible with GPL :(

I'll keep the ticket open for a few days so that you can make the necessary changes. Remember to include the relevant licensing information of all bundled resources.

~ Vicky

comment:3 follow-up: Nu Studio18 months ago

Can I just put a link to http://creativecommons.org/licenses/by/2.0/legalcode in license.txt?

Or can I copy and paste the license from that URL and place in a license-images.txt file?

Or something else?

comment:4 in reply to: ↑ 3 garinungkadol18 months ago

Replying to Nu Studio:

Can I just put a link to http://creativecommons.org/licenses/by/2.0/legalcode in license.txt?


As per guidelines:

Themes are required to be 100% GPL-licensed, or use a GPL-compatible license. This includes all PHP, HTML, CSS, images, fonts, icons, and everything else. All of the theme must be GPL-Compatible.

You have two options:
(1) Contact the owner of the image and ask if the image can be licensed under GPL v2 or CC-0 (public domain)
or
(2) Find another image with a license that is GPL-compatible.

comment:5 Nu Studio18 months ago

Just checking with the photographer now. Thanks

comment:6 garinungkadol18 months ago

Have you heard back from the photographer or are you intending to change the image?

comment:7 Nu Studio18 months ago

I am still waiting to hear back. I will be in touch as soon as possible. Thanks

comment:8 Nu Studio18 months ago

From the photographer - "If you abide by the attribution requirement in CC-BY you can use it for whatever."

Since I have attributed him in both readme.txt and style.css I believe this requirement is met.

Please go ahead and make this theme version live.

Thanks

comment:9 Otto4218 months ago

Not good enough, unfortunately. CC-BY 2.0 is not GPL-Compatible, whether the author states it's okay or not.

We require that all files in the theme be available under a GPL-Compatible license. This file isn't available as such, therefore it cannot be in our repository. The author would have to make it available under a different license, one that is GPL-Compatible.

comment:10 Nu Studio18 months ago

Forgive me, but I am confused. The author says I can use it for whatever I like as long as I put a link back to him. Therefore he is essentially giving me the image to do with what I like. Why can I not release this under GPL? If there's a problem beyond this, I will just remove the image from the theme.

If you know of a GPL compatible image library please feel free to lead me in the right direction.

Thanks.

comment:11 Otto4218 months ago

The problem is that the author said that while also basically stating that you have to abide by the requirements in CC-BY. CC-BY isn't compatible with the GPL, for various and assorted reasons.

As to why you can't release it under the GPL, it's not your work. You can't re-license somebody else's work, because copyright simply doesn't work that way.

The short of it is that you'd have to remove the image and use another one which has more compatible licensing, or get the author to state that the license for it is another one which is GPL-Compatible. See, while he may have told you that you can use it for whatever you want, without a proper license declaration, there's no guarantee that he won't hold others to different terms. We require the terms (license) to be clear and well-defined. A statement of intent in an email just isn't good enough.

Note that unlike some other projects, we only require GPL-Compatible licensing, not necessarily the GPL itself. Unfortunately, no Creative-Commons license is GPL-Compatible, with the exception of "CC0" which is basically identical to "public domain".

comment:12 chipbennett18 months ago

  • Resolution set to closed-newer-version-uploaded
  • Status changed from assigned to closed
Last edited 18 months ago by Otto42 (previous) (diff)
Note: See TracTickets for help on using tickets.